Package Details: kcm-qt-graphicssystem 1.3-2

Git Clone URL: https://aur.archlinux.org/kcm-qt-graphicssystem.git (read-only)
Package Base: kcm-qt-graphicssystem
Description: This KCM allows you to easily configure the standard Qt graphics system.
Upstream URL: http://kde-apps.org/content/show.php?content=129817
Licenses: GPL
Submitter: daimonion
Maintainer: None
Last Packager: fettouhi
Votes: 120
Popularity: 0.580815
First Submitted: 2010-09-06 15:24
Last Updated: 2015-06-08 19:38

Latest Comments

fettouhi commented on 2015-12-24 21:46

Disowning this package because I switched to Plasma 5.

g99 commented on 2015-12-24 21:43

WARNING! kcm kills X! Windows will appear black, e.g. on intel graphics driver.

This trivial KCM sets 1 of 3 options in
/home/YOU/.kde4/env/qt-graphicssystem.sh

The bottommost "OpenGL" will kill a current (2016) X Desktop.

sourcecode:
scriptFile->write("export QT_GRAPHICSSYSTEM=opengl");

traceback when your X is destroyed:


find -D rates ~ -name * -print | xargs cat | grep QT_GRAPHICS

Predicate success rates after completion:
-name qt-graphicssystem.sh [0.1] [1/1311] -a [0.1] [1/131] -print [1] [1/1=1]
export QT_GRAPHICSSYSTEM=raster

find ~ -name qt-graphicssystem.sh

/home/YOU/.kde4/env/qt-graphicssystem.sh


To recover, edit the file qt-graphicssystem.sh

or operate the KCM blindly with ALT-x ALT-o (for OK) to goto default X-render mode. I do not like this underdocumented silly KCM which is not even listed by
kcmshell5 --list

because it is kcmshell4


fettouhi commented on 2013-12-06 20:04

I just tested the PKGBUILD and the package build fine for me. Here's the output

==> Starter build()...
-- The C compiler identification is GNU 4.8.2
-- The CXX compiler identification is GNU 4.8.2
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found
-- Found Qt4: /usr/bin/qmake-qt4 (found suitable version "4.8.5", minimum required is "4.7.0")
-- Found Qt-Version 4.8.5 (using /usr/bin/qmake-qt4)
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib64/libX11.so
-- Looking for include file pthread.h
-- Looking for include file pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE
-- Found OpenSSL: /usr/lib64/libssl.so;/usr/lib64/libcrypto.so (found version "1.0.1e")
-- Looking for _POSIX_TIMERS
-- Looking for _POSIX_TIMERS - found
-- Found Automoc4: /usr/bin/automoc4
-- Found Perl: /usr/bin/perl (found version "5.18.1")
-- Found Phonon: /usr/include/qt4 (Required is at least version "4.3.80")
-- Performing Test _OFFT_IS_64BIT
-- Performing Test _OFFT_IS_64BIT - Success
-- Performing Test HAVE_FPIE_SUPPORT
-- Performing Test HAVE_FPIE_SUPPORT - Success
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success
-- Performing Test __KDE_HAVE_GCC_VISIBILITY
-- Performing Test __KDE_HAVE_GCC_VISIBILITY - Success
-- Found KDE 4.11 include dir: /usr/include
-- Found KDE 4.11 library dir: /usr/lib
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
-- Building prober application.
-- Configuring done
-- Generating done
-- Build files have been written to: /home/af/kcm-qt-graphicssystem/src/kcm-qt-graphicssystem-1.3
[ 8%] [ 16%] Generating __/moc_EngineProbe.cxx
Scanning dependencies of target kcm_qt_graphicssystem_automoc
Generating moc_Prober.cxx
Generating moc_Module.cpp
Scanning dependencies of target qt-graphicssystem-prober
Generating moc_EngineProbe.cpp
[ 16%] Built target kcm_qt_graphicssystem_automoc
[ 25%] Generating ui_Module.h
Scanning dependencies of target kcm_qt_graphicssystem
[ 33%] [ 50%] [ 50%] [ 58%] [ 66%] Building CXX object src/prober/CMakeFiles/qt-graphicssystem-prober.dir/main.o
Building CXX object src/prober/CMakeFiles/qt-graphicssystem-prober.dir/Prober.o
Building CXX object src/prober/CMakeFiles/qt-graphicssystem-prober.dir/__/EngineProbe.o
Building CXX object src/prober/CMakeFiles/qt-graphicssystem-prober.dir/__/moc_EngineProbe.o
Building CXX object src/prober/CMakeFiles/qt-graphicssystem-prober.dir/moc_Prober.o
[ 75%] [ 83%] [ 91%] [100%] Building CXX object src/CMakeFiles/kcm_qt_graphicssystem.dir/EngineProbe.o
Building CXX object src/CMakeFiles/kcm_qt_graphicssystem.dir/main.o
Building CXX object src/CMakeFiles/kcm_qt_graphicssystem.dir/kcm_qt_graphicssystem_automoc.o
Building CXX object src/CMakeFiles/kcm_qt_graphicssystem.dir/Module.o
Linking CXX executable qt-graphicssystem-prober
[100%] Built target qt-graphicssystem-prober
Linking CXX shared module ../lib/kcm_qt_graphicssystem.so
[100%] Built target kcm_qt_graphicssystem
==> Indtræder i fakeroot miljø...
==> Starter package()...
Generating moc_Module.cpp
[ 58%] Built target qt-graphicssystem-prober
Generating moc_EngineProbe.cpp
[ 58%] Built target kcm_qt_graphicssystem_automoc
Scanning dependencies of target kcm_qt_graphicssystem
[ 66%] Building CXX object src/CMakeFiles/kcm_qt_graphicssystem.dir/kcm_qt_graphicssystem_automoc.o
Linking CXX shared module ../lib/kcm_qt_graphicssystem.so
[100%] Built target kcm_qt_graphicssystem
Install the project...
-- Install configuration: "Release"
-- Installing: /home/af/kcm-qt-graphicssystem/pkg/kcm-qt-graphicssystem/usr/lib/kde4/kcm_qt_graphicssystem.so
-- Installing: /home/af/kcm-qt-graphicssystem/pkg/kcm-qt-graphicssystem/usr/share/kde4/services/qt-graphicssystem.desktop
-- Installing: /home/af/kcm-qt-graphicssystem/pkg/kcm-qt-graphicssystem/usr/bin/qt-graphicssystem-prober

alice commented on 2013-12-06 18:54

==> Starting build()...
-- The C compiler identification is GNU 4.8.2
-- The CXX compiler identification is GNU 4.8.2
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found
CMake Error at /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:108 (message):
Could NOT find Qt4 (missing: QT_MOC_EXECUTABLE QT_RCC_EXECUTABLE
QT_UIC_EXECUTABLE) (found suitable version "4.8.5", minimum required is
"4.7.0")
Call Stack (most recent call first):
/usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:315 (_FPHSA_FAILURE_MESSAGE)
/usr/share/cmake-2.8/Modules/FindQt4.cmake:1393 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
CMakeLists.txt:15 (find_package)


CMake Warning (dev) in CMakeLists.txt:
No cmake_minimum_required command is present. A line of code such as

cmake_minimum_required(VERSION 2.8)

should be added at the top of the file. The version specified may be lower
if you wish to support older CMake versions for this project. For more
information run "cmake --help-policy CMP0000".
This warning is for project developers. Use -Wno-dev to suppress it.

-- Configuring incomplete, errors occurred!
See also "/tmp/yaourt-tmp-alice/aur-kcm-qt-graphicssystem/src/kcm-qt-graphicssystem-1.3/CMakeFiles/CMakeOutput.log".
See also "/tmp/yaourt-tmp-alice/aur-kcm-qt-graphicssystem/src/kcm-qt-graphicssystem-1.3/CMakeFiles/CMakeError.log".
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build kcm-qt-graphicssystem.
==> Restart building kcm-qt-graphicssystem ? [y/N]
==> -----------

fettouhi commented on 2013-04-10 07:03

Adopted and updated.

daimonion commented on 2013-04-09 13:41

Disowned. Apologize for the delay.

fettouhi commented on 2013-04-09 13:27

Might we see an update of this? If not then please disown so someone else can take it over.

mtorromeo commented on 2013-03-01 17:26

qt can be removed altogether since it is already a dependency of kdelibs

felixonmars commented on 2013-02-28 02:29

Please replace `qt` with `qt4` from the depends array. (and maybe also the pkgname if only qt4 could be configured using this?)
There's no more a 'qt' package in [testing] (and in the next days in [extra])

einseenai commented on 2012-12-06 09:52

Doesn't build for me, using latest KDE 4.9.4 - http://pastebin.com/iirHANEZ

All comments