Package Details: kcm-ufw 0.4.3-4

Git Clone URL: https://aur.archlinux.org/kcm-ufw.git (read-only)
Package Base: kcm-ufw
Description: KDE4 control module for UFW (Uncomplicated Firewall)
Upstream URL: http://kde-apps.org/content/show.php/UFW+KControl+Module?content=137789
Keywords: kcm kde ufw
Licenses: GPL
Submitter: adaptee
Maintainer: None
Last Packager: FadeMind
Votes: 99
Popularity: 0.000101
First Submitted: 2011-02-25 06:28
Last Updated: 2015-12-02 07:00

Latest Comments

1 2 3 4 5 6 ... Next › Last »

nfs commented on 2018-05-02 21:06

@avalar

I completely understand, and it's probably for the best that you officially orphan the package.

My experience with linux is less than 2 years now, and I don't know anything about creating packages. I will read up on it.

Even if that confirms my suspicion that I'm nowhere near ready to maintain a package, it may help me when installing one doesn't work without editing the PKGBUILD.

The unfortunate thing is that gufw isn't working now either, so there's no gui solution for managing UFW available in Arch. I've worked around it by creating a desktop file that calls "sudo ufw status verbose" using a custom profile for konsole. This tells me what I need to know for the most part.

ava1ar commented on 2018-05-02 00:37

nfs,

I am not using it anymore, so orphaning it now - feel free to pickup and make it working. There is no t much sense anyway - this is for KDE4 and won't be visible in KDE5 control center. This need to be migrated to kde5, which is not that easy.

nfs commented on 2018-05-01 22:04

Apparently, the same problem has existed for more than 6 months now:

   make[2]: *** [kcm/CMakeFiles/kcm_ufw.dir/build.make:95: kcm/CMakeFiles/kcm_ufw.dir/kcm.cpp.o] Error 1
   make[1]: *** [CMakeFiles/Makefile2:246: kcm/CMakeFiles/kcm_ufw.dir/all] Error 2
   make: *** [Makefile:152: all] Error 2
   ==> ERROR: A failure occurred in build().
       Aborting...
   :: Unable to build kcm-ufw - makepkg exited with code: 2

Now that I see that the package hasn't been updated since 2015, it's not too surprising. Hopefully someone more responsive will take this over.

OdinEidolon commented on 2018-03-04 20:07

I also cannot build this due to the same problem yulert reported.

yulert commented on 2017-09-17 10:04

I don't seem to be able to build the package.

A series of errors occur.

error: conflicting declaration of C function ‘bool operator!=(const QStringRef&, const char*)’ --> occurs multiple times then

make[2]: *** [kcm/CMakeFiles/kcm_ufw.dir/build.make:95: kcm/CMakeFiles/kcm_ufw.dir/kcm.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:246: kcm/CMakeFiles/kcm_ufw.dir/all] Error 2
make: *** [Makefile:152: all] Error 2
==> ERROR: A failure occurred in build().
Aborting...
:: failed to build kcm-ufw package(s)

Any ideas on how to resolve the issue?





wchouser3 commented on 2017-03-20 17:00

@hepha,
how about a pkgbuild for that. I'd like to try it

hepha commented on 2016-07-02 04:41

hello
this is new
KDE QuickGit :: ufw-kde.git/summary - https://quickgit.kde.org/?p=ufw-kde.git&l=en_US

ava1ar commented on 2016-03-03 03:06

@Aventura5
Since kcm-ufw is KDE4 module, you won't find it in the GUI - to start it, just run the command:
kcmshell4 ufw

Aventura5 commented on 2016-03-02 15:47

I just installed it successfully but it doesn't show up in the app menu and I can't find a command to run it.

youngunix commented on 2015-10-02 08:17

The git link above doesn't seem to work (happens with all packages as far as I can tell), but you can access the PKGBUILD from here https://aur.archlinux.org/cgit/aur.git/tree/?h=kcm-ufw. I've created a git repo on GitHub if you want to add it as a git url for cloning: https://github.com/youngunix/kcm-ufw.git.