Package Details: kcm-wacomtablet-git 1:585.4c1006a-1

Git Clone URL: https://aur.archlinux.org/kcm-wacomtablet-git.git (read-only)
Package Base: kcm-wacomtablet-git
Description: KDE GUI for the Wacom Linux Drivers
Upstream URL: https://www.linux-apps.com/p/1127862/
Licenses: GPL
Conflicts: kcm-wacomtablet
Provides: kcm-wacomtablet
Replaces: kcm-wacomtablet-frameworks-git
Submitter: stativ
Maintainer: stativ
Last Packager: stativ
Votes: 24
Popularity: 0.227321
First Submitted: 2018-02-03 19:46
Last Updated: 2018-02-03 19:46

Pinned Comments

stativ commented on 2018-02-03 20:01

This package is a development version of wacomtablet KCM with support for KDE Frameworks 5.

The current version of kcm-wacomtablet package also supports KF5, so this package is no longer required under modern KDE desktop unless you want to keep up to date with the latest development.

Latest Comments

stativ commented on 2018-04-13 20:37

The package builds fine on all my systems and in a clean chroot. Maybe it was just a temporary breakage – which can happen anytime, since it is a development version.

Also, the kcm-wacomtablet-frameworks-git package you used builds from a branch that is way older than what the kcm-wacomtablet in [community] provides.

mistical2008 commented on 2018-04-13 08:13

I have success with compile. I've just tried that PKGBUILD: https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=kcm-wacomtablet-frameworks-git

mistical2008 commented on 2018-04-13 07:59

I have a compilation error in build():

Scanning dependencies of target kded_wacomtablet_lib_autogen [ 36%] Automatic MOC for target kded_wacomtablet_lib AutoMoc warning: "/home/evgeniy/Документы/02_linux_projects/wacomtablet/src/kded/tabletdaemon.cpp" Could not find dependency file "wacomtablet.json"

AutoMoc subprocess error

moc failed for "/home/evgeniy/Документы/02_linux_projects/wacomtablet/src/kded/tabletdaemon.cpp"

Command

/usr/bin/moc -I/home/evgeniy/Документы/02_linux_projects/wacomtablet/build/src/kded -I/home/evgeniy/Документы/02_linux_projects/wacomtablet/build/src/kded/kded_wacomtablet_lib_autogen/include -I/home/evgeniy/Документы/02_linux_projects/wacomtablet/build/src/common -I/home/evgeniy/Документы/02_linux_projects/wacomtablet/src/kded -I/home/evgeniy/Документы/02_linux_projects/wacomtablet/src/common -I/usr/include/libwacom-1.0 -I/usr/include/qt -I/usr/include/qt/QtCore -I/usr/lib/qt/mkspecs/linux-g++ -I/usr/include/qt/QtGui -I/usr/include/qt/QtWidgets -I/usr/include/qt/QtX11Extras -I/usr/include/KF5/KI18n -I/usr/include/KF5 -I/usr/include/KF5/KGlobalAccel -I/usr/include/qt/QtDBus -I/usr/include/KF5/KConfigCore -I/usr/include/KF5/KCoreAddons -I/usr/include/KF5/KNotifications -I/usr/include/KF5/KXmlGui -I/usr/include/qt/QtXml -I/usr/include/KF5/KConfigWidgets -I/usr/include/KF5/KCodecs -I/usr/include/KF5/KWidgetsAddons -I/usr/include/KF5/KConfigGui -I/usr/include/KF5/KAuth -I/usr/include/KF5/KDBusAddons -I/usr/include -DHAVE_XCB_XINPUT -DKCOREADDONS_LIB -DQT_CORE_LIB -DQT_DBUS_LIB -DQT_GUI_LIB -DQT_NO_CAST_FROM_ASCII -DQT_NO_CAST_TO_ASCII -DQT_NO_DEBUG -DQT_STRICT_ITERATORS -DQT_USE_FAST_CONCATENATION -DQT_USE_FAST_OPERATOR_PLUS -DQT_WIDGETS_LIB -DQT_X11EXTRAS_LIB -DQT_XML_LIB "-DTRANSLATION_DOMAIN=\"wacomtablet\"" -D_GNU_SOURCE -D_LARGEFILE64_SOURCE --include /home/evgeniy/Документы/02_linux_projects/wacomtablet/build/src/kded/kded_wacomtablet_lib_autogen/moc_predefs.h -o /home/evgeniy/Документы/02_linux_projects/wacomtablet/build/src/kded/kded_wacomtablet_lib_autogen/include/tabletdaemon.moc /home/evgeniy/Документы/02_linux_projects/wacomtablet/src/kded/tabletdaemon.cpp

Output

/home/evgeniy/Документы/02_linux_projects/wacomtablet/src/kded/tabletdaemon.cpp:47: Error: Plugin Metadata file "wacomtablet.json" does not exist. Declaration will be ignored

make[2]: [src/kded/CMakeFiles/kded_wacomtablet_lib_autogen.dir/build.make:58: src/kded/CMakeFiles/kded_wacomtablet_lib_autogen] Ошибка 1 make[1]: [CMakeFiles/Makefile2:1064: src/kded/CMakeFiles/kded_wacomtablet_lib_autogen.dir/all] Ошибка 2 make: *** [Makefile:141: all] Ошибка 2

I also tried to install on a fresh system in a virtual machine and compiling from source and the same error emerged. Qt version 5.10

stativ commented on 2018-02-03 20:01

This package is a development version of wacomtablet KCM with support for KDE Frameworks 5.

The current version of kcm-wacomtablet package also supports KF5, so this package is no longer required under modern KDE desktop unless you want to keep up to date with the latest development.

elvisvinicius commented on 2017-06-06 22:33

It is working wonderfully. :) Thank you!

opensw commented on 2016-12-02 09:03

It is working wonderfully, thank you for your effort

Anonymous comment on 2016-07-08 01:34

Upstream URL is broken.

Danyright commented on 2016-01-29 12:20

Ok, it does build fine now.
Thanks :-)

stativ commented on 2016-01-20 20:50

It builds fine on my machine and in a clean chroot. The missing files are from docbook-xsl, but that is a kdoctools dependency. Maybe it was a bug in docbook-xsl?

Danyright commented on 2016-01-13 11:14

The build fails - it seems that it can't parse index.docbook :

I/O warning : failed to load external entity "/usr/share/xml/docbook/xsl-stylesheets-1.78.1/html/autoidx.xsl"
compilation error: file /usr/share/kf5/kdoctools/customization/kde-include-common.xsl line 4 element import
xsl:import : unable to load /usr/share/xml/docbook/xsl-stylesheets-1.78.1/html/autoidx.xsl
I/O warning : failed to load external entity "/usr/share/xml/docbook/xsl-stylesheets-1.78.1/html/chunk.xsl"
compilation error: file /usr/share/kf5/kdoctools/customization/kde-include-common.xsl line 5 element import
xsl:import : unable to load /usr/share/xml/docbook/xsl-stylesheets-1.78.1/html/chunk.xsl
Error: Unable to parse "index.docbook"
doc/user/CMakeFiles/doc-user-index-cache-bz2.dir/build.make:61: recipe for target 'doc/user/index.cache.bz2' failed
make[2]: *** [doc/user/index.cache.bz2] Error 1
CMakeFiles/Makefile2:739: recipe for target 'doc/user/CMakeFiles/doc-user-index-cache-bz2.dir/all' failed
make[1]: *** [doc/user/CMakeFiles/doc-user-index-cache-bz2.dir/all] Error 2

Do you know if it's because of the package or the source code ?
Thanks, Daniel

All comments