Package Details: kdenlive-git 16.07.70.r7617.ad250f4-1

Git Clone URL: https://aur.archlinux.org/kdenlive-git.git (read-only)
Package Base: kdenlive-git
Description: A non-linear video editor for Linux using the MLT video framework. KF5 Frameworks (Latest Applications GIT Version)
Upstream URL: http://www.kdenlive.org/
Licenses: GPL
Conflicts: kdenlive
Provides: kdenlive
Submitter: nous
Maintainer: evorster
Last Packager: evorster
Votes: 63
Popularity: 1.965631
First Submitted: 2011-11-28 22:37
Last Updated: 2016-07-12 09:13

Dependencies (19)

Required by (0)

Sources (1)

Latest Comments

syarifqwerty commented on 2016-07-28 02:21

i can't open title for saved title. must rename saved title with *.kdenlivetitle

evorster commented on 2016-07-02 01:57

The dependencies were added to be the same as the official kdenlive package. Thanks for the info on the quotation marks, it is fixed now.

blackhole commented on 2016-07-01 22:03

Also some quotation marks missing in depends

blackhole commented on 2016-07-01 22:01

Why plasma-desktop?

evorster commented on 2016-05-27 08:53

The issue with the home directory deletion has been corrected, according to the git comments.

https://quickgit.kde.org/?p=kdenlive.git

osc commented on 2016-05-25 18:16

i had the same issue!

my /home/myuser was deleted!

but the problem could be a kdenlive commit rather than this package:

https://quickgit.kde.org/?p=kdenlive.git&a=commit&h=d9b73c74a0b6725d1455558d5a3cb244b7e812cf

xF0E commented on 2016-05-25 13:01

ATTENTION ATTENTION ATTENTION

don't install this package(at least the current version). Installed it yesterday and upon the first start the whole content of my /home was deleted. Such a shame.

I only tried this version because the 16.04 crashes a way too frequently.

regreddit commented on 2016-04-01 16:09

This package isn't really usable with gnome until oxygen-icons is installed. The interface is missing all of its icons and buttons. I think it should be a required dependency

blackhole commented on 2016-03-27 00:07

I am using xfce4. I think kinit must be a dependency, otherwise it would be impossible to add clips "could not start process cannot talk to klauncher the name org.kde.klauncher5 was not provided by any .service files"

jz_train commented on 2016-02-01 16:32

Can confirm.

qt5-quickcontrols eliminates the segfault

nous commented on 2016-01-21 09:51

Needs qt5-quickcontrols in depends(), otherwise kdenlive segfaults at launch.

evorster commented on 2015-11-16 09:11

Optional dependency of oxygen-icons added.

Kallestofeles commented on 2015-11-14 13:11

"oxygen-icons" should definitely be marked as "optional for xfce" as the hicolor-icon-theme doesn't seem to do the trick - missing "play" "markers" etc buttons until oxygen-icons is installed.

bidulock commented on 2015-09-08 00:02

I think you also need kded as a dependency just as the 15.08 version from 'extra'.

bidulock commented on 2015-09-07 23:46

A corrected PKGBUILD with a VCS conforming pkgver() furnction is here:

https://gist.github.com/bbidulock/65b52cb7f726ed24e72c

evorster commented on 2015-06-03 13:10

I get this segfault too, reported the backtrace to devs upstream.

I suggest using kdenlive-applications15.04-git for now until this is fixed.

RankoKohime commented on 2015-05-25 16:29

Also experiencing a segfault at startup on my end. Even running through gdb, the only output is that the application segfaulted.

zobi8225 commented on 2015-05-05 18:44

I seg fault at startup :-(

➜ ~ kdenlive
[1] 10738 segmentation fault (core dumped) kdenlive
➜ ~ uname -a
Linux amelie 4.0.1-1-ARCH #1 SMP PREEMPT Wed Apr 29 12:00:26 CEST 2015 x86_64 GNU/Linux

arojas commented on 2015-03-24 20:53

Merging in kdenlive-git

agapito commented on 2015-03-03 01:50

Sorry, it was my fault. I was not using cmake from extra repo.

agapito commented on 2015-03-02 09:08

Resolving deltas: 100% (50512/50512), done.
Checking connectivity... done.
==> Validando las fuentes con md5sums...
kdenlive ... Omitido
==> Extrayendo las fuentes...
-> Creando copia de trabajo de kdenlive del repositorio git...
Cloning into 'kdenlive'...
done.
Switched to a new branch 'makepkg'
==> Iniciando pkgver()...
==> Versión actualizada: kdenlive-frameworks-git v0.9.10.369.g8e95cf3-1
==> Iniciando prepare()...
==> Iniciando build()...
cmake: error while loading shared libraries: libjsoncpp.so.0: cannot open shared object file: No such file or directory
==> ERROR: Se produjo un fallo en build().
Cancelando...
==> ERROR: Makepkg no ha podido compilar kdenlive-frameworks-git.
==> ¿Reiniciar la compilación de kdenlive-frameworks-git? [s/N]
==> -----------------------------------------------------------
==>

sl1pkn07 commented on 2015-03-02 01:15

More log podase

agapito commented on 2015-03-01 23:58

cmake: error while loading shared libraries: libjsoncpp.so.0: cannot open shared object file: No such file or directory

evorster commented on 2015-02-27 08:32

Looks like the dependency of mlt-git has changed to mlt-qt5.

It may be best to base this package of off kdenlive-frameworks-git now, as that is what I used to build the latest working git version of kdenlive, with only changing the source to the same one used in kdenlive-git.

The other option could be to make a new package called kdenive-kf5, but since kdenlive-git does not build anymore in it's current form, it may be best to just modify this package?

;)

evorster commented on 2015-02-27 08:07

As of 2015-02-27, the git master is now based on
Kdenlive-git gained two dependencies, namely: "extra-cmake-modules" and "kdoctools"
I get a successful build with those two extra depenedncies installed:

kdenlive-git-v0.9.10.r225.gda91989-1, but the binary segfaults

arojas commented on 2015-02-25 22:22

This is now based on Qt5/KF5

IncredibleLaser commented on 2015-02-02 21:07

I'm not 100% sure about that. I think kdenlive just uses the icons as specified in application appearance settings (which for KDE is systemsettings). However, any icon set providing the appropriate icons should be good. That's why hicolor-icon-theme is a dependency of this package (which in itself only provides the directories, not icons itself). Not perfect, I agree, but I don't like listing all icon sets as optional dependencies.

Thoughts?

sakalisc commented on 2015-01-30 15:08

Hi,

with the current dependencies, icons do not appear in the application. Installing oxygen-icons seems to fix this, perhaps the package should be a dependency? At the very least, an optional one?

Best

nous commented on 2014-10-05 13:01

Thanks for testing, as I no longer use the -git version.

Bitl0rd commented on 2014-10-03 18:13

thanks perfect current version 0.9.10

e8hffff commented on 2014-03-02 19:05

Still builds. Just need to change 'pkgver=' in PKGBUILD, to represent your date or build name.

lockheed commented on 2014-02-23 18:42

Well, if anyone wants to adopt it, here's the fix that should be implemented:
http://forum.kde.org/viewtopic.php?f=279&t=119774&p=302804#p302804

nous commented on 2014-02-21 20:54

I'm not actively using this anymore. I'll orphan it so anyone interested can adopt it.

nous commented on 2014-02-21 20:54

I'm not actively using this anymore. I'll orphan it so anyone intrested can adopt it.

lockheed commented on 2014-02-21 12:57

The package is broken in the vdpau part. Here's details:
https://bbs.archlinux.org/viewtopic.php?pid=1383474#p1383474

lockheed commented on 2014-02-13 10:36

Anyone knows how to fix this error during compilation?

producer_avformat.c: In function ‘producer_get_audio’:
producer_avformat.c:2270:4: warning: ‘request_channels’ is deprecated (declared at /usr/include/libavcodec/avcodec.h:1926) [-Wdeprecated-declarations]
codec_context->request_channels = self->audio_index == INT_MAX ? codec_context->channels : *channels;
^
<builtin>: recipe for target 'producer_avformat.o' failed
make[2]: *** [producer_avformat.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory '/tmp/yaourt-tmp-juha/aur-mlt-git/src/mlt-build/src/modules/avformat'
Makefile:5: recipe for target 'all' failed
make[1]: *** [all] Error 1
make[1]: Leaving directory '/tmp/yaourt-tmp-juha/aur-mlt-git/src/mlt-build/src/modules'
Makefile:9: recipe for target 'all' failed
make: *** [all] Error 1
==> ERROR: A failure occurred in build().
Aborting...

nous commented on 2013-11-02 23:42

Added, thanks.

alphazo commented on 2013-11-02 20:31

Package "glew" needs to be added as a required package to compile kdenlive-git.

Splashy commented on 2013-06-01 06:41

If you can't launch kdenlive:

kdenlive with --mlt-path /usr/share/mlt/profiles

and then in kdenlive go in option/environment and check that the path for the binaries are ok.

Splashy commented on 2013-05-29 17:31

I have a problem with kdenlive, it only runs as Root...

nous commented on 2012-09-23 16:33

Done, thanks.

Anonymous comment on 2012-09-23 10:58

The current version fails with the following:

[ 87%] Building CXX object src/CMakeFiles/kdenlive.dir/renderer.o
/home/thor/kdenlive/kdenlive-git/src/kdenlive/src/renderer.cpp: In member function 'void Render::buildConsumer(const QString&)':
/home/thor/kdenlive/kdenlive-git/src/kdenlive/src/renderer.cpp:199:42: error: 'class Mlt::Profile' has no member named 'colorspace'
make[2]: *** [src/CMakeFiles/kdenlive.dir/renderer.o] Error 1
make[1]: *** [src/CMakeFiles/kdenlive.dir/all] Error 2
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
Aborting...

This was fixed by removing "mlt" and installing "mlt-git", so maybe you need to update the dependencies until the mlt changes make it to the regular version?

nous commented on 2012-07-20 10:46

Fixed, thanks. At least it compiles on others.

attilio commented on 2012-07-20 08:08

I tried to compile using makepkg but it does not work for me unless I apply the modification shown in my previous comment.

Attilio

nous commented on 2012-07-19 18:25

If yaourt (or any other pacman/makepkg wrapper) fails, please use straight makepkg. It should work where yaourt fails.

I still can't compile it though, cmake wont find automoc4 binary no matter what.

attilio commented on 2012-07-19 14:44

Error in building:

tmp/yaourt-tmp-sickboy/aur-kdenlive-git/./PKGBUILD: line 56: cd: /tmp/yaourt-tmp-sickboy/aur-kdenlive-git/src/kdenlive-build: No such file or directory
==> ERROR: A failure occurred in package().
Aborting...
==> ERROR: Makepkg was unable to build kdenlive-git.

Successfully compiled with the following modification

package() {
cd "$srcdir/$_gitname-build"

-->

package() {
cd "$srcdir/$_gitname/build"

nous commented on 2012-07-19 09:30

==> Connecting to the GIT server....
Cloning into 'kdenlive'...
remote: Counting objects: 45674, done.
remote: Compressing objects: 100% (9811/9811), done.
Receiving objects: 26% (12110/45674), 7.37 MiB | 635 KiB/s


But it fails at cmake configuration:
CMake Error at /usr/share/apps/cmake/modules/FindPackageHandleStandardArgs.cmake:198 (MESSAGE):
Did not find automoc4 (Automoc4Config.cmake, install
git://anongit.kde.org/automoc). (missing: AUTOMOC4_EXECUTABLE)
Call Stack (most recent call first):
/usr/share/apps/cmake/modules/FindAutomoc4.cmake:49 (find_package_handle_standard_args)
/usr/share/apps/cmake/modules/FindKDE4Internal.cmake:423 (find_package)
/usr/share/cmake-2.8/Modules/FindKDE4.cmake:95 (FIND_PACKAGE)
CMakeLists.txt:51 (find_package)


-- Configuring incomplete, errors occurred!

Something's broken in my configuration (automoc4 is installed alright), does it compile on anyone else?

Anonymous comment on 2012-07-19 02:52

can anyone else compile this? I'm sitting @ Cloning into 'kdenlive'... but it's not pulling any data.

nous commented on 2011-11-28 22:47

Well, since I sometimes use kdenlive I adopted it. Please use the new kdenlive-git at https://aur.archlinux.org/packages.php?ID=54418. I started it using the PKGBUILD submitted by amirs. I'll request this page/comments/votes be merged with the new one. Your comments and contributions will help me maintain it better.

alphazo commented on 2011-11-26 22:05

PKGBUILD proposed below for git repo worked fine assuming that you rename kdenlive-svn.install to kdenlive.install.
I hope that maintainer will update it.

amirs commented on 2011-11-08 10:43

this PKGBUILD worked for me:

http://pastebin.com/dNm3b9Q8

amirs commented on 2011-11-08 10:19

moved to git

The Git repository is online at
http://quickgit.kde.org/?p=kdenlive.git&a=summary

alphazo commented on 2011-04-23 21:18

No longer works with ffmpeg-mt-git (which uses x264-git). avformat is not recognized when starting Kdenlive. I had to go back to x264 and ffmpeg from Extra/Community and mlt-git (AUR).

al3hex commented on 2011-03-06 14:15

Orphaned.

al3hex commented on 2011-02-18 23:04

Fixed. Thanks to alphazo.

alphazo commented on 2011-02-18 22:44

This PKGBUILD has been working fine until rev 5425.
qjson package is now required (for building only I guess). Can you please add it as a build dependency.

Anonymous comment on 2010-09-15 10:57

I tuned the PKGbuild a bit and now the build works flawlessly...

<script src="http://pastebin.com/embed_js.php?i=E7g0mDmD"></script>

ChemBro commented on 2010-08-10 18:20

I get this error:

mkdir: kann Verzeichnis „build“ nicht anlegen: Die Datei existiert bereits (mkdir: cannot create directory "build": it already exists).

Also kdenlive-svn does not like mlt-git because the version number is not high enough (but it's mlt-git and it's newer than mlt).