Package Details: kdepimlibs4 4.14.10-15

Git Clone URL: https://aur.archlinux.org/kdepimlibs4.git (read-only)
Package Base: kdepimlibs4
Description: KDE4 PIM Libraries
Upstream URL: https://projects.kde.org/projects/kde/kdepimlibs
Licenses: GPL, LGPL
Conflicts: kdepimlibs
Provides: kdepimlibs
Replaces: kdepimlibs
Submitter: Chazza
Maintainer: None
Last Packager: Chazza
Votes: 1
Popularity: 0.467699
First Submitted: 2018-02-17 17:12
Last Updated: 2018-02-26 23:08

Pinned Comments

Chazza commented on 2018-02-26 13:56

Note to all - The akonadi-qt4 package conflicts with the KDE 5 version of akonadi and you need akonadi-qt4 to build kdepimlibs4. However, kdepimlibs4 only needs libakonadi-qt4 at runtime which doesn't conflict with akonadi. So if you're trying to build kdepimlibs4 but you have packages which depend on KDE 5 akonadi installed then what you need to do is the following:

1) pacman -Rdd akonadi (this will uninstall KDE 5 akonadi with no dependency checks)

2) Install akonadi-qt4 and libakonadi-qt4

3) Build and install kdepimlibs4

4) pacman -R akonadi-qt4

5) pacman -S akonadi

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

mozo commented on 2018-02-25 21:45

Of course I'll let you know :)

Chazza commented on 2018-02-25 16:37

Great :) Well if you do, let me know what happens. And when I'm able I'll look into resurrecting some of the KDE 4 applications PKGBUILDS.

mozo commented on 2018-02-25 13:32

I have a backup so I can try some day :)

Chazza commented on 2018-02-25 13:04

Doing what I proposed below won't automatically install plasma 5 dolphin. But I have no idea what will happen to your plasma 4 dolphin or any other plasma applications. You probably shouldn't update anything just yet if you really want to keep your kde 4 applications as I think you might end up in dependency hell. I'm not sure what to do about the kde4 applications just yet. I need to think about it.

mozo commented on 2018-02-25 12:34

Thank you very much :) Will this bring me Plasma 5 Dolphin?

Chazza commented on 2018-02-25 11:52

Bear in mind that I don't have an existing KDE 4 install. When building these packages I have a fresh install of Arch with just base, base-devel and X. So it's difficult for me to know what your environment is like. :( But I think the procedure would be something like this:

1) Unhold all packages.

2) Replace kactivites with kactivities4.

3) Update kdelibs and kdebase-runtime to their latest versions.

4) Update any other packages to their latest versions, either in the official repos or the AUR.

5) At this point, you should have a working plasma desktop but the systray will be broken. Then install the new package I created, kdebase-runtime-plasma4extras and log out and in again and the systray should work.

+++++++++++++++++++++++++

I think you can still use the KDE 4 versions of Dolphin etc but they'll need to be rebuilt against the updated libraries. So someone would need to dig up the KDE 4 era PKGBUILD for Dolphin and add it to the AUR.

Which applications do you use where you want to stay with the KDE 4 versions? Is it just dolphin, kwrite and kate? Or there others? If it's just a few then I'm happy to add those to the AUR. But I don't think I can maintain the entire KDE 4 applications stack all on my own. :(

mozo commented on 2018-02-25 11:32

Chazza, yes this is a problem for me. The KDE 5 version of Dolphin is very ugly :) Can you explain briefly how to use your packages in a step by step manner?

mozo commented on 2018-02-25 11:29

You'll have to upgarade kdelibs than upgrade kdepimlibs4 and downgrade kdelibs again. There aren't any problems from this operation.

Chazza commented on 2018-02-25 11:28

Ok folks, so my aim is to make the plasma 4 desktop installable alongside the packages in the official repos. This means I have zero packages on hold and I'm assuming that anyone who uses these packages also has zero packages on hold. If you've got things like kdelibs or kdebase-runtime on hold then you're going to get unpredictable results.

What I can say is this. If you build all the packages I've added to the AUR and you have nothing on hold then you will have a working plasma 4 desktop apart from the systray and if you install the package in my google drive - see my previous comment - then the systray should work as well. And I'm just waiting for someone else to confirm that and then I'll add it the AUR.

As for KWrite, Dolphin etc, you can use the KDE 5 versions of these alongside the plasma 4 desktop just fine. Is this a problem for you?

whaler commented on 2018-02-25 11:21

I have avoided upgrading to "kdepimlibs4 4.14.10-12". If I do, will I run into any of the problems mentioned below, or are the problems solved by now?