Package Details: kdepimlibs4 4.14.10-15

Git Clone URL: https://aur.archlinux.org/kdepimlibs4.git (read-only)
Package Base: kdepimlibs4
Description: KDE4 PIM Libraries
Upstream URL: https://projects.kde.org/projects/kde/kdepimlibs
Licenses: GPL, LGPL
Conflicts: kdepimlibs
Provides: kdepimlibs
Replaces: kdepimlibs
Submitter: Chazza
Maintainer: None
Last Packager: Chazza
Votes: 1
Popularity: 0.485347
First Submitted: 2018-02-17 17:12
Last Updated: 2018-02-26 23:08

Pinned Comments

Chazza commented on 2018-02-26 13:56

Note to all - The akonadi-qt4 package conflicts with the KDE 5 version of akonadi and you need akonadi-qt4 to build kdepimlibs4. However, kdepimlibs4 only needs libakonadi-qt4 at runtime which doesn't conflict with akonadi. So if you're trying to build kdepimlibs4 but you have packages which depend on KDE 5 akonadi installed then what you need to do is the following:

1) pacman -Rdd akonadi (this will uninstall KDE 5 akonadi with no dependency checks)

2) Install akonadi-qt4 and libakonadi-qt4

3) Build and install kdepimlibs4

4) pacman -R akonadi-qt4

5) pacman -S akonadi

Latest Comments

« First ‹ Previous 1 2 3 4 5

mozo commented on 2018-02-20 10:45

It gives an error at the compile stage:

[100%] Building CXX object kontactinterface/CMakeFiles/kontactinterface.dir/pimuniqueapplication.o <br> [100%] Building CXX object kontactinterface/CMakeFiles/kontactinterface.dir/kontactinterface_autogen/mocs_compilation.o <br> [100%] Linking CXX shared library ../lib/libkontactinterface.so [100%] Built target kontactinterface Scanning dependencies of target doc-kcontrol-kresources-handbook [100%] Generating index.cache.bz2 I/O warning : failed to load external entity "/usr/share/xml/docbook/xsl-stylesheets-1.79.1/html/autoidx.xsl" compilation error: file /usr/share/apps/ksgmltools2/customization/kde-include-common.xsl line 4 element import xsl:import : unable to load /usr/share/xml/docbook/xsl-stylesheets-1.79.1/html/autoidx.xsl I/O warning : failed to load external entity "/usr/share/xml/docbook/xsl-stylesheets-1.79.1/html/chunk.xsl" compilation error: file /usr/share/apps/ksgmltools2/customization/kde-include-common.xsl line 5 element import xsl:import : unable to load /usr/share/xml/docbook/xsl-stylesheets-1.79.1/html/chunk.xsl unable to parse /tmp/makepkg/kdepimlibs4/src/kdepimlibs-4.14.10/doc/kcontrol/kresources/index.docbook make[2]: [doc/kcontrol/kresources/CMakeFiles/doc-kcontrol-kresources-handbook.dir/build.make:62: doc/kcontrol/kresources/index.cache.bz2] Error 1 make[1]: [CMakeFiles/Makefile2:17106: doc/kcontrol/kresources/CMakeFiles/doc-kcontrol-kresources-handbook.dir/all] Error 2 make: *** [Makefile:141: all] Error 2 ==> ERROR: A failure occurred in build(). Aborting... ==> ERROR: Makepkg was unable to build . ==> Restart building kdepimlibs4 ? [y/N]