Package Details: kdeplasma-applets-veromix-git 29.813dcbd-2

Git Clone URL: (read-only)
Package Base: kdeplasma-applets-veromix-git
Description: A plasmoid mixer for the Pulseaudio sound server
Upstream URL:
Licenses: GPL3
Conflicts: kdeplasma-applets-veromix, veromix-git
Submitter: M0Rf30
Maintainer: M0Rf30
Last Packager: M0Rf30
Votes: 35
Popularity: 0.002986
First Submitted: 2012-07-16 14:47
Last Updated: 2015-10-21 14:45

Latest Comments

cousinm commented on 2015-09-17 08:25

Please replace kdesdk-dev-scripts with kde-dev-scripts (this must have been renamed). The package doesn't build without this.

nylocx commented on 2014-05-17 11:53

Hmm, it seems as if the bug is resolved in the master branch of Morfeo's git repo but the PKGBUILD still checks out the stable branch with the bug.

Btw. I'm far from a python expert, but I guess the right way to create path strings is by using os.path.join like this.

configpath = os.path.join(os.getenv('HOME'), ".veromix")
blacklist_file = os.path.join(configpath, "ladspa-blacklist.conf")

Commander commented on 2014-05-12 21:41

Hm after looking into why this would not launch i noticed that this is really a fork and not using code from:

Stupidly enough i noticed after creating a bug report on his tracker:

There is a typo in located in:

Line 179:
configpath = os.getenv('HOME') + ".veromix/"
Should probably be:
configpath = os.getenv('HOME') + "/.veromix/"

This will make veromix work.
Maybe me, but shouldn't the upstream URL point to your github? I call it a long day but got me confused =)

nylocx commented on 2014-04-06 14:52

The latest Version seems to have a bug.
It tries to create '/home/{username}.veromix'.
I guess there is a missing / somewhere in the code

If I create the directory by hand and give my user ownership veromix works as expected.

agapito commented on 2013-12-11 14:59

This package is not outdated, I clicked by mistake. Sorry.

marcinfa commented on 2013-06-18 09:31

"There is an update that changed python2-qt to python2-pyqt4, so the depends needs to be adjusted." - change depends not work - package broken.

denisfalqueto commented on 2013-06-18 04:34

There is an update that changed python2-qt to python2-pyqt4, so the depends needs to be adjusted.

agapito commented on 2013-01-05 14:05

Add "kdeplasma-applets-veromix" to conflicts line.

agapito commented on 2013-01-05 14:04

error: error al realizar la transacción (archivos en conflicto)
kdeplasma-applets-veromix-git: /usr/share/apps/plasma/plasmoids/veromix-plasmoid/contents/code/veromixcommon existe en el sistema de archivos
kdeplasma-applets-veromix-git: /usr/share/apps/plasma/plasmoids/veromix-plasmoid/contents/icons existe en el sistema de archivos
kdeplasma-applets-veromix-git: /usr/share/apps/plasma/plasmoids/veromix-plasmoid/contents/locale existe en el sistema de archivos
kdeplasma-applets-veromix-git: /usr/share/apps/plasma/plasmoids/veromix-plasmoid/dbus-service existe en el sistema de archivos
Ocurrieron errores, no se actualizaron paquetes

M0Rf30 commented on 2012-07-16 16:33

during the bytecode generation with python3
and many other
I tried to use 2to3 but there are many other issues about urllib

ilpianista commented on 2012-07-16 14:57

Just a question, the stable version of veromix uses python3, why this uses python2 then?

M0Rf30 commented on 2012-07-16 14:48

moved to

ilpianista commented on 2012-07-16 09:56

please rename this package following the KDE package guidelines,


tdebruyn commented on 2012-06-08 14:08

I think you should change the preset.patch to modify the presets path to "/usr/share/veromix/data" instead of "/usr/share/apps/plasma/plasmoids/veromix-plasmoid"

roentgen commented on 2012-06-07 19:41

Now the link looks like

$ ls -l plasma-widget-veromix.desktop
lrwxrwxrwx 1 root root 95 Jun 7 22:32 plasma-widget-veromix.desktop -> ../../../../../../../../../../usr/share/apps/plasma/plasmoids/veromix-plasmoid/metadata.desktop

Nothing wrong about it as it works as it is but I see in other pkgbuilds that they only use "ln -s" without the -r (relative).

roentgen commented on 2012-06-07 16:38

/usr/share/kde4/services/plasma-widget-veromix.desktop installs as a broken symlink pointing to ../apps/plasma/plasmoids/veromix-plasmoid/metadata.desktop.

It needs another ../ in front of it...

Anonymous comment on 2012-06-07 13:23

Works for me with dependency dbus-python instead of python2-dbus which is in testing.

M0Rf30 commented on 2012-06-06 18:49

if you do /usr/share/veromix/dbus-service/ it will run correctly.
But I didn't understood why, cause this script could be launched by /usr/share/dbus-1/services/org.veromix.pulseaudio.qt.service

agapito commented on 2012-06-06 17:04

agapito commented on 2012-06-06 17:01

Not working here.

M0Rf30 commented on 2012-06-06 16:57

python2-dbus is in testing

M0Rf30 commented on 2012-06-06 16:03

moved to veromix-git

M0Rf30 commented on 2012-06-06 12:33

I will fix and organize packages asap. ;)

Anonymous comment on 2012-06-06 10:19

Dependency pygi from aur doesn't build... says
"This page has been deprecated (PyGI have been merged in PyGObject); Please refer to PyGObject in its place."

roentgen commented on 2012-06-06 06:38

This shouldn't be named kdeplasma anymore if it supports gnome and requires gtk stuff.

I suggest that this should be kept kde only and another package should be created with gnome support.

rtimush commented on 2012-06-05 21:31

The package doesn't build anymore because of massive upstream file moves.