Package Details: kdesrc-build-git v15.05.r9.g517c5b8-1

Git Clone URL: (read-only)
Package Base: kdesrc-build-git
Description: A script to build KDE software from KDE's source repositories
Upstream URL:
Keywords: kde
Licenses: GPL
Conflicts: kdesrc-build
Provides: kdesrc-build
Submitter: JiajunW
Maintainer: None
Last Packager: ilpianista
Votes: 1
Popularity: 0.000000
First Submitted: 2013-01-07 16:52
Last Updated: 2015-08-05 17:05

Dependencies (9)

Required by (0)

Sources (1)

Latest Comments

ilpianista commented on 2015-01-21 17:13

you broke cds into build() and package() now...

ilpianista commented on 2015-01-20 17:35

Please fix pkgver(), it does cd into $pkgname instead of $_pkgname

JiajunW commented on 2014-07-04 16:31

@ilpianista thx for advise!

I have installed kdesrc-buildrc-sample in /usr/share/kdesrc-build/.

ilpianista commented on 2014-06-22 19:02

kdesrc-build encountered an exceptional error condition: Runtime Error: Logical module groups require the Perl JSON module

perl-json dep is missing

ilpianista commented on 2013-11-20 16:53

maybe you should install kdesrc-buildrc-sample somewhere? e.g. /usr/share/doc/kdesrc-build/

ilpianista commented on 2013-11-20 16:51

also note that there's no svn packages, but subversion. svn is just an alias.

ilpianista commented on 2013-11-20 16:51

hi again, the optdepends' descriptions are switched:
svn: download source code using git
git: download source code using svn

JiajunW commented on 2013-10-03 13:02

@ascarpino Updated.

ilpianista commented on 2013-09-22 13:59

Could you port this to the new pacman VCS features?

JiajunW commented on 2013-02-11 12:48

@ascarpino Add it, thx.

ilpianista commented on 2013-02-08 00:26

missing deps: dialog

Unable to run the dialog(1) program, it is required for this setup script.
The program wouldn't even run, due to error: No such file or directory