Package Details: kdevplatform-git 5.0.0.r13516.664d2fc-1

Git Clone URL: (read-only)
Package Base: kdevplatform-git
Description: A C/C++ development platform for KDE. (GIT Version)
Upstream URL:
Licenses: GPL
Conflicts: kdevplatform
Provides: kdevplatform
Submitter: mosra
Maintainer: Aetf
Last Packager: Aetf
Votes: 73
Popularity: 0.141133
First Submitted: 2010-05-05 21:15
Last Updated: 2016-08-31 21:38

Latest Comments

greenbagels commented on 2016-07-10 16:08

I'll get right on that, expect a fix tonight.

goetzc commented on 2016-07-08 01:46

It seems that kde-cli-tools dependency is needed for kioclient, which is needed for shell integration in the Konsole inside KDevelop.

"The utility kioclient is not in your path, the shell integration will not work properly."

greenbagels commented on 2016-05-26 08:13

Updated, really sorry for the lack of a fix for all this time.

intelfx commented on 2016-03-31 18:47

qt5-quick1 is not needed in current master. Please remove the dependency — this module has been deprecated and is in AUR now.

greenbagels commented on 2015-12-28 04:24

Fixed the llvm dependency issue — never noticed it myself as I had the package already installed. Thanks for pointing it out!

About the conflicting package proposal, I'm not sure if I'm okay with adding kapptemplate as a conflicting package as it would prevent users from using both packages (which would be allowed if the normal upstream packages were used).

Perhaps the better solution would be to edit the PKGBUILD to delete the conflicting file after installation?

Musikolo commented on 2015-12-26 21:28

I got the following error when building this package:

CMake Error at cmake/modules/FindLLVM.cmake:115 (message):
Could not find LLVM: Could NOT find 'llvm-config' executable

More details at

I solved the issue by installing llvm package. So, I guess it should be added as a dependency.

Later on, I also found the following issue when installing the package I guess the problem can be solved by adding kapptemplate as a conflicting package.


greenbagels commented on 2015-12-18 05:48

Would you guys be okay if I updated these git repository-based packages weekly just for the sake of your ability to get the newer commits without having to build from scratch? Mainly it'd be helping AUR helper applications.

sl1pkn07 commented on 2015-08-17 19:29

fixed in upstream (?)

amgo100 commented on 2015-08-16 09:45

Kdevplatform in repo is now incompatible with current subversion. To skip building subversion plugin add -DBUILD_subversion=OFF to cmake configuration.

sl1pkn07 commented on 2015-06-11 15:32

@CIB done(?)

All comments