Package Details: keepass-plugin-kpuinput 1.4-2

Git Clone URL: https://aur.archlinux.org/keepass-plugin-kpuinput.git (read-only, click to copy)
Package Base: keepass-plugin-kpuinput
Description: Keepass plugin to use /dev/uinput for auto-typing
Upstream URL: https://keepass.info/help/kb/autotype_wayland.html
Licenses: GPL
Submitter: jhenson
Maintainer: jhenson
Last Packager: jhenson
Votes: 3
Popularity: 0.37
First Submitted: 2022-04-11 21:31 (UTC)
Last Updated: 2023-06-23 13:17 (UTC)

Latest Comments

Aroun commented on 2024-04-03 06:26 (UTC) (edited on 2024-04-03 06:27 (UTC) by Aroun)

You are right, the patch had probably not been properly applied the first time I built the package. I think debugedit was missing. I forced a rebuild/reinstall and it works properly now. Thank you.

jhenson commented on 2024-04-01 15:37 (UTC)

Hmm, that's strange. The path_fix.patch hardcodes the so path to the location that it's installed to. Are you sure that was applied properly when building the package? I've not had any issues with it loading it from the /usr/share/keepass/plugins/KPUInputN.so location.

Aroun commented on 2024-04-01 13:55 (UTC)

About my previous comment, I had the same error message with other plugins also. After a few reboots, the plugin finally compiled. I am not sure what the issue was.

Other than that, for the kpuinput plugin to work, I had to execute the command indicated in point 7 of https://keepass.info/help/kb/autotype_wayland.html#setup

sudo cp -f /usr/share/keepass/plugins/KPUInputN.so /usr/lib/KPUInputN.so

Aroun commented on 2024-03-31 06:54 (UTC)

"The following plugin is incompatible with the current KeePass version: /usr/share/keepass/plugins/KPUInput.plgx

Have a look at the plugin's website for an appropriate version.

On some systems, the 'mono-complete' package may be required for plugins to work properly."