Package Details: kencfs-plasma 2.0.3a-1

Git Clone URL: https://aur.archlinux.org/kencfs-plasma.git (read-only)
Package Base: kencfs-plasma
Description: KDE-Plasma compatible GUI frontend for encfs. Create, mount, umount and delete your encrypted fs.
Upstream URL: https://www.linux-apps.com/p/1170068/
Licenses: (L)GPL
Submitter: felmur
Maintainer: felmur
Last Packager: felmur
Votes: 3
Popularity: 0.000002
First Submitted: 2017-02-24 14:56
Last Updated: 2018-11-03 17:15

Dependencies (2)

Required by (0)

Sources (1)

Latest Comments

j0hannes commented on 2018-12-03 13:22

can't install the package, seems like the error reported two months ago is still around

felmur commented on 2018-11-03 16:36

New version is coming. Please wait.

FranzMari commented on 2018-10-25 09:50

@felmur Looks like a Qt5 problem: kstatusnotifier.h uses QtDBus from Qt4 instead of Qt5. I had to manually change

include <QDBusArgument>

to

include <qt5/QtDBus/QDBusArgument>

in order to make kencf-plasma build successfully.

felmur commented on 2018-10-15 11:36

@Delian, it seems a problem with include file /usr/include/qt/QtDBus/qdbusargument.h.

I don't understand that: the file is regulary installed by qt5-base 5.11.2-1 package. The qt5-base package is required by very huge list of others packages of Plasma. So, how can be missed on your system?

Someone have the same problem?

Delian commented on 2018-10-12 15:13

Seems there is an issue with the package.

/usr/include/KF5/KNotifications/kstatusnotifieritem.h:26:10: fatal error: QDBusArgument: No such file or directory #include <qdbusargument></qdbusargument>

I've temporary fixed like gentoo team did https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=c90b2e9405c3e27059242c157dd32ee4ce4fe243&b=4

Someone commented about it on upstream already but it has no answer from the dev.

felmur commented on 2018-02-28 17:32

2.02a - Fixed a bug in loadCFG, which creates some fake filesystem rows.