Package Details: keybase-git 5.5.0+35896.807c29924b-1

Git Clone URL: https://aur.archlinux.org/keybase-git.git (read-only, click to copy)
Package Base: keybase-git
Description: the Keybase Go client, filesystem, and GUI
Upstream URL: https://keybase.io
Licenses: BSD
Conflicts: kbfs, keybase, keybase-bin, keybase-gui, keybase-release
Provides: kbfs, keybase, keybase-gui
Submitter: oconnor663
Maintainer: oconnor663 (keybase)
Last Packager: oconnor663
Votes: 11
Popularity: 0.001445
First Submitted: 2016-02-10 22:48
Last Updated: 2020-04-27 15:05

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

oconnor663 commented on 2016-06-17 12:34

@shellkr that's what I did just now. Are you noticing any inconsistencies? We do have a push script we automate internally which uses a different hack, though, because it runs on Debian.

shellkr commented on 2016-06-17 03:38

@oconnor663 Can you not just.. 'rm .SRCINFO && mksrcinfo' ...before you push?

oconnor663 commented on 2016-06-16 20:03

@shellkr just added, thanks.

shellkr commented on 2016-06-16 18:41

You are missing the "upstream url" link

oconnor663 commented on 2016-04-12 19:13

I just filed https://github.com/rmarquis/pacaur/issues/483.

oconnor663 commented on 2016-04-12 18:31

@mjec that sounds like it would be a problem with any git AUR package, if there have been commits since the PKGBUILD was last updated. Do you know if other packages do something different to avoid this problem? Also I just installed pacaur and ran `pacaur -S keybase-git` and it seems to be working ok on my machine. Maybe you could paste in the error you're seeing?

Edit: Scratch that, I just saw "keybase-git package(s) failed to install. Check .SRCINFO for mismatching data with PKGBUILD." at the end of the pacaur build.

mjec commented on 2016-04-12 17:39

This won't install with pacaur because .SRCINFO keeps the old pkgver but PKGBUILD pkgver is updated to the latest version (as of right now, 1.0.15_20160412164601+b747605-1) during the build process. The mismatch causes pacaur to choke.

It looks like this is associated with client/packaging/linux/arch/PKGBUILD's pkgver() which calls client/packaging/version.sh; but .SRCINFO remains the version on AUR which has a version mismatch if there have been any new commits.

oconnor663 commented on 2016-04-04 17:57

@njaremko Previously we were putting out daily builds but not bumping this PKGBUILD. As of today it should be automatically bumped daily.

njaremko commented on 2016-04-01 20:32

Needs to be updated, Keybase is yelling at me saying I need to update.

Until then, you can also reinstall because the package just pulls from github.

oconnor663 commented on 2016-02-14 00:25

Oops, bad copypasta from some internal scripts. Thanks again.