Package Details: kguiaddons-git 5.240.0_r562.gc5ed05d-1

Git Clone URL: https://aur.archlinux.org/kguiaddons-git.git (read-only, click to copy)
Package Base: kguiaddons-git
Description: Addons to QtGui
Upstream URL: https://community.kde.org/Frameworks
Licenses: LGPL
Conflicts: kguiaddons
Provides: kguiaddons
Submitter: ilpianista
Maintainer: IslandC0der (chaotic-aur)
Last Packager: IslandC0der
Votes: 20
Popularity: 0.000000
First Submitted: 2014-01-04 11:37 (UTC)
Last Updated: 2023-08-21 17:16 (UTC)

Required by (20)

Sources (1)

Latest Comments

1 2 Next › Last »

MarsSeed commented on 2023-08-05 22:28 (UTC)

Please remove the obsolete sip4 make dependency.

sandy8925 commented on 2023-02-20 06:15 (UTC) (edited on 2023-02-20 06:20 (UTC) by sandy8925)

Here's a patch that removes qt6-x11extras and adds plasma-wayland-protocols that's now required. diff --git a/PKGBUILD b/PKGBUILD index f3d5a1e..7432567 100644 --- a/PKGBUILD +++ b/PKGBUILD @@ -9,7 +9,7 @@ pkgdesc='Addons to QtGui' arch=($CARCH) url='https://community.kde.org/Frameworks' license=(LGPL) -depends=(qt6-x11extras qt6-wayland) +depends=(qt6-wayland plasma-wayland-protocols) makedepends=(git extra-cmake-modules-git clang python-pyqt6 doxygen qt6-tools sip4) conflicts=(${pkgname%-git}) provides=(${pkgname%-git})

sandy8925 commented on 2023-02-20 04:43 (UTC)

qt6-x11 extras doesn't exist anymore. Can you please remove it or replace with the correct dependency?

davispuh commented on 2023-02-05 21:23 (UTC)

Doesn't build anymore. Need to add -DQT_MAJOR_VERSION=6 CMake option now.

carlosnewmusic commented on 2021-07-09 12:22 (UTC)

yes it worked for me thanks although I had to put the raw patches in the pkbuild of that git.

IslandC0der commented on 2021-07-07 02:20 (UTC)

For everyone having that PyQt5 issue, please try recompiling extra-cmake-modules-git with this patch

IslandC0der commented on 2021-07-06 15:23 (UTC) (edited on 2021-07-06 15:24 (UTC) by IslandC0der)

@carlosnewmusic @Ext Many people are having this issue. Do you have python 2 installed? If so, does uninstalling it fix the problem?

carlosnewmusic commented on 2021-07-06 15:01 (UTC)

I keep getting the same error https://pastebin.com/edit/Dkd0iwNM

Ext commented on 2021-06-14 19:38 (UTC)

[78%] Built target KF5GuiAddons_QCH make: *** [Makefile: 136: all] Error 2 ==> ERROR: The build () has failed.

IslandC0der commented on 2021-06-12 00:10 (UTC)

@carlosnewmusic that pastebin is private, I can't open it :(