Package Details: khard-git 0.12.2.r2.g3cd57db-1

Git Clone URL: https://aur.archlinux.org/khard-git.git (read-only)
Package Base: khard-git
Description: Console CardDAV client
Upstream URL: https://github.com/scheibler/khard/
Keywords: carddav cli dav
Licenses: GPL3
Conflicts: khard
Provides: khard
Submitter: dvzrv
Maintainer: dvzrv
Last Packager: dvzrv
Votes: 8
Popularity: 0.000000
First Submitted: 2014-10-12 16:43
Last Updated: 2018-03-15 02:43

Latest Comments

1 2 3 Next › Last »

dvzrv commented on 2018-03-15 02:05

sasvari: perks of having a git package... you rarely get to see all upstream changes ;-)

sasvari commented on 2018-03-08 12:50

python-ruamel-yaml is missing as a dependency:

raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'ruamel.yaml' distribution was not found and is required by khard

dvzrv commented on 2016-09-26 11:09

Please note: There's currently an issue involving python-vobject (https://github.com/scheibler/khard/issues/97). The current khard (0.11.3) works only with python-vobject 0.9.2 (atm it's at 0.9.3 already though)!
So either downgrade python-vobject to 0.9.2 or khard-git to below 0.11.3

dvzrv commented on 2016-09-25 17:32

@bastelfreak: Added python-setuptools to makedepends. Should build now.
Enjoy!

bastelfreak commented on 2016-09-25 12:52

Hi,
I'm unable to build the PKGBUILD in a fresh arch linux:

>>>>>>>>>>>>>>>>>>>>>>==> Starting package()...
Traceback (most recent call last):
File "setup.py", line 13, in <module>
from setuptools import setup
ImportError: No module named 'setuptools'
==> ERROR: A failure occurred in package().
Aborting...
==> ERROR: Build failed, check /mnt/aur/build_test/khard-git/build
<<<<<<<<<<<<<<<<<<<<<<

It should be enough to add python-setuptools as a make depend

Rhinoceros commented on 2016-07-27 23:51

Thanks @dvzrv!

dvzrv commented on 2016-07-27 19:44

@Rhinoceros: I fixed it. Khard now is fully python3!

Note: davcontroller (which honestly I never use) still uses python2 though!

Rhinoceros commented on 2016-07-26 10:10

This fails to build.

==> Starting package()...
Error: khard runs under python3 only. Please upgrade your system wide python installation or create a python3 virtual environment first.

It works if I change python2 to python in the PKGBUILD. Presumably some of the dependencies have changed too (see AUR's `khard` [a]).

[a] https://aur.archlinux.org/packages/khard/

dvzrv commented on 2016-01-31 19:02

@hobarrera, Xyne: You are correct. Added, fixed and updated.
Sorry for the long delay, been busy with work.

Xyne commented on 2016-01-26 20:46

python2-atomicwrites is a run-time dependency. Please add it to the "depends" array. Thanks!