Package Details: khard 0.11.4-1

Git Clone URL: https://aur.archlinux.org/khard.git (read-only)
Package Base: khard
Description: Console CardDAV client
Upstream URL: https://github.com/scheibler/khard
Licenses: GPL3
Conflicts: khard
Provides: davcontroller, khard
Submitter: Eisfreak7
Maintainer: Eisfreak7
Last Packager: Eisfreak7
Votes: 13
Popularity: 0.329521
First Submitted: 2015-12-30 13:09
Last Updated: 2017-03-07 12:21

Dependencies (6)

Required by (0)

Sources (1)

Latest Comments

Eisfreak7 commented on 2017-03-07 12:21

Done

polyzen commented on 2017-02-20 07:01

Please remove the build() function as it's not currently used.

Eisfreak7 commented on 2016-09-20 14:47

Note that vobject 0.9.3 causes an issue when importing a vcard file:
https://github.com/eventable/vobject/issues/39

There's nothing I can do about it, so I just remove the version restriction of vobject.
If you want to resolve this issue, you have to manually install an older version of vobject (0.9.2) or wait until the issue is resolved upstream.

Eisfreak7 commented on 2016-02-02 21:32

I did not, sorry.
Now it should be updated.

wilbowma commented on 2016-02-02 18:44

Did you commit that change? It's not listed as a dependency in the version I can see.

Eisfreak7 commented on 2016-01-23 13:20

Ah okay, I really had that already installed.
I've added the dependency.

Markus00000 commented on 2016-01-21 17:27

Sorry, I meant python2-yaml. Maybe you have it installed already? Without python2-yaml I get this:

% khard email --search 'm'
Traceback (most recent call last):
File "/usr/bin/khard", line 5, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3130, in <module>
@_call_aside
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3116, in _call_aside
f(*args, **kwargs)
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3143, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 642, in _build_master
ws.require(__requires__)
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 943, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 830, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'pyyaml' distribution was not found and is required by khard

Eisfreak7 commented on 2016-01-21 16:53

I added the python2-setuptools makedepend.

@Markus00000
There is no python2-pyyaml in the repos or the aur.
Also, I don't have it installed and the command doesn't crash for me.

Markus00000 commented on 2016-01-21 07:49

python2-pyyaml is missing as a dependency. From setup.py:

required_modules = ['atomicwrites', 'configobj', 'pyyaml', 'vobject']

khard crashes without it when looking up email addresses with `khard email --search '%s'`.

Anonymous comment on 2016-01-05 00:29

Requires a makedepend on python2-setuptools.