Package Details: kibana-xpack 7.12.0-1

Git Clone URL: https://aur.archlinux.org/kibana-xpack.git (read-only, click to copy)
Package Base: kibana-xpack
Description: Browser based analytics and search dashboard for Elasticsearch
Upstream URL: https://www.elastic.co/products/kibana
Licenses: custom:Elastic2
Conflicts: kibana
Provides: kibana
Submitter: hnws
Maintainer: dwheeler
Last Packager: dwheeler
Votes: 3
Popularity: 0.81
First Submitted: 2019-03-27 01:53
Last Updated: 2021-03-27 00:00

Pinned Comments

dwheeler commented on 2020-10-29 00:45

To import the PGP key:

gpg --recv-keys 46095ACC8548582C1A2699A9D27D666CD88E42B4

or

curl -sS https://artifacts.elastic.co/GPG-KEY-elasticsearch | gpg --import - 

Latest Comments

bidulock commented on 2021-04-03 12:54

Please change provides=('kibana') to provides=("kibana=$pkgver") to handle version dependencies of other packages.

Also, can't really be an "any" package because it contains x86_64 ELF binaries.

MCOfficer commented on 2021-02-26 09:15

Upgrading this package can fail due to the change in node version:

looking for conflicting packages...
:: nodejs-lts-fermium and nodejs-lts-dubnium are in conflict (nodejs). Remove nodejs-lts-dubnium? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing nodejs-lts-dubnium breaks dependency 'nodejs-lts-dubnium' required by kibana-xpack
error installing repo packages

In that case, remove it, then reinstall it to break the "dependency stalemate".

dwheeler commented on 2020-10-29 00:45

To import the PGP key:

gpg --recv-keys 46095ACC8548582C1A2699A9D27D666CD88E42B4

or

curl -sS https://artifacts.elastic.co/GPG-KEY-elasticsearch | gpg --import -