Package Details: kicad-pretty-git a-1

Git Clone URL: https://aur.archlinux.org/kicad-pretty-git.git (read-only)
Package Base: kicad-pretty-git
Description: KiCad .pretty repos. Theese are the new footprint library.
Upstream URL: https://github.com/KiCad
Licenses: GPL
Submitter: nickoe
Maintainer: nickoe
Last Packager: nickoe
Votes: 26
Popularity: 0.000090
First Submitted: 2014-06-08 10:24
Last Updated: 2015-08-27 16:54

Dependencies (2)

Required by (0)

Sources (95)

Pinned Comments

greyltc commented on 2018-03-16 21:32

Can we get a sticky comment here saying that these part libraries are legacy and no longer maintained?

Latest Comments

greyltc commented on 2018-03-16 21:32

Can we get a sticky comment here saying that these part libraries are legacy and no longer maintained?

nickoe commented on 2017-07-12 21:33

@gyscos, what?

gyscos commented on 2017-07-07 18:36

@nickoe, what binaryplease meant was to add kicad-library to the conflict list in the PKGBUILD.

nickoe commented on 2017-07-02 14:18

Mmm, where exactly do you see the default of modules? Quite some time ago, every instance of modules were renamed to footprints in kicad.

Anonymous comment on 2017-07-02 13:12

Why do you install to "footprints" instead of the default path "modules"?

nickoe commented on 2017-04-14 21:42

So don't try to install them both.

pablo1 commented on 2017-04-14 18:04

This package conflicts with kicad-library.

nickoe commented on 2015-09-28 14:16

@doragasu

I recommend to install both. But this one only includes the pretty footprints, while kicad-library-git includes the schematic symbols and 3D models...

Strictly speaking you can download the footprints from within KiCad, and hence don't need this package, but unfortunately you can not do that with the schematic symbols yet.

doragasu commented on 2015-09-28 10:30

Sorry to ask some maybe stupid questions, but... what's the difference between this and "kicad-library-git"? Will I find the same parts? Do they come with 3D models? Is there one recommended over the other? Or is it recommended to install both?

Thanks!

nickoe commented on 2015-01-25 12:38

I have now fixed this as https://github.com/nickoe/PKGBUILDs/commit/9c5d46906583c934b095f0ec6b04a1bbbce4b1aa

I believe I should not ignore it, not to mess too much with what is upstream. But I also saw that the dir was not listed in the fp-lib-table. Only time will tell what is going on.

All comments