Package Details: kiibohd-configurator-git r286.2e12869-1

Git Clone URL: https://aur.archlinux.org/kiibohd-configurator-git.git (read-only, click to copy)
Package Base: kiibohd-configurator-git
Description: Client Side Configuration & Flashing Software for Kiibohd compatible keyboards
Upstream URL: https://github.com/kiibohd/configurator
Keywords: configurator input keyboards
Licenses: GPL3
Conflicts: kiibohd-configurator
Provides: kiibohd-configurator
Submitter: gvelchuru
Maintainer: marcs
Last Packager: marcs
Votes: 2
Popularity: 0.22
First Submitted: 2019-03-18 23:19
Last Updated: 2020-08-30 09:24

Dependencies (3)

Required by (0)

Sources (1)

Latest Comments

mal commented on 2021-04-12 00:06

My build was dying with:

gyp ERR! stack Error: Command failed: /usr/bin/python -c import sys; print "%s.%s.%s" % sys.version_info[:3]; [...]
gyp ERR! stack SyntaxError: invalid syntax

Modern node-gyp supports python3, but the locked version of node-sass depends on node-gyp 3.x. I added yarn add --dev node-sass@"^5.0.0" after the cd in build(), and everything is working so far. Alternatively, install python2 (probably as a makedep).

ETA: It appears the release-next branch updates node-sass to ^5.0.0.

marcs commented on 2020-01-07 10:35

You should add nodejs-lts-erbium as a makedep since the package doesn't build with the latest nodejs for NaN incompatibility.