Package Details: kile-git 3.0b4_r3616.g2f49c0c8-1

Git Clone URL: (read-only, click to copy)
Package Base: kile-git
Description: A user friendly TeX/LaTeX frontend for KDE
Upstream URL:
Keywords: editor latex
Licenses: GPL-2.0-or-later
Conflicts: kile
Provides: kile
Submitter: vnoel
Maintainer: IslandC0der
Last Packager: IslandC0der
Votes: 24
Popularity: 0.000000
First Submitted: 2010-11-16 10:39 (UTC)
Last Updated: 2024-03-26 04:17 (UTC)

Latest Comments

1 2 3 4 5 6 Next › Last »

simonescalabrino commented on 2024-03-09 18:12 (UTC)

The current version does not work after the Plasma 6 upgrade.

I slightly adapted the PKGBUILD and it and works for me now:

Note that I simply removed qt6-script to make it work (the package does not exist), not sure if it is necessary for some features.

MarsSeed commented on 2024-03-02 19:20 (UTC)

Upstream master branch now seems to support Qt6/KF6.

They have ported the code away from the deprecated qt5-script, which was not carried over to Qt6.

MarsSeed commented on 2023-12-27 22:29 (UTC)

Please stop making empty pkgver bumps. This practice is disallowed by Arch package guidelines.

zoidberg commented on 2023-10-22 12:36 (UTC)

Could you change the depends and makedepends to the following? Some packages in the repos have been renamed.

depends=('kinit' 'texlive-core' 'okular>16.12.0' 'ktexteditor5' 'khtml' 'qt5-script')
makedepends=('git' 'extra-cmake-modules' 'kdoctools5' 'python')

Martchus commented on 2020-04-17 21:58 (UTC)

Thanks for updating. It seems the package needs qt5-script which is missing in the dependencies:

CMake Error at /usr/lib64/cmake/Qt5/Qt5Config.cmake:28 (find_package):
  Could not find a package configuration file provided by "Qt5Script" with
  any of the following names:


  Add the installation prefix of "Qt5Script" to CMAKE_PREFIX_PATH or set
  "Qt5Script_DIR" to a directory containing one of the above files.  If
  "Qt5Script" provides a separate development package or SDK, be sure it has
  been installed.
Call Stack (most recent call first):
  CMakeLists.txt:31 (find_package)

-- Configuring incomplete, errors occurred!

fclad commented on 2020-04-15 19:03 (UTC)

Hi, I am orphaning this package as I don't use Kile anymore!

fclad commented on 2017-06-30 14:25 (UTC)

Done. Thanks for your contribution!

Martchus commented on 2017-06-17 14:18 (UTC)

Dependency khtml is missing: ``` CMake Error at /usr/share/cmake-3.8/Modules/FindPackageHandleStandardArgs.cmake:137 (message): Could NOT find KF5 (missing: KHtml) (found suitable version "5.35.0", minimum required is "5.11") Call Stack (most recent call first): /usr/share/cmake-3.8/Modules/FindPackageHandleStandardArgs.cmake:377 (_FPHSA_FAILURE_MESSAGE) /usr/share/ECM/find-modules/FindKF5.cmake:110 (find_package_handle_standard_args) CMakeLists.txt:37 (find_package) -- Configuring incomplete, errors occurred! ```

sebsch commented on 2017-01-29 08:42 (UTC)

Having issues building this packet. Does anyone have a glue what is going so badly here? /usr/lib/ undefined reference to `qt_version_tag@Qt_5.7' /usr/lib/ undefined reference to `qt_version_tag@Qt_5.8' /usr/lib/ undefined reference to `QIODevice::isTransactionStarted() const@Qt_5' /usr/lib/ undefined reference to `QJsonObject::value(QLatin1String) const@Qt_5' /usr/lib/ undefined reference to `QJsonObject::contains(QLatin1String) const@Qt_5' /usr/lib/ undefined reference to `QIcon::fromTheme(QString const&)@Qt_5' /usr/lib/ undefined reference to `QJsonValue::toString() const@Qt_5' /usr/lib/ undefined reference to `QListWidget::setSelectionModel(QItemSelectionModel*)@Qt_5' /usr/lib/ undefined reference to `QString::resize(int, QChar)@Qt_5'

fclad commented on 2017-01-14 16:28 (UTC)

@naund changed!