Package Details: kile-git v2.1.r602.ge005e2a-1

Git Clone URL: https://aur.archlinux.org/kile-git.git (read-only)
Package Base: kile-git
Description: A TeX/LaTeX frontend for KDE
Upstream URL: http://kile.sourceforge.net/
Keywords: editor latex
Licenses: GPL2
Conflicts: kile
Provides: kile
Replaces: kile-svn
Submitter: vnoel
Maintainer: fclad
Last Packager: fclad
Votes: 24
Popularity: 0.007529
First Submitted: 2010-11-16 10:39
Last Updated: 2016-11-12 17:38

Required by (1)

  • keme (requires kile) (optional)

Sources (1)

Latest Comments

fclad commented on 2016-11-13 14:25

@prettyvanilla Thanks! I have updated the PKGBUILD

prettyvanilla commented on 2016-11-05 19:49

okular-frameworks-git has been deleted today, so the dependency needs to be changed to okular-git. Also, the install file shouldn't be needed anymore, as that is covered by hooks now.

Spyhawk commented on 2015-11-14 14:00

fclad> Works fine now. Thank you for the quick update!

fclad commented on 2015-11-14 13:37

@Spyhawk Sorry for this problem. I've just fixed the PKGBUILD. Please let me know if you have any problems.

Spyhawk commented on 2015-11-14 13:31

The pkgver seems incomplete. It is v2.1.r572.ga13b20 while it should be v2.1.r572.ga13b20c, according to the pkgver() function (note the ending "c").

As a result, helpers such as cower detect this package as having a newer version than the one locally installed, and they always try to update it.

fclad commented on 2015-06-30 23:03

I modified the PKGBUILD. Let me know if you have any problems.

arojas: I used your PKGBUILD as reference, so I added your name to the contributors list.

fclad commented on 2015-06-30 21:06

Thanks arojas, I'm working on that.

arojas commented on 2015-06-27 08:36

This is now ported to Qt5/KF5, please update dependencies

abulak commented on 2015-04-28 13:10

During compilation I got the following error:

In file included from /tmp/yaourt-tmp-kalmar/aur-kile-frameworks-git/src/kile/src/kile.cpp:58:0:
/usr/include/okular/interfaces/viewerinterface.h:13:31: fatal error: okularcore_export.h: No such file or directory
#include "okularcore_export.h"

I had to prefix/replace these by
#include <interfaces/okularcore_export.h>
etc...

is it known issue, or something is wrong with my installation??

btw commit
http://quickgit.kde.org/?p=kile.git&a=commit&h=cd5dec8933bc98fbe1df78843a2858c6ae024baf
fixed problems with live-preview & okular

Daedalus24 commented on 2015-04-04 18:13

@Corelli and @arojas:

Hello! It works if you install kile and kdegraphics-okular initially (implicitly the kde4 dependencies), followed by the step where you replace them with the corresponding git programs (kdelibs4support-git, kdepimlibs-git, etc.). Another anomaly lies in the fact that replacing kdegraphics-okular with okular-frameworks-git results in an error when compiling kile-frameworks-git. You have to install okular-git, then kile-frameworks-git, start kile so that it finds okular in the path, then replace okular-git with okular-frameworks-git.
Could not find a reasonable explanation, but it works this way.
All the best.

Anonymous comment on 2015-02-15 15:02

@arojas: ok. Thank you for your reply.

arojas commented on 2015-02-15 09:41

@Corelli try to get a backtrace and report it upstream, nothing I can do about it.

Anonymous comment on 2015-02-15 05:06

Hello arojas,
I have an error with this package (Segmentation Fault). Compilation seems to be ok but Kile crashes at startup.
Thanks.

$ kile
Could not find drkonqi at /usr/lib/drkonqi
QObject::connect: Cannot connect Kile::destroyed(QObject*) to (null)::quit()
kf5.kservice.sycoca: Trying to open ksycoca from "/home/corelli/.cache/ksycoca5"
QObject::connect: No such signal QTabWidget::testCanDecode(const QDragMoveEvent*, bool&)
QObject::connect: (receiver name: 'KileView::Manager')
QObject::connect: No such signal QTabWidget::receivedDropEvent(QDropEvent*)
QObject::connect: (receiver name: 'KileDocument::Manager')
QObject::connect: No such signal QTabWidget::receivedDropEvent(QWidget*, QDropEvent*)
QObject::connect: (receiver name: 'KileView::Manager')
QObject::connect: No such signal QTabWidget::mouseDoubleClick()
QObject::connect: (receiver name: 'KileDocument::Manager')
Shortcut for action "tag_tabulator" "Smart Tabulator" set with QAction::setShortcut()! Use KActionCollection::setDefaultShortcut(s) instead.
KSambaShare: Could not find smb.conf!
Calling notify on "Sound"
Changing audio state from Phonon::LoadingState to Phonon::StoppedState 
Calling notify on "Taskbar"
0 2097331
Changing audio state from Phonon::StoppedState to Phonon::LoadingState 
Changing audio state from Phonon::LoadingState to Phonon::StoppedState 
Changing audio state from Phonon::StoppedState to Phonon::LoadingState 
Changing audio state from Phonon::LoadingState to Phonon::BufferingState 
Changing audio state from Phonon::BufferingState to Phonon::PlayingState 
Changing audio state from Phonon::PlayingState to Phonon::BufferingState 
Changing audio state from Phonon::BufferingState to Phonon::PlayingState 
Changing audio state from Phonon::PlayingState to Phonon::StoppedState 
Closing notification 1
not found dbus id to close 1
Segmentation Fault (Core Dumped)

Anonymous comment on 2015-02-15 05:02

Hello arojas,
I have an error (Segmentation Fault (Core Dumped)) with this package.
Thanks.

$ kile
Could not find drkonqi at /usr/lib/drkonqi
QObject::connect: Cannot connect Kile::destroyed(QObject*) to (null)::quit()
kf5.kservice.sycoca: Trying to open ksycoca from "/home/lenny/.cache/ksycoca5"
QObject::connect: No such signal QTabWidget::testCanDecode(const QDragMoveEvent*, bool&)
QObject::connect: (receiver name: 'KileView::Manager')
QObject::connect: No such signal QTabWidget::receivedDropEvent(QDropEvent*)
QObject::connect: (receiver name: 'KileDocument::Manager')
QObject::connect: No such signal QTabWidget::receivedDropEvent(QWidget*, QDropEvent*)
QObject::connect: (receiver name: 'KileView::Manager')
QObject::connect: No such signal QTabWidget::mouseDoubleClick()
QObject::connect: (receiver name: 'KileDocument::Manager')
Shortcut for action "tag_tabulator" "Smart Tabulator" set with QAction::setShortcut()! Use KActionCollection::setDefaultShortcut(s) instead.
KSambaShare: Could not find smb.conf!
Calling notify on "Sound"
Changing audio state from Phonon::LoadingState to Phonon::StoppedState
Calling notify on "Taskbar"
0 2097331
Changing audio state from Phonon::StoppedState to Phonon::LoadingState
Changing audio state from Phonon::LoadingState to Phonon::StoppedState
Changing audio state from Phonon::StoppedState to Phonon::LoadingState
Changing audio state from Phonon::LoadingState to Phonon::BufferingState
Changing audio state from Phonon::BufferingState to Phonon::PlayingState
Changing audio state from Phonon::PlayingState to Phonon::BufferingState
Changing audio state from Phonon::BufferingState to Phonon::PlayingState
Changing audio state from Phonon::PlayingState to Phonon::StoppedState
Closing notification 1
not found dbus id to close 1
Erreur de segmentation (core dumped)

fclad commented on 2014-07-14 13:29

Standard version format. Sorry for the updates.

HotblackDesiato commented on 2014-06-30 05:16

Kile needs the package kdebase-katepart. Pls add this dependency to the package. Thanks.

fclad commented on 2013-12-11 03:16

Done.
Thanks for your contribution.

prettyvanilla commented on 2013-12-09 00:06

I updated the PKGBUILD to the current standards: http://pastebin.com/waFbBMUz
Could you please update your package?

fclad commented on 2013-08-15 21:12

Done

eshalygin commented on 2013-08-15 11:34

Could you, please, update the poppler dependency (poppler-qt -> poppler-qt4)?

fclad commented on 2013-03-20 16:23

Ok, thanks for the feedback. I'll keep an eye out.

Anonymous comment on 2013-03-20 15:59

Looks like texlive-core is flagged out of date since Dec 2012. He may have orphaned the whole meta package and sub packages.

gkey

Anonymous comment on 2013-03-20 15:54

I appreciate the help. I just turned off package signing to load the whole Texlive meta package. Remys key affects packages there too. Seeing as Texlive is in extra I would assume that they won't remain uninstallable with Package signing required for long. I will leave a message there also, now that the culprit has been reproduced.

gkey

Anonymous comment on 2013-03-20 11:18

FWIW kile in extra has the same issue with texlive-core.

gkey

Anonymous comment on 2013-03-20 11:16

I emailed a screenshot showing the item not found lines in Remys keyring.
I use: SigLevel = PackageRequired DatabaseNever
throughout my /etc/pacman.conf
and my system is up to date and only uses stock kernels from extra. All my other apps are from normal repos.

Thanks for the help. I appreciate it.

gkey

fclad commented on 2013-03-19 23:57

I'm working on that.

Anonymous comment on 2013-03-19 18:50

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

There appears to be multiple keysigners for the kile, kile-git packages. The dependency for texlive-core will not work on either of the above. A keysigner by the name of REMY signs texlive. Please update the top 5-6 lines for what look to be signature spots are mangled. gkey
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.19 (GNU/Linux)

iQIcBAEBAgAGBQJRSLNsAAoJEEl9Bby9yD58gCUQAJ9TA5a87ZIMkLpPoQXJM/ht
skLP+mdOXjLySkW445IpMfK18KAejWptTd/TmfbqSNhbcfJwZ+XTD+yw3pm/wqbc
rcEKP/GigUOAUnCNM667qnGQfoQfGviRRPeMtGGc3iMVnAMl2w6px//RWslDp1/T
WNmTCFwVidYjxUXM0cv37pUtB4gDBGE2Z4gwYulNqOhdfviG19JoELX5LYpj1t4K
74YtEhEH1WN51CKyhgYfF8FGIBdd7QlKF2nCVkOddkZdL/wj6QJepgJ5W+uPL2Nx
6lw2ywSKSBiZC9dMm4PpcrmaUxKmzCr5gdWwSJkyT0TWbIPw5uO7HNGZnJTfp+tC
EVZhEFlLNupn94IQfZl6PcZajlKjHXbbPW5ZChBkQCsjKuFz16sSQnuadgZF8YYO
WfOQbHnpSGrCx75MmNR0ucXPMEdC0DduysQWZn2uyp7dobBXMq5gDX0OMtp5H+4X
f92omlztDnR8cbrAljfcGyAiGM4SSmmjq/wLgajjCH9zffxUW7+hOeZSxpn0sEOX
kYN3WWvvOUV0l3uli4YEM7huibtaXTPuTN7DpcmzjiP9TTr2Hi0KqLwDUG8MMd71
FTqOaK2yUQaqe+kcXwHA/a0HpxKGcvCmlNGJ3lV5m6NZxkYalQznrq2lWbqnNPJ1
aQZyITbsyTEEFJ8bS9s3
=M1UF
-----END PGP SIGNATURE-----

fclad commented on 2013-03-06 12:45

Thanks, it's done. I hope everything will go well.

vnoel commented on 2013-03-06 09:03

haha, so just take the position, it's already available, and you will see, it's really not a difficult job :P

fclad commented on 2013-03-06 08:48

It could be a good opportunity to start my career as a maintainer :D.

vnoel commented on 2013-03-05 17:21

Hi, I updated the PKGBUILD.

Also, I don't have time to maintain that package (and I don't use it anymore actually…)

If someone is interested, I'm leaving the maintainer place :)

fclad commented on 2013-03-05 15:31

Hi. Adding -DQT_QMAKE_EXECUTABLE=qmake-qt4 to cmake seems to solve the problem.

vnoel commented on 2013-03-04 11:36

Hi, yes, I'm going to take a look at it, but I don't have much time lately.
Until that time, if you want to take a look and propose a workaround, you can :)

fclad commented on 2013-03-03 16:46

After qt replacement in [extra], the package doesn't compile. I think it is because qt5 is used. I got

-- Found Qt-Version 5.0.1 (using /usr/bin/qmake)

before the error

fclad commented on 2013-03-03 16:45

After qt replacement in [extra], the package doesn't compile. I think it is because qt5 is used. I got

-- Found Qt-Version 5.0.1 (using /usr/bin/qmake)

before the error


fclad commented on 2013-03-03 16:42

After qt replacement in [extra], the package doesn't compile. I think it is because qt5 is used. I got

-- Found Qt-Version 5.0.1 (using /usr/bin/qmake)

before the error


vnoel commented on 2012-05-05 05:31

Hi, I followed the dependencies included in the package from arch.
I also added poppler-qt which seemed to be needed as namcap told me.

If there is a problem with kdebase4-kate-git, tell me, but it should normally be fixed on the package, not kile I guess…

Anonymous comment on 2012-05-04 14:10

Hrmm its the part at the end of the PKGBUILD, the package_kdebase-4-kate-git() function that made me think it conflicted. And thank you =)

vnoel commented on 2012-05-03 20:10

Well, I don't see any conflict with katepart in kdebase4-kate-git... I will check tomorrow and update the PKGBUILD as needed :)
Thanks

Anonymous comment on 2012-05-03 19:52

Edit: Not that experienced playing with PKGBUILDS but the package kdebase-katepart seems to work, however it would then conflict with the kdebase4-kate-git development version, which doesn't provide or replace the kdebase-katepart, just conflicts with it.

Anonymous comment on 2012-05-03 19:21

I think kate should be pulled in as a dependency? I don't think there's a way to untangle them and it keeps erroring out: "No editor component found, please check your KDE installation."

vnoel commented on 2011-05-17 07:48

cleaned a bit the pkgbuild

vnoel commented on 2011-02-01 10:42

Ok, updated, the update should be smooth, I used "git config remote.origin.url" to update the remote url :)

vnoel commented on 2011-02-01 06:53

Ok, that's why it wasn't working for me also, I thought it was a firewall and proxy problem, so I just changed to http, I didn't notice the git:// one had changed!

I will update that, the problem is for already cloned repository kept by yaourt… People will have to delete them

big_gie commented on 2011-01-31 18:35

I had to change _gitroot to "git://anongit.kde.org/kile.git" as shown on http://quickgit.kde.org/?p=kile.git&a=summary

vnoel commented on 2011-01-14 09:50

Done, I also updated the version since it is a git package, sorry for those who just compiled it :)

stativ commented on 2011-01-13 17:48

Please add docbook-xml to makedepends.