Package Details: kio-gdrive-git 1.2.4.r82.gecf8a41-2

Git Clone URL: https://aur.archlinux.org/kio-gdrive-git.git (read-only, click to copy)
Package Base: kio-gdrive-git
Description: KIO Slave to access Google Drive
Upstream URL: https://projects.kde.org/kio-gdrive
Licenses: GPL
Conflicts: kio-gdrive
Provides: kio-gdrive
Submitter: arojas
Maintainer: Aetf
Last Packager: Aetf
Votes: 6
Popularity: 0.017197
First Submitted: 2016-08-09 12:27
Last Updated: 2018-10-17 17:37

Latest Comments

Aetf commented on 2020-04-06 00:18

@billypilgrim you probably need kaccounts-providers-git rather than kaccounts-providers.

billypilgrim commented on 2020-04-02 17:11

I'm getting a build issue :-(

/tmp/trizen-alex/kio-gdrive-git/src/kio-gdrive/kaccounts/kaccountsplugin.cpp: In constructor ‘GoogleDrivePlugin::GoogleDrivePlugin(QObject*, const QVariantList&)’:
/tmp/trizen-alex/kio-gdrive-git/src/kio-gdrive/kaccounts/kaccountsplugin.cpp:33:36: error: no matching function for call to ‘KAccountsDPlugin::KAccountsDPlugin(QObject*&, const QVariantList&)’
   33 |     : KAccountsDPlugin(parent, args)
      |                                    ^
In file included from /usr/include/KAccounts/KAccountsDPlugin:1,
                 from /tmp/trizen-alex/kio-gdrive-git/src/kio-gdrive/kaccounts/kaccountsplugin.h:22,
                 from /tmp/trizen-alex/kio-gdrive-git/src/kio-gdrive/kaccounts/kaccountsplugin.cpp:20:
/usr/include/KAccounts/kaccountsdplugin.h:57:5: note: candidate: ‘KAccountsDPlugin::KAccountsDPlugin(QObject*)’
   57 |     KAccountsDPlugin(QObject *parent = nullptr);
      |     ^~~~~~~~~~~~~~~~
/usr/include/KAccounts/kaccountsdplugin.h:57:5: note:   candidate expects 1 argument, 2 provided
make[2]: *** [kaccounts/CMakeFiles/kaccounts_gdrive.dir/build.make:93: kaccounts/CMakeFiles/kaccounts_gdrive.dir/kaccountsplugin.cpp.o] Error 1

sagittarius commented on 2018-08-31 06:31

Just for info: I managed to get it working but I had to remove Oracle JDK and replace it by OpenJDK. Otherwise I could not authentify.

sl1pkn07 commented on 2017-03-29 23:26

please add kio-gdrive to conflicts=() / provides=()

ceri commented on 2016-08-30 06:46

Last working revision:

source=("git://anongit.kde.org/$_gitname.git#commit=8231017")

ceri commented on 2016-08-30 06:38

Doesn't build requires libkgapi 5.3.0+ from kde-unstable.