Package Details: kipi-plugins-git r11750.0e0e4f5-1

Git Clone URL: https://aur.archlinux.org/kipi-plugins-git.git (read-only)
Package Base: kipi-plugins-git
Description: A collection of plugins extending the KDE graphics and image applications as digiKam
Upstream URL: http://www.kipi-plugins.org/
Licenses: GPL, LGPL, FDL
Groups: digikamsc-git
Conflicts: kipi-plugins
Provides: kipi-plugins
Submitter: flamelab
Maintainer: Sevenseven
Last Packager: Sevenseven
Votes: 19
Popularity: 0.002164
First Submitted: 2011-02-06 11:08
Last Updated: 2016-09-16 08:23

Dependencies (14)

Required by (3)

Sources (1)

Latest Comments

Sevenseven commented on 2016-07-26 20:34

Pushed in master.

lexikon commented on 2016-07-17 12:03

maybe possible update to last branch with last patches?
Fixed o2auth with imgur service and another...
https://bugs.kde.org/show_bug.cgi?id=360404

desaparecido commented on 2016-02-09 21:33

hi, I'm using the workaround used in repos package and is only adding this line in cmake in PKGBUILD

-DCMAKE_C_COMPILER=clang # Fix error: C++ style comments are not allowed in ISO C90

is easier, and off course, you need to have "clang" to successfully build

jat255 commented on 2016-02-08 22:31

To get this to work, I had to recompile flex, like suggested by @Sevenseven.

To do that, I made a new directory (~/builds/flex) and put the following files in it:
PKGBUILD: http://paste.pound-python.org/show/lSHrvjtnrQrPOk3w78xA/
flex.install: http://paste.pound-python.org/show/gk1gJphVEtKmFniBvJPE/
flex.skl.patch: http://paste.pound-python.org/show/UbqniNWZJTn3xYwStgWo/

From that directory (with the three files), run `makepkg`, wait for it to finish, then install the package with `pacman -U flex-2.6.0-2-x86_64.pkg.tar.xz`

Doing this allowed me to install the kipi-plugins with no problem.

Sevenseven commented on 2016-02-05 08:22

@lexikon
Take pkgbuild and patch from pastebin(link bellow), put them in same dir and run makepkg.

lexikon commented on 2016-02-04 20:49

@Sevenseven
Sorry for my eng, but can you explain how rebuild flex.
I tried command 'yaourt -Sb flex'
but get error
-----
curl: (22) The requested URL returned error: 404 Not Found
-----

Sevenseven commented on 2016-02-04 11:07

@lexikon
Rebuild flex: http://pastebin.com/dpjPiWcf

lexikon commented on 2016-02-04 10:47

@Sevenseven
-------
From your url I found patch and I see
- num_to_alloc = 1; // After all that talk, this was set to 1 anyways...
+ num_to_alloc = 1; /* After all that talk, this was set to 1 anyways... */
-------
How I can compile kipi plugins without error? I tried to modify the files in the /tmp directory but after restarting the installation, all files are deleted and downloaded again

Sevenseven commented on 2016-01-30 11:27

@lexikon
It`s not a kipi problem https://crux.nu/bugs/index.php?do=details&task_id=1284

lexikon commented on 2016-01-28 20:42

Please fix this

[ 80%] Building C object panorama/CMakeFiles/libpanorama.dir/panoScanner.c.o
/tmp/yaourt-tmp-roman/aur-kipi-plugins-git/src/build/panorama/panoScanner.c: В функции «yyensure_buffer_stack»:
/tmp/yaourt-tmp-roman/aur-kipi-plugins-git/src/build/panorama/panoScanner.c:1920:21: ошибка: комментарии в стиле C++ не разрешены в ISO C90
num_to_alloc = 1; // After all that talk, this was set to 1 anyways...

Comment "// After ..." not allowed
C++ style comments are not allowed in ISO C90

lexikon commented on 2016-01-28 19:45

I found a little trouble with imgur export...Request autorization not work properly

========== KQOAuthRequest has the following base string:
"POST&https%3A%2F%2Fapi.imgur.com%2Foauth%2Frequest_token&oauth_callback%3Dhttp%253A%252F%252Flocalhost%253A48412%26oauth_consumer_key%3D9ad9d48124b7137d9cc9e0397219f52004fcba12a%26oauth_nonce%3D1419787434%26oauth_signature_method%3DHMAC-SHA1%26oauth_timestamp%3D1454009916%26oauth_version%3D1.0"

========== KQOAuthRequest has the following signature:
* Signature : "XomdyJ%2BGQfEFJzTTNy58mivNHfI%3D"

("Authorization", "Content-Type")
"OAuth oauth_callback=\"http%3A%2F%2Flocalhost%3A48412\", oauth_signature_method=\"HMAC-SHA1\", oauth_consumer_key=\"9ad9d48124b7137d9cc9e0397219f52004fcba12a\", oauth_version=\"1.0\", oauth_timestamp=\"1454009916\", oauth_nonce=\"1419787434\", oauth_signature=\"XomdyJ%2BGQfEFJzTTNy58mivNHfI%3D\""
"application/x-www-form-urlencoded"


My screenshot is not exported to imgur

sl1pkn07 commented on 2016-01-05 17:16

Hi

i drop the Qt4 support for kqoauth and change the name of the packages (kqoauth-git is now only Qt5 version), please update the dependencies

greetings

Sevenseven commented on 2015-11-17 16:04

Ty, fixed.

davispuh commented on 2015-11-10 18:49

getting
Invalid syntax for optdepend: 'kqoauth-qt5-git For Imgur Auhtenticated API'

you need a colon there, like 'kqoauth-qt5-git: For Imgur Auhtenticated API'

Sevenseven commented on 2015-10-29 06:36

Updated.

tajidinabd commented on 2015-10-26 21:00

this commit https://quickgit.kde.org/?p=kipi-plugins.git&a=commit&h=ce54bf66255d153fbba33948d8be0a4f7b60a9f3 makes karchive and threadweaver an optional dependencies.

tajidinabd commented on 2015-10-26 06:11

https://aur.archlinux.org/packages/kqoauth-qt5-git/ this is a new optional dependency for kipi-plugins-git according to this git commit : https://quickgit.kde.org/?p=kipi-plugins.git&a=commit&h=6ba02d3b8a891d386a6af333c0fbd12f5db4ee19

Sevenseven commented on 2015-10-20 10:26

Enable mediawiki&vkontake by default.

desaparecido commented on 2015-10-19 06:37

about my last message, with the latest commit of libmediawiki-git (https://quickgit.kde.org/?p=libmediawiki.git&a=commit&h=4c3d19b76b68338e54914b8b7c7aa575d0345a6e) all builds fine now. ;-)

desaparecido commented on 2015-10-18 12:53

thanks for update the PKGBUILD ;-)

I'm using git versions of kf5 and plasma, and when try to build this package I have this error:

/tmp/makepkg/kipi-plugins-git/src/kipi-plugins/mediawiki/wikimediajob.cpp:43:28: fatal error: MediaWiki/Upload: No such file or directory
compilation terminated.
mediawiki/CMakeFiles/kipiplugin_wikimedia.dir/build.make:110: recipe for target 'mediawiki/CMakeFiles/kipiplugin_wikimedia.dir/wikimediajob.cpp.o' failed
make[2]: *** [mediawiki/CMakeFiles/kipiplugin_wikimedia.dir/wikimediajob.cpp.o] Error 1
[ 88%] Building CXX object panorama/CMakeFiles/libpanorama.dir/tasks/task.cpp.o
[ 88%] Building CXX object panorama/CMakeFiles/libpanorama.dir/importwizard/previewpage.cpp.o
[ 88%] Building CXX object vkontakte/CMakeFiles/kipiplugin_vkontakte.dir/authinfowidget.cpp.o
[ 89%] Building CXX object advancedslideshow/CMakeFiles/kipiplugin_advancedslideshow.dir/widgets/slideshow.cpp.o
/tmp/makepkg/kipi-plugins-git/src/kipi-plugins/mediawiki/wmwindow.cpp:48:27: fatal error: MediaWiki/Login: No such file or directory
compilation terminated.
mediawiki/CMakeFiles/kipiplugin_wikimedia.dir/build.make:134: recipe for target 'mediawiki/CMakeFiles/kipiplugin_wikimedia.dir/wmwindow.cpp.o' failed
make[2]: *** [mediawiki/CMakeFiles/kipiplugin_wikimedia.dir/wmwindow.cpp.o] Error 1
[ 90%] Building CXX object panorama/CMakeFiles/libpanorama.dir/tasks/commandtask.cpp.o
In file included from /tmp/makepkg/kipi-plugins-git/src/build/mediawiki/moc_plugin_wikimedia.cpp:9:0,
from /tmp/makepkg/kipi-plugins-git/src/build/mediawiki/kipiplugin_wikimedia_automoc.cpp:2:
/tmp/makepkg/kipi-plugins-git/src/build/mediawiki/../../kipi-plugins/mediawiki/plugin_wikimedia.h:37:27: fatal error: MediaWiki/Login: No such file or directory
compilation terminated.
[ 90%] Building CXX object panorama/CMakeFiles/libpanorama.dir/tasks/preprocesstask.cpp.o
mediawiki/CMakeFiles/kipiplugin_wikimedia.dir/build.make:158: recipe for target 'mediawiki/CMakeFiles/kipiplugin_wikimedia.dir/kipiplugin_wikimedia_automoc.cpp.o' failed
make[2]: *** [mediawiki/CMakeFiles/kipiplugin_wikimedia.dir/kipiplugin_wikimedia_automoc.cpp.o] Error 1
CMakeFiles/Makefile2:2519: recipe for target 'mediawiki/CMakeFiles/kipiplugin_wikimedia.dir/all' failed
make[1]: *** [mediawiki/CMakeFiles/kipiplugin_wikimedia.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....

even with uncommented libmediawiki-git line, somebody else ? or I missing something ?

;-)

blackhole commented on 2015-08-20 12:00

Now is fixed, thank you

desaparecido commented on 2015-08-20 09:59

@blackhole , try again, latest commit was successfully builded ;-) ... fixed in upstream I suppose

blackhole commented on 2015-08-19 09:07

I cannot compile. At some time have this error:

fatal error: ui_flickralbumdialog.h: File o directory non esistente

desaparecido commented on 2015-07-09 10:57

hi, since some days I have this error:

[ 89%] Building CXX object googleservices/CMakeFiles/kipiplugin_googleservices.dir/gswindow.cpp.o
[ 90%] Building CXX object dlnaexport/extra/hupnp_av/CMakeFiles/HUpnpAv.dir/src/cds_model/model_mgmt/hcds_dlite_serializer.cpp.o
/tmp/makepkg/kipi-plugins-frameworks-git/src/kipi-plugins/googleservices/gswindow.cpp:54:21: fatal error: kwallet.h: No such file or directory
compilation terminated.
googleservices/CMakeFiles/kipiplugin_googleservices.dir/build.make:192: recipe for target 'googleservices/CMakeFiles/kipiplugin_googleservices.dir/gswindow.cpp.o' failed
make[2]: *** [googleservices/CMakeFiles/kipiplugin_googleservices.dir/gswindow.cpp.o] Error 1
CMakeFiles/Makefile2:3538: recipe for target 'googleservices/CMakeFiles/kipiplugin_googleservices.dir/all' failed
make[1]: *** [googleservices/CMakeFiles/kipiplugin_googleservices.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 90%] [ 91%] Building CXX object dlnaexport/extra/hupnp_av/CMakeFiles/HUpnpAv.dir/src/cds_model/model_mgmt/hcdsobjectdata_p.cpp.o
Building CXX object calendar/CMakeFiles/kipiplugin_calendar.dir/wizard/calwizard.cpp.o
/tmp/makepkg/kipi-plugins-frameworks-git/src/kipi-plugins/dlnaexport/extra/hupnp_av/src/cds_model/model_mgmt/hcdsproperties.cpp:83:6: warning: ‘bool Herqq::Upnp::Av::{anonymous}::lessThan(const Herqq::Upnp::Av::HCdsPropertyInfo*, const Herqq::Upnp::Av::HCdsPropertyInfo*)’ defined but not used [-Wunused-function]
bool lessThan(const HCdsPropertyInfo* obj1, const HCdsPropertyInfo* obj2)


I have qjson-qt5-git installed, but I don't know if is about that package (googleservices plugin) or is in kipi-plugins upstream, or if I missing something

thanks ;-)

sl1pkn07 commented on 2015-06-07 10:53

why? only need reinstall the pakage

FadeMind commented on 2015-06-07 10:04

Please upgrade version to: 5.0.0.r10369.d56650d

Sevenseven commented on 2013-02-07 18:18

>Found KDE 4.9
Should be 4.10

Anonymous comment on 2013-02-01 22:20

I'm getting the fallowing when building:

-- Found libkdcraw: /usr/lib64/libkdcraw.so
CMake Warning at CMakeLists.txt:145 (MESSAGE):
libkdcraw: Version information not found, your version is probably too old.

but I have libkdcraw from git already installed.

My whole log: http://pastebin.com/StMzjvim

sl1pkn07 commented on 2012-12-30 10:02

please add provides=('kipi-plugins')

greetings

Sevenseven commented on 2012-10-06 19:47

Update kipi dependencies fist,also please use something like pastebin.

paulbarbee commented on 2012-10-06 18:51

I'm getting the following when trying tpo update kipi-plugins-git:


[ 2%] Building CXX object timeadjust/CMakeFiles/kipiplugin_timeadjust.dir/plugin_timeadjust.o
/var/abs/local/yaourtbuild/kipi-plugins-git/src/kipi-plugins/timeadjust/plugin_timeadjust.cpp: In constructor ‘KIPITimeAdjustPlugin::Plugin_TimeAdjust::Plugin_TimeAdjust(QObject*, const QVariantList&)’:
/var/abs/local/yaourtbuild/kipi-plugins-git/src/kipi-plugins/timeadjust/plugin_timeadjust.cpp:74:47: error: ‘setUiBaseName’ was not declared in this scope
/var/abs/local/yaourtbuild/kipi-plugins-git/src/kipi-plugins/timeadjust/plugin_timeadjust.cpp:75:14: error: ‘setupXML’ was not declared in this scope
/var/abs/local/yaourtbuild/kipi-plugins-git/src/kipi-plugins/timeadjust/plugin_timeadjust.cpp: In member function ‘virtual void KIPITimeAdjustPlugin::Plugin_TimeAdjust::setup(QWidget*)’:
/var/abs/local/yaourtbuild/kipi-plugins-git/src/kipi-plugins/timeadjust/plugin_timeadjust.cpp:88:20: error: ‘interface’ was not declared in this scope
/var/abs/local/yaourtbuild/kipi-plugins-git/src/kipi-plugins/timeadjust/plugin_timeadjust.cpp:94:43: error: ‘interface’ was not declared in this scope
/var/abs/local/yaourtbuild/kipi-plugins-git/src/kipi-plugins/timeadjust/plugin_timeadjust.cpp: In member function ‘void KIPITimeAdjustPlugin::Plugin_TimeAdjust::setupActions()’:
/var/abs/local/yaourtbuild/kipi-plugins-git/src/kipi-plugins/timeadjust/plugin_timeadjust.cpp:103:36: error: ‘setDefaultCategory’ was not declared in this scope
/var/abs/local/yaourtbuild/kipi-plugins-git/src/kipi-plugins/timeadjust/plugin_timeadjust.cpp:113:47: error: no matching function for call to ‘KIPITimeAdjustPlugin::Plugin_TimeAdjust::addAction(const char [11], KAction*&)’
/var/abs/local/yaourtbuild/kipi-plugins-git/src/kipi-plugins/timeadjust/plugin_timeadjust.cpp:113:47: note: candidate is:
In file included from /var/abs/local/yaourtbuild/kipi-plugins-git/src/kipi-plugins-build/timeadjust/../../kipi-plugins/timeadjust/plugin_timeadjust.h:33:0,
from /var/abs/local/yaourtbuild/kipi-plugins-git/src/kipi-plugins-build/timeadjust/plugin_timeadjust.moc:10,
from /var/abs/local/yaourtbuild/kipi-plugins-git/src/kipi-plugins/timeadjust/plugin_timeadjust.cpp:24:
/usr/include/libkipi/plugin.h:79:10: note: void KIPI::Plugin::addAction(KAction*)
/usr/include/libkipi/plugin.h:79:10: note: candidate expects 1 argument, 2 provided
/var/abs/local/yaourtbuild/kipi-plugins-git/src/kipi-plugins/timeadjust/plugin_timeadjust.cpp: In member function ‘void KIPITimeAdjustPlugin::Plugin_TimeAdjust::slotActivate()’:
/var/abs/local/yaourtbuild/kipi-plugins-git/src/kipi-plugins/timeadjust/plugin_timeadjust.cpp:118:40: error: ‘interface’ was not declared in this scope
In file included from /usr/include/klibloader.h:29:0,
from /usr/include/kgenericfactory.h:22,
from /var/abs/local/yaourtbuild/kipi-plugins-git/src/kipi-plugins/timeadjust/plugin_timeadjust.cpp:33:
/usr/include/kpluginfactory.h: In instantiation of ‘static QObject* KPluginFactory::createInstance(QWidget*, QObject*, const QVariantList&) [with impl = KIPITimeAdjustPlugin::Plugin_TimeAdjust; ParentType = QObject; QObject = QObject; QVariantList = QList<QVariant>]’:
/usr/include/kpluginfactory.h:495:70: required from ‘QObject* (* KPluginFactory::InheritanceChecker<impl>::createInstanceFunction(...))(QWidget*, QObject*, const QVariantList&) [with impl = KIPITimeAdjustPlugin::Plugin_TimeAdjust; KPluginFactory::CreateInstanceFunction = QObject* (*)(QWidget*, QObject*, const QList<QVariant>&); QObject = QObject; QVariantList = QList<QVariant>]’
/var/abs/local/yaourtbuild/kipi-plugins-git/src/kipi-plugins/timeadjust/plugin_timeadjust.cpp:51:1: required from here
/usr/include/kpluginfactory.h:477:32: error: cannot allocate an object of abstract type ‘KIPITimeAdjustPlugin::Plugin_TimeAdjust’
In file included from /var/abs/local/yaourtbuild/kipi-plugins-git/src/kipi-plugins-build/timeadjust/plugin_timeadjust.moc:10:0,
from /var/abs/local/yaourtbuild/kipi-plugins-git/src/kipi-plugins/timeadjust/plugin_timeadjust.cpp:24:
/var/abs/local/yaourtbuild/kipi-plugins-git/src/kipi-plugins-build/timeadjust/../../kipi-plugins/timeadjust/plugin_timeadjust.h:40:7: note: because the following virtual functions are pure within ‘KIPITimeAdjustPlugin::Plugin_TimeAdjust’:
In file included from /var/abs/local/yaourtbuild/kipi-plugins-git/src/kipi-plugins-build/timeadjust/../../kipi-plugins/timeadjust/plugin_timeadjust.h:33:0,
from /var/abs/local/yaourtbuild/kipi-plugins-git/src/kipi-plugins-build/timeadjust/plugin_timeadjust.moc:10,
from /var/abs/local/yaourtbuild/kipi-plugins-git/src/kipi-plugins/timeadjust/plugin_timeadjust.cpp:24:
/usr/include/libkipi/plugin.h:75:24: note: virtual KIPI::Category KIPI::Plugin::category(KAction*) const
make[2]: *** [timeadjust/CMakeFiles/kipiplugin_timeadjust.dir/plugin_timeadjust.o] Error 1
make[1]: *** [timeadjust/CMakeFiles/kipiplugin_timeadjust.dir/all] Error 2
make: *** [all] Error 2

Sevenseven commented on 2011-11-10 08:42

Fixed.

Anonymous comment on 2011-11-09 18:38

The install field should not be an array, but a single string: install='kipi-plugins-git.install'. Otherwise makepkg complains that it couldn't find file ('kipi-plugins-git.install').

Sevenseven commented on 2011-06-23 01:48

Ok

alphazo commented on 2011-06-22 21:20

Thanks. That did the trick!

Sevenseven commented on 2011-06-22 12:20

Try to update libkmap-git.

alphazo commented on 2011-06-22 06:21

here it is:

Scanning dependencies of target kipiplugin_gpssync
[ 95%] Building CXX object gpssync/CMakeFiles/kipiplugin_gpssync.dir/kipiplugin_gpssync_automoc.o
[ 95%] Building CXX object gpssync/CMakeFiles/kipiplugin_gpssync.dir/gpssyncdialog.o
In file included from /tmp/yaourt-tmp-alpha/aur-kipi-plugins-git/src/kipi-plugins/gpssync/gpssyncdialog.cpp:100:0:
/tmp/yaourt-tmp-alpha/aur-kipi-plugins-git/src/kipi-plugins/gpssync/gpslistviewcontextmenu.h:34:37: fatal error: libkmap/lookup_altitude.h: No such file or directory
compilation terminated.
make[2]: *** [gpssync/CMakeFiles/kipiplugin_gpssync.dir/gpssyncdialog.o] Error 1
make[1]: *** [gpssync/CMakeFiles/kipiplugin_gpssync.dir/all] Error 2
make: *** [all] Error 2

Sevenseven commented on 2011-06-22 00:02

Log is not full, cd to the build dir, run make -j1 and find Error 1(and few line above).

alphazo commented on 2011-06-21 20:19

I'm getting the following error:
..
[ 88%] Building CXX object dngconverter/CMakeFiles/libdng.dir/dngwriter/extra/dng_sdk/dng_tone_curve.o
[ 88%] Building CXX object dngconverter/CMakeFiles/libdng.dir/dngwriter/extra/dng_sdk/dng_hue_sat_map.o
[ 89%] Building CXX object dngconverter/CMakeFiles/libdng.dir/dngwriter/extra/dng_sdk/dng_pthread.o
Linking CXX static library ../lib/liblibdng.a
[ 89%] Built target libdng
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build kipi-plugins-git.

Sevenseven commented on 2011-03-14 09:27

update

Sevenseven commented on 2011-03-13 15:25

kdegraphics-libs is too old, i think i need to create a few pkguilds(for libkdcraw, libkexiv2 and etc)

alphazo commented on 2011-03-13 14:02

I now get the following error:
Scanning dependencies of target raw2dng
[ 1%] Building CXX object dngconverter/test/CMakeFiles/raw2dng.dir/raw2dng_automoc.o
[ 1%] Building CXX object dngconverter/test/CMakeFiles/raw2dng.dir/__/dngwriter/dngwriter.o
[ 1%] Building CXX object dngconverter/test/CMakeFiles/dngvalidate.dir/__/dngwriter/extra/xmp_sdk/XMPCore/XMPCore_Impl.o
[ 2%] Building CXX object common/libkipiplugins/CMakeFiles/kipiplugins.dir/dialogs/imagedialog.o
/tmp/yaourt-tmp-alpha/aur-kipi-plugins-git/src/kipi-plugins/dngconverter/dngwriter/dngwriter.cpp: In member function ‘int DNGIface::DNGWriter::convert()’:
/tmp/yaourt-tmp-alpha/aur-kipi-plugins-git/src/kipi-plugins/dngconverter/dngwriter/dngwriter.cpp:548:68: erreur: ‘class KDcrawIface::DcrawInfoContainer’ has no member named ‘blackPointCh’
/tmp/yaourt-tmp-alpha/aur-kipi-plugins-git/src/kipi-plugins/dngconverter/dngwriter/dngwriter.cpp:549:68: erreur: ‘class KDcrawIface::DcrawInfoContainer’ has no member named ‘blackPointCh’
/tmp/yaourt-tmp-alpha/aur-kipi-plugins-git/src/kipi-plugins/dngconverter/dngwriter/dngwriter.cpp:550:68: erreur: ‘class KDcrawIface::DcrawInfoContainer’ has no member named ‘blackPointCh’
/tmp/yaourt-tmp-alpha/aur-kipi-plugins-git/src/kipi-plugins/dngconverter/dngwriter/dngwriter.cpp:551:68: erreur: ‘class KDcrawIface::DcrawInfoContainer’ has no member named ‘blackPointCh’
/tmp/yaourt-tmp-alpha/aur-kipi-plugins-git/src/kipi-plugins/dngconverter/dngwriter/dngwriter.cpp:834:72: erreur: no matching function for call to ‘KExiv2Iface::KExiv2::getExifTagLong(const char [26], long int&, int)’
/usr/include/libkexiv2/kexiv2.h:477:10: note: candidate is: bool KExiv2Iface::KExiv2::getExifTagLong(const char*, long int&) const
/tmp/yaourt-tmp-alpha/aur-kipi-plugins-git/src/kipi-plugins/dngconverter/dngwriter/dngwriter.cpp:835:72: erreur: no matching function for call to ‘KExiv2Iface::KExiv2::getExifTagLong(const char [26], long int&, int)’
/usr/include/libkexiv2/kexiv2.h:477:10: note: candidate is: bool KExiv2Iface::KExiv2::getExifTagLong(const char*, long int&) const
/tmp/yaourt-tmp-alpha/aur-kipi-plugins-git/src/kipi-plugins/dngconverter/dngwriter/dngwriter.cpp:836:72: erreur: no matching function for call to ‘KExiv2Iface::KExiv2::getExifTagLong(const char [26], long int&, int)’
/usr/include/libkexiv2/kexiv2.h:477:10: note: candidate is: bool KExiv2Iface::KExiv2::getExifTagLong(const char*, long int&) const
/tmp/yaourt-tmp-alpha/aur-kipi-plugins-git/src/kipi-plugins/dngconverter/dngwriter/dngwriter.cpp:837:72: erreur: no matching function for call to ‘KExiv2Iface::KExiv2::getExifTagLong(const char [26], long int&, int)’
/usr/include/libkexiv2/kexiv2.h:477:10: note: candidate is: bool KExiv2Iface::KExiv2::getExifTagLong(const char*, long int&) const
/tmp/yaourt-tmp-alpha/aur-kipi-plugins-git/src/kipi-plugins/dngconverter/dngwriter/dngwriter.cpp:851:67: erreur: no matching function for call to ‘KExiv2Iface::KExiv2::getExifTagLong(const char [21], long int&, int)’
/usr/include/libkexiv2/kexiv2.h:477:10: note: candidate is: bool KExiv2Iface::KExiv2::getExifTagLong(const char*, long int&) const
/tmp/yaourt-tmp-alpha/aur-kipi-plugins-git/src/kipi-plugins/dngconverter/dngwriter/dngwriter.cpp:963:78: erreur: no matching function for call to ‘KExiv2Iface::KExiv2::getExifTagLong(const char [21], long int&, int)’
/usr/include/libkexiv2/kexiv2.h:477:10: note: candidate is: bool KExiv2Iface::KExiv2::getExifTagLong(const char*, long int&) const
/tmp/yaourt-tmp-alpha/aur-kipi-plugins-git/src/kipi-plugins/dngconverter/dngwriter/dngwriter.cpp:964:78: erreur: no matching function for call to ‘KExiv2Iface::KExiv2::getExifTagLong(const char [21], long int&, int)’
/usr/include/libkexiv2/kexiv2.h:477:10: note: candidate is: bool KExiv2Iface::KExiv2::getExifTagLong(const char*, long int&) const
[ 2%] make[2]: *** [dngconverter/test/CMakeFiles/raw2dng.dir/__/dngwriter/dngwriter.o] Erreur 1
make[1]: *** [dngconverter/test/CMakeFiles/raw2dng.dir/all] Erreur 2

alphazo commented on 2011-03-12 17:56

I have the same error:
==> Starting make for: kipi-plugins-git
error: pathspec 'development/2.0' did not match any file(s) known to git.

Version fetched is 20110312 so I guess PKGBUILD is out of date (not the source material).

Anonymous comment on 2011-03-09 15:24

Out of date


$ makepkg PKGBUILD
==> Determining latest git revision...
-> Version found: 20110309
==> Making package: kipi-plugins-git 20110309-1 (Wed Mar 9 17:22:44 EET 2011)
==> Checking Runtime Dependencies...
==> Checking Buildtime Dependencies...
==> Retrieving Sources...
==> Extracting Sources...
==> Starting build()...
==> Connecting to the GIT server....
Cloning into kipi-plugins...
remote: Counting objects: 2489, done.
remote: Compressing objects: 100% (2201/2201), done.
remote: Total 2489 (delta 1021), reused 1130 (delta 241)
Receiving objects: 100% (2489/2489), 5.19 MiB | 476 KiB/s, done.
Resolving deltas: 100% (1021/1021), done.
==> GIT checkout done.
==> Starting make for: kipi-plugins-git
error: pathspec 'development/2.0' did not match any file(s) known to git.
Aborting...

jordidg commented on 2011-02-16 12:36

libkmap is required to build this package

Anonymous comment on 2011-02-14 10:48

What is the use of face detection libraries?

flamelab commented on 2011-02-09 04:51

Fixed !

Sevenseven commented on 2011-02-09 03:19

Need fix dep, maybe like this http://aur.pastebin.com/AL3rd4Z9