Package Details: kirigami2-git 5.116.0_r3814.gbff8d7e3-1

Git Clone URL: https://aur.archlinux.org/kirigami2-git.git (read-only, click to copy)
Package Base: kirigami2-git
Description: A QtQuick based components set
Upstream URL: https://community.kde.org/Frameworks
Licenses: LGPL
Groups: kf5-git
Conflicts: kirigami2
Provides: kirigami2
Submitter: IslandC0der
Maintainer: IslandC0der
Last Packager: IslandC0der
Votes: 4
Popularity: 0.000000
First Submitted: 2021-02-05 02:34 (UTC)
Last Updated: 2024-03-01 18:06 (UTC)

Required by (79)

Sources (1)

Latest Comments

IslandC0der commented on 2024-03-01 18:13 (UTC)

@MarsSeed Yup, you're right; this package is the git version of kirigami2, which is indeed part of Kf5. So I've added a kirigami-git package for Kf6 (pkgbases can't be renamed anyway), and fixed this one so it once again builds with Qt5, as intended :)

Thank you for noticing

MarsSeed commented on 2024-03-01 10:35 (UTC)

This package should actually be renamed to kirigami-git, see repo's kirigami.

That package does not provide kirigami2 and does not conflict with it.

MarsSeed commented on 2023-10-21 15:17 (UTC) (edited on 2024-02-27 02:03 (UTC) by MarsSeed)

Please kindly remove 'kirigami2' from provides and conflicts, because that repo package builds only Qt5/KF5 artifacts, with file/dir names reflecting that.

Then please add 'kirigami' to provides and conflicts, which as of now Arch only carries in 'KDE-unstable' repo, but that is the package that builds Qt6/KF6 files.

EDIT: Actually this whole package should be renamed to kirigami-git.

Rustmilian commented on 2023-03-13 00:57 (UTC) (edited on 2023-03-13 00:57 (UTC) by Rustmilian)

@IslandC0der

I missed qt6-shadertools first time around flagging this, be sure to add it.

davispuh commented on 2023-03-06 22:21 (UTC)

These dependencies are wrong: qt6-graphicaleffects, qt6-quickcontrols

there's no such thing :P

davispuh commented on 2023-02-06 02:38 (UTC)

Doesn't build anymore. Need to add -DQT_MAJOR_VERSION=6 CMake option now.

It also depends on qt6-shadertools

IslandC0der commented on 2021-02-18 14:46 (UTC)

Ahh, the source was wrong, it's fixed now. Thank you! :)

desaparecido commented on 2021-02-18 11:03 (UTC)

hi, thanks for the keep up-to-date the package ;-) . trying to build, ask username to clone github, is github side ? or in PKGBUILD ?

unusual_thoughts commented on 2020-11-17 13:34 (UTC)

this is missing makedepends: qt5-svg

arojas commented on 2016-08-10 14:31 (UTC)

There's a stable kirigami package now, please add conflicts and provides