Package Details: kiwix-bin 0.9-1

Git Clone URL: https://aur.archlinux.org/kiwix-bin.git (read-only)
Package Base: kiwix-bin
Description: Offline reader for Web content. It's especially intended to make Wikipedia available offline.
Upstream URL: http://www.kiwix.org
Licenses: GPL3
Conflicts: kiwix
Provides: kiwix
Submitter: felihommen
Maintainer: nic96
Last Packager: nic96
Votes: 28
Popularity: 1.831006
First Submitted: 2012-03-30 11:14
Last Updated: 2015-06-27 17:35

Latest Comments

nic96 commented on 2015-02-13 23:13

The md5sum check passes by me.
Maybe retry installing it.

nic96 commented on 2015-02-13 23:04

Might they have repackaged it? I'll check the md5sum again right away.
Meanwhile you could edit the PKGBUILD and replace the md5sum with SKIP to skip checking.

nic96 commented on 2015-02-13 23:04

Might they have repackaged it? I'll check the md5sum again right away.

nic96 commented on 2015-02-13 23:03

lolop commented on 2015-02-13 22:29

hello,

Modify PKGBUILD?

==> Validation des fichiers sources avec md5sums...
kiwix-0.9-linux-x86_64.tar.bz2 ... ÉCHEC

felihommen commented on 2013-06-23 15:30

I'm afraid I have no idea what's the problem. It's working OK for me with amd_64 architecture.
May be you could check http://sourceforge.net/p/kiwix/discussion/604122/thread/ec2e18f8

alex8664 commented on 2013-06-23 09:08

Crashes with: /usr/lib/kiwix/xulrunner/xulrunner-bin: relocation error: /usr/lib/libpng16.so.16: symbol inflateReset2, version ZLIB_1.2.3.4 not defined in file libz.so.1 with link time reference

caemir commented on 2013-02-13 06:02

Error:
checking for xpidl... no
configure: error: cannot find the xpidl binary
==> ERREUR : Une erreur s'est produite dans build().
Abandon...

But:
1 extra/libidl2 0.8.14-2 [installed]
A front-end for CORBA 2.2 IDL and Netscape's XPIDL
2 aur/lib32-libidl2 0.8.14-3 [installed] (388)
A front-end for CORBA 2.2 IDL and Netscape's XPIDL (32 bit)

felihommen commented on 2012-12-24 22:07

Version 0.9rc2 is out.
x86_64 crash is fixed. Thanks, Kelson!

Anonymous comment on 2012-11-24 12:39

x86_64 crash should be fixed (see next version 0.9rc2). More details at:
https://sourceforge.net/p/kiwix/bugs/365/

Thank you for your feedbacks.

felihommen commented on 2012-11-20 18:18

Changed: now use i686 version also for x86_64 architecture until a bug in x86_64 version is solved.

Anonymous comment on 2012-11-20 04:28

I ment buildbot, they have kiwix builds here:
http://buildbot.kiwix.org/

Thanks, I look forward to the fixed version :D

felihommen commented on 2012-11-19 08:12

Thanks for your comment.
Sorry, what's the "bot build"? I don't speak English very much.

I tested it in my 64 bit computer and I have the same problem.

Installing the needed lib32 libraries and the i686 version works fine for me.
I'm think about changing the PKGBUILD to use the i686 version instead of the amd_64 one, for now.
Needs to replace gcc-libs, binutils and gcc with gcc-libs-multilib, binutils-multilib and gcc-multilib. Then, install lib32-dbus-glib.

Do you think it's a good idea? I'm going to change it tomorrow if there aren't any other comment.

Anonymous comment on 2012-11-18 23:18

Having this problem:
http://sourceforge.net/p/kiwix/bugs/365/

I downloaded the latest bot build of kiwi 64bit and it is working fine.

felihommen commented on 2012-08-12 08:01

Changed wrong md5sums

felihommen commented on 2012-07-08 09:49

Bug fixed upstream.

felihommen commented on 2012-03-30 11:16

There is a bug when you run kiwix in an x86_64 architecture. If you try to scroll down in the open file dialog, kiwix crashes and keeps a process running in the background. You can avoid this by either maximizing the window so yo don't have to scroll down, or putting the file you want to load in a cleaner folder.
Any suggestions are welcome. Enjoy it!

prosciutboy commented on 2012-01-19 15:24

Can't build the package, I get the following error during the config: "configure: error: cannot find the xpidl binary"

Any idea ?

smradlev commented on 2011-10-18 23:45

The PKGBUILD below solves the clucene problem. But a new problem appears:
/usr/include/xulrunner-7.0/nsStringAPI.h:1101:3: error: ‘char16_t’ was not declared in this scope


pkgname=kiwix
_pkgver=0.9
_pkgsubversion=beta3
pkgver=0.9_beta3
pkgrel=1
pkgdesc="Offline reader for Web content. It's especially thought to make Wikipedia available offline. You can download a zim archive of Wikipedia from the project website to use with kiwix."
arch=(i686 x86_64)
url="http://www.kiwix.org"
license=('GPL3')
depends=('libmicrohttpd' 'xz' 'xulrunner>=1.9.2' 'xapian-core' 'icu' 'gcc' 'pkg-config' 'clucene' 'make')

source=(http://sourceforge.net/projects/$pkgname/files/$pkgname-${_pkgver}-${_pkgsubversion}-src.tar.bz2/download)

md5sums=('e84a551e5f31ef1d240088246ed089d5')

build() {
cd "$srcdir"/$pkgname-${_pkgver}
sed -e "s/"-lclucene"/"-lclucene-core"/" -i configure
./configure --prefix=/usr
make || return 1
}

package() {
cd ${pkgname}-${_pkgver}
make DESTDIR=${pkgdir} install
ln -f -s /usr/lib/kiwix/kiwix.sh ${pkgdir}/usr/bin/kiwix
ln -f -s /usr/lib/kiwix/kiwix-compact.sh ${pkgdir}/usr/bin/kiwix-compact
}

erick2red commented on 2011-08-17 14:17

You better ask the kiwix developer about this, since it seems the package is asking for the open function into clucene library and it seems is missing from this clucene release.

erick2red commented on 2011-08-17 14:17

You better ask the developer about this, since it seems the package is asking for the open function into clucene library and it seems is missing from this clucene release.

Sandnabba commented on 2011-08-17 13:52

Hello! I'm trying to compile 0.9 beta1 by my self, but I get the same error as "khelek":
checking for CLucene.h... yes
checking for open in -lclucene... no
configure: error: cannot find clucene

Any idea?

Anonymous comment on 2011-07-25 16:19

Hi I get an Error even before the build process:

...
checking for CLucene.h... yes
checking for open in -lclucene... no
configure: error: cannot find clucene

The Problem is I have definitely installed clucene. Is it my fault or is this package not working anymore ?

Anonymous comment on 2011-07-18 10:37

Could you make a new package with Kiwix 0.9 beta1 ?
Here is the dist tgz http://download.kiwix.org/src/nightlies/kiwix-svn-2011-07-15.tar.bz2
Check to add the aria2 dependence...

Anonymous comment on 2011-04-12 13:18

@smradlev @zwirks

The problem is that you try to compile Kiwix against the new xulrunner 2.0.
Currently (and the AUR packages) compiles/runs only against xulrunner 1.9.x.x.

We are working on that. I have open a feature request to track this issue:
http://sourceforge.net/tracker/?func=detail&aid=3285237&group_id=175508&atid=873518

smradlev commented on 2011-04-07 16:12

I get the same error as zwirks.

Anonymous comment on 2011-04-01 06:47

Hi!
It is not working anymore.
build error
""
make[4]: Entering directory `/home/sim/abs/kiwix/src/kiwix-0.9/src/components/xapianAccessor'
/bin/sh ../../../libtool --tag=CXX --mode=compile g++ -DHAVE_CONFIG_H -I. -I../../../src/zimlib/src -I/usr/lib -fshort-wchar -I/usr/include/xulrunner-2.0 -I/usr/include/nspr -march=x86-64 -mtune=generic -O2 -pipe -W -Wall -ansi -pedantic -Wpointer-arith -Wwrite-strings -Wno-long-long -fno-rtti -fPIC -I../../common/ -O6 -MT libXapianAccessor_la-xapianAccessor.lo -MD -MP -MF .deps/libXapianAccessor_la-xapianAccessor.Tpo -c -o libXapianAccessor_la-xapianAccessor.lo `test -f 'xapianAccessor.cpp' || echo './'`xapianAccessor.cpp
libtool: compile: g++ -DHAVE_CONFIG_H -I. -I../../../src/zimlib/src -I/usr/lib -fshort-wchar -I/usr/include/xulrunner-2.0 -I/usr/include/nspr -march=x86-64 -mtune=generic -O2 -pipe -W -Wall -ansi -pedantic -Wpointer-arith -Wwrite-strings -Wno-long-long -fno-rtti -fPIC -I../../common/ -O6 -MT libXapianAccessor_la-xapianAccessor.lo -MD -MP -MF .deps/libXapianAccessor_la-xapianAccessor.Tpo -c xapianAccessor.cpp -fPIC -DPIC -o .libs/libXapianAccessor_la-xapianAccessor.o
xapianAccessor.cpp:2:31: schwerwiegender Fehler: nsIGenericFactory.h: Datei oder Verzeichnis nicht gefunden
Kompilierung beendet.
make[4]: *** [libXapianAccessor_la-xapianAccessor.lo] Fehler 1
make[4]: Leaving directory `/home/sim/abs/kiwix/src/kiwix-0.9/src/components/xapianAccessor'
make[3]: *** [all] Fehler 2
make[3]: Leaving directory `/home/sim/abs/kiwix/src/kiwix-0.9/src/components/xapianAccessor'
make[2]: *** [all-recursive] Fehler 1
make[2]: Leaving directory `/home/sim/abs/kiwix/src/kiwix-0.9/src/components'
make[1]: *** [all-recursive] Fehler 1
make[1]: Leaving directory `/home/sim/abs/kiwix/src/kiwix-0.9/src'
make: *** [all-recursive] Fehler 1
==> FEHLER: Ein Unfall geschah in build().
Breche ab ...
""
I have no clue what is going on - hope it helps to solve the problem (maybe it is not only on my box)
thanks!

Anonymous comment on 2011-01-25 18:58

It works now! Thx a lot.

Anonymous comment on 2011-01-12 13:28

Hi, I'm a Kiwix developer and I have got feedbacks with something like "the Kiwix Arch Package does not work".
By starting kiwix, none of the XPCOM components could be registered.

Unable to register the zimAccessor XPCOM, Kiwix will be unable to read ZIM files.
Unable to register the xapianAccessor XPCOM, Kiwix will be unable to provide the search engine.
Unable to register the zimXapianIndexer XPCOM, Kiwix will be unable to index ZIM files.

I do not know neither Arch nor the Arch Packaging system but I'm interested in fixing the issue.
Maybe we can achieve that together?