Package Details: klassy-git 6.0.breeze6.0.2.r2.g58c38f60-1

Git Clone URL: https://aur.archlinux.org/klassy-git.git (read-only, click to copy)
Package Base: klassy-git
Description: Highly customizable binary Window Decoration, Application Style and Global Theme plugin for recent versions of the KDE Plasma desktop.
Upstream URL: https://github.com/paulmcauley/klassy
Licenses: GPL-2.0-only AND GPL-3.0-only AND GPL-2.0-or-later AND LGPL-2.1-or-later AND MIT
Conflicts: klassy
Provides: klassy
Replaces: classik-git
Submitter: rocka
Maintainer: rocka (lilac)
Last Packager: lilac
Votes: 7
Popularity: 0.130929
First Submitted: 2022-08-10 15:10 (UTC)
Last Updated: 2024-03-16 12:19 (UTC)

Latest Comments

1 2 Next › Last »

octopus4003 commented on 2023-10-28 13:46 (UTC) (edited on 2023-10-28 13:48 (UTC) by octopus4003)

:: installing frameworkintegration5 (5.111.0-1) breaks dependency 'frameworkintegration' required by klassy-git
:: installing kwayland5 (5.111.0-1) breaks dependency 'kwayland' required by klassy-git

kde has changed the package names so cannot update properly

xiota commented on 2023-09-20 07:57 (UTC) (edited on 2023-10-28 14:56 (UTC) by xiota)

Please remove replaces directive, in accordance with AUR submission guidelines.

achilleas commented on 2023-05-15 09:38 (UTC)

This package should be marked as conflicting with klassy.

leo_sk commented on 2023-05-13 11:31 (UTC) (edited on 2023-05-13 11:32 (UTC) by leo_sk)

@rocka I built your klassy package and it installed successfully. I tried manually building the git package but that too gave the same error. So using your other package for now

rocka commented on 2023-05-13 05:36 (UTC)

@leo_sk maybe you can try prebuilt binary package from archlinuxcn repo. We use extra-x86_64-build from devtools to build the package, and did not encounter any errors.

leo_sk commented on 2023-05-12 18:43 (UTC) (edited on 2023-05-12 18:44 (UTC) by leo_sk)

I am getting error:

[ 98%] Built target klassydecoration
[100%] Linking CXX shared module ../bin/klassy.so
[100%] Built target klassy
make: *** [Makefile:136: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...

I tried building it consecutively for 3 days, clearing build files and downloaded data each time, but get the same error

paulmcauley commented on 2023-05-10 23:41 (UTC)

@jnko Try cleaning/deleting your build directory and try again.

jnko commented on 2023-05-10 16:29 (UTC) (edited on 2023-05-10 16:32 (UTC) by jnko)

Hmmm, I get this error when trying to install/compile:

[  1%] Automatic MOC for target klassydecoration_STATIC
[  1%] Built target klassydecoration_STATIC_autogen
[  2%] Building CXX object kdecoration/CMakeFiles/klassydecoration_STATIC.dir/klassydecoration_STATIC_autogen/mocs_compilation.cpp.o
In file included from /home/injk/.cache/pikaur/build/klassy-git/src/klassy/build/kdecoration/klassydecoration_STATIC_autogen/IJHAR2IVER/../../../../kdecoration/config/breezeconfigwidget.h:12,
             from /home/injk/.cache/pikaur/build/klassy-git/src/klassy/build/kdecoration/klassydecoration_STATIC_autogen/IJHAR2IVER/moc_breezeconfigwidget.cpp:10,
             from /home/injk/.cache/pikaur/build/klassy-git/src/klassy/build/kdecoration/klassydecoration_STATIC_autogen/mocs_compilation.cpp:2:
/home/injk/.cache/pikaur/build/klassy-git/src/klassy/libbreezecommon/breeze.h:16:10: fatal error: breezesettings.h: No such file or directory
   16 | #include "breezesettings.h"
      |          ^~~~~~~~~~~~~~~~~~
compilation terminated.
make[2]: *** [kdecoration/CMakeFiles/klassydecoration_STATIC.dir/build.make:109: kdecoration/CMakeFiles/klassydecoration_STATIC.dir/klassydecoration_STATIC_autogen/mocs_compilation.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:586: kdecoration/CMakeFiles/klassydecoration_STATIC.dir/all] Error 2
make: *** [Makefile:136: all] Error 2

rocka commented on 2022-09-14 09:43 (UTC)

@leo_sk as of today (2022-09-14), the repository size of klassy is 822.12 MiB in total. Consider it's a fork of KDE's Breeze ( https://invent.kde.org/plasma/breeze ), which takes 767.00 MiB , I think it's understandable.