Package Details: klayout 0.24.8-2

Git Clone URL: (read-only)
Package Base: klayout
Description: High Performance Layout Viewer And Editor. Support of GDS and OASIS files.
Upstream URL:
Licenses: GPL
Submitter: t0nedef
Maintainer: t0nedef
Last Packager: t0nedef
Votes: 3
Popularity: 0.004647
First Submitted: 2015-08-29 17:21
Last Updated: 2016-09-07 16:55

Required by (0)

Sources (3)

Latest Comments

t0nedef commented on 2016-09-07 16:56

Thanks sasvari and Fweeb. I've bumped klayout to use the latest ruby. I'll see what I can do about Python bindings.

Fweeb commented on 2016-09-05 16:00

It appears that klayout will now compile against Ruby 2.3 (ruby in the main repo) without problems. Build opts need to be updated thusly:

build_opt="-qt /usr -qtinc /usr/include/qt4 -qtbin /usr/lib/qt4/bin -bin $pkgdir/usr/bin -rblib /usr/lib/ -rbinc /usr/include/ruby-2.3.0/"

Also depends should be depends=('qt4' 'ruby')

And, yes, the Python bindings would be a nice thing to add.

sasvari commented on 2016-08-30 21:34

The package is not really out of date but has an unavailable dependency with ruby2.1.

t0nedef commented on 2016-04-26 17:07

Thanks for the notification sasvari, I changed the download domain as you suggested

sasvari commented on 2016-04-18 19:18

currently fails downloading:

:: Retrieving package(s)...
:: klayout build files are up-to-date -- skipping
:: Checking klayout integrity...
==> Making package: klayout 0.24.6-1 (Mon Apr 18 21:15:37 CEST 2016)
==> Retrieving sources...
-> Downloading klayout-0.24.6.tar.gz...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 331 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
0 0 0 0 0 0 0 0 --:--:-- 0:02:07 --:--:-- 0
curl: (7) Failed to connect to port 80: Connection timed out
==> ERROR: Failure while downloading

the reason is that the download URL changed from to


archleon commented on 2016-03-12 17:15

I get the following error: -rbvers not specified or version cannot be determined from Ruby installation

ipickering commented on 2016-02-05 19:52

This looks like the relevant Ruby 2.3.0 bug:

So updating to 2.3.0 breaks the compilation of certain native extensions. Not sure if the fix is going to get backported soon.

marmei commented on 2016-02-03 13:01

Hey mabi, hey t0nedef,
can't we just remove the ruby-2.1 or previous ruby2.1 dependency and just use the ruby dependecy from the main repository ?? is the old ruby really necessary? - cheers

t0nedef commented on 2016-01-30 22:08

Hey mabi, yah I can see how that would be a problem. I implemented your suggestions. Thanks

mabl commented on 2016-01-24 08:21

Hi t0nedef,

ruby-2.1 want to replace the system ruby, which is not acceptable. Please use the ruby2.1 package which installs a separate ruby in /opt/. You will then have to adapt the configure flags as Fweeb indicated:

build_opt="-qt /usr -qtinc /usr/include/qt4 -qtbin /usr/lib/qt4/bin -bin $pkgdir/usr/bin -rblib /opt/ruby2.1/lib/ -rbinc /opt/ruby2.1/include/ruby-2.1.0/"

(We could also think about python bindings btw)

All comments