Package Details: klayout 0.25.3-1

Git Clone URL: (read-only)
Package Base: klayout
Description: High Performance Layout Viewer And Editor. Support of GDS and OASIS files.
Upstream URL:
Licenses: GPL
Submitter: t0nedef
Maintainer: t0nedef
Last Packager: t0nedef
Votes: 6
Popularity: 0.069879
First Submitted: 2015-08-29 17:21
Last Updated: 2018-05-14 19:37

Latest Comments

t0nedef commented on 2018-04-23 19:14

Thanks for the feedback heitzmann I have updated the PKGBUILD with these requirements. If anyone manages to build with the latest ruby please let me know.

heitzmann commented on 2018-03-23 17:12

The PKGBUILD is missing a few dependencies: 'qt5-tools' 'qt5-multimedia' 'qt5-xmlpatterns' 'qt5-svg'

Materiewelle commented on 2018-02-02 09:16

Simply making a symbolic link /usr/lib/ -> /usr/lib/ is a quick and dirty fix. It does not ACTUALLY require version 2.4 as it seems. Just remove the link again after the package has been updated...

bubka commented on 2018-01-24 19:05

I confirm this. Downgrade to ruby 2.4 works fine.

Fweeb commented on 2018-01-24 18:12

Is anyone else having trouble building against ruby 2.5? I seem to be getting issues when linking It seems to specifically want

I've tried setting build_opts to specifically point to ruby 2.5 (-rbvers 25000 -rblib /usr/lib/ -rbinc /usr/include/ruby-2.5.0/)... but none of those seem to have worked for me. Anyone else having luck?

t0nedef commented on 2017-12-07 11:16

Thanks for the help bubka. I had already investigated a fix for this I was just waiting on the test results. Please update and you'll find the issue fixed. I also added python bindings satisfying a very old request.

bubka commented on 2017-12-07 08:22

PKGBUILD needs to be changed

bubka commented on 2017-07-14 09:57

Hi! Please add %F flag to Exec command in .desktop files according to

t0nedef commented on 2017-01-24 19:57

yes I agree, not sure why I missed that last update. I updated this package to use ruby from extra.

mabl commented on 2017-01-23 22:25

Indeed it looks like it builds and works against ruby 2.4 which is packaged in extra.

nordog commented on 2017-01-23 12:39

I just successfully built klayout against ruby 2.4 in [extra]. If ruby 2.3 is not explicitly required, you might consider removing it as a dependency, and depend on and build against 2.4 instead.

t0nedef commented on 2017-01-16 01:06

Thanks for the info rugaliz. I updated the package to 0.24.9 and changed the dependency on ruby to ruby2.3 (AUR). You are right on qt, this package already lists qt4 as a dependency for that reason.

rugaliz commented on 2017-01-12 11:40

I have had trouble building the latest (0.24.9) package as well as this one.
With 0.24.8 i get an error due to the ruby version (i guess it expected something from version 2.3 [current version 2.4]) and with the new version i get errors due to the qt version (i found out that the build expects qt4 with an old deprecated function "QInputContext").

t0nedef commented on 2016-09-07 16:56

Thanks sasvari and Fweeb. I've bumped klayout to use the latest ruby. I'll see what I can do about Python bindings.

Fweeb commented on 2016-09-05 16:00

It appears that klayout will now compile against Ruby 2.3 (ruby in the main repo) without problems. Build opts need to be updated thusly:

build_opt="-qt /usr -qtinc /usr/include/qt4 -qtbin /usr/lib/qt4/bin -bin $pkgdir/usr/bin -rblib /usr/lib/ -rbinc /usr/include/ruby-2.3.0/"

Also depends should be depends=('qt4' 'ruby')

And, yes, the Python bindings would be a nice thing to add.

sasvari commented on 2016-08-30 21:34

The package is not really out of date but has an unavailable dependency with ruby2.1.

t0nedef commented on 2016-04-26 17:07

Thanks for the notification sasvari, I changed the download domain as you suggested

sasvari commented on 2016-04-18 19:18

currently fails downloading:

:: Retrieving package(s)...
:: klayout build files are up-to-date -- skipping
:: Checking klayout integrity...
==> Making package: klayout 0.24.6-1 (Mon Apr 18 21:15:37 CEST 2016)
==> Retrieving sources...
-> Downloading klayout-0.24.6.tar.gz...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 331 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
0 0 0 0 0 0 0 0 --:--:-- 0:02:07 --:--:-- 0
curl: (7) Failed to connect to port 80: Connection timed out
==> ERROR: Failure while downloading

the reason is that the download URL changed from to


archleon commented on 2016-03-12 17:15

I get the following error: -rbvers not specified or version cannot be determined from Ruby installation

ipickering commented on 2016-02-05 19:52

This looks like the relevant Ruby 2.3.0 bug:

So updating to 2.3.0 breaks the compilation of certain native extensions. Not sure if the fix is going to get backported soon.

marmei commented on 2016-02-03 13:01

Hey mabi, hey t0nedef,
can't we just remove the ruby-2.1 or previous ruby2.1 dependency and just use the ruby dependecy from the main repository ?? is the old ruby really necessary? - cheers

t0nedef commented on 2016-01-30 22:08

Hey mabi, yah I can see how that would be a problem. I implemented your suggestions. Thanks

mabl commented on 2016-01-24 08:21

Hi t0nedef,

ruby-2.1 want to replace the system ruby, which is not acceptable. Please use the ruby2.1 package which installs a separate ruby in /opt/. You will then have to adapt the configure flags as Fweeb indicated:

build_opt="-qt /usr -qtinc /usr/include/qt4 -qtbin /usr/lib/qt4/bin -bin $pkgdir/usr/bin -rblib /opt/ruby2.1/lib/ -rbinc /opt/ruby2.1/include/ruby-2.1.0/"

(We could also think about python bindings btw)

t0nedef commented on 2016-01-20 23:50

I've added ruby-2.1 as a dependency instead of just ruby

sasvari commented on 2016-01-19 12:43

if you have have problems starting klayout (already installed) after a recent update, installing ruby2.2 from aur works as Fweeb suggests.

Fweeb commented on 2016-01-11 14:33

For what it's worth, I was able to get this to build by installing ruby 2.1 ( and updating the compile flags in the pkgbuild to build against that. This may also work with ruby 2.2; I haven't tried that yet.

Fweeb commented on 2016-01-08 13:28

Has anyone else had difficulty compiling this against Ruby 2.3.0? When building the rba, I get a string of scope errors that look like the following:

aur-klayout/src/klayout-0.24.4/src/ In function ‘void rba::rba_get_backtrace_from_array(VALUE, std::vector<gsi::BacktraceElement>&, unsigned int)’:
/usr/include/ruby-2.3.0/ruby/ruby.h:882:52: error: ‘__builtin_choose_expr’ was not declared in this scope
OBJ_WB_UNPROTECT((VALUE)(obj)), ((VALUE)(obj))))

Can anyone else confirm?

t0nedef commented on 2015-10-14 01:10

Thanks ehud42, I've added ruby to the list of dependencies.

ehud42 commented on 2015-10-08 07:45

I had to install ruby to get this package to compile. Otherwise it complained about missing