Package Details: klayout 0.24.8-1

Git Clone URL: https://aur.archlinux.org/klayout.git (read-only)
Package Base: klayout
Description: High Performance Layout Viewer And Editor. Support of GDS and OASIS files.
Upstream URL: http://www.klayout.org/
Licenses: GPL
Submitter: t0nedef
Maintainer: t0nedef
Last Packager: t0nedef
Votes: 3
Popularity: 0.049984
First Submitted: 2015-08-29 17:21
Last Updated: 2016-06-24 13:45

Dependencies (2)

Required by (0)

Sources (3)

Latest Comments

t0nedef commented on 2016-04-26 17:07

Thanks for the notification sasvari, I changed the download domain as you suggested

sasvari commented on 2016-04-18 19:18

currently fails downloading:

```
:: Retrieving package(s)...
:: klayout build files are up-to-date -- skipping
:: Checking klayout integrity...
==> Making package: klayout 0.24.6-1 (Mon Apr 18 21:15:37 CEST 2016)
==> Retrieving sources...
-> Downloading klayout-0.24.6.tar.gz...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 331 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
0 0 0 0 0 0 0 0 --:--:-- 0:02:07 --:--:-- 0
curl: (7) Failed to connect to 178.77.72.242 port 80: Connection timed out
==> ERROR: Failure while downloading http://www.klayout.de/downloads/klayout-0.24.6.tar.gz
Aborting...
```

the reason is that the download URL changed from klayout.de to klayout.org:

--> http://www.klayout.de/build.html
--> http://www.klayout.org/downloads/klayout-0.24.6.tar.gz

archleon commented on 2016-03-12 17:15

I get the following error: -rbvers not specified or version cannot be determined from Ruby installation

ipickering commented on 2016-02-05 19:52

This looks like the relevant Ruby 2.3.0 bug:

https://bugs.ruby-lang.org/issues/11962

So updating to 2.3.0 breaks the compilation of certain native extensions. Not sure if the fix is going to get backported soon.

marmei commented on 2016-02-03 13:01

Hey mabi, hey t0nedef,
can't we just remove the ruby-2.1 or previous ruby2.1 dependency and just use the ruby dependecy from the main repository ?? is the old ruby really necessary? - cheers

t0nedef commented on 2016-01-30 22:08

Hey mabi, yah I can see how that would be a problem. I implemented your suggestions. Thanks

mabl commented on 2016-01-24 08:21

Hi t0nedef,

ruby-2.1 want to replace the system ruby, which is not acceptable. Please use the ruby2.1 package which installs a separate ruby in /opt/. You will then have to adapt the configure flags as Fweeb indicated:

build_opt="-qt /usr -qtinc /usr/include/qt4 -qtbin /usr/lib/qt4/bin -bin $pkgdir/usr/bin -rblib /opt/ruby2.1/lib/libruby.so -rbinc /opt/ruby2.1/include/ruby-2.1.0/"

(We could also think about python bindings btw)

t0nedef commented on 2016-01-20 23:50

I've added ruby-2.1 as a dependency instead of just ruby

sasvari commented on 2016-01-19 12:43

if you have have problems starting klayout (already installed) after a recent update, installing ruby2.2 from aur works as Fweeb suggests.

Fweeb commented on 2016-01-11 14:33

For what it's worth, I was able to get this to build by installing ruby 2.1 (https://aur.archlinux.org/packages/ruby2.1/) and updating the compile flags in the pkgbuild to build against that. This may also work with ruby 2.2; I haven't tried that yet.

Fweeb commented on 2016-01-08 13:28

Has anyone else had difficulty compiling this against Ruby 2.3.0? When building the rba, I get a string of scope errors that look like the following:

aur-klayout/src/klayout-0.24.4/src/rba.cc: In function ‘void rba::rba_get_backtrace_from_array(VALUE, std::vector<gsi::BacktraceElement>&, unsigned int)’:
/usr/include/ruby-2.3.0/ruby/ruby.h:882:52: error: ‘__builtin_choose_expr’ was not declared in this scope
OBJ_WB_UNPROTECT((VALUE)(obj)), ((VALUE)(obj))))
^

Can anyone else confirm?

t0nedef commented on 2015-10-14 01:10

Thanks ehud42, I've added ruby to the list of dependencies.

ehud42 commented on 2015-10-08 07:45

I had to install ruby to get this package to compile. Otherwise it complained about missing libruby.so