Package Details: kmscon-git 2:8.15.g3b6fb0f-1

Git Clone URL: (read-only)
Package Base: kmscon-git
Description: Terminal emulator based on Kernel Mode Setting (KMS)
Upstream URL:
Licenses: MIT
Conflicts: kmscon
Provides: kmscon
Submitter: thestinger
Maintainer: None
Last Packager: thestinger
Votes: 14
Popularity: 0.028703
First Submitted: 2012-06-25 05:37
Last Updated: 2015-06-25 15:12

Latest Comments

ice commented on 2016-02-14 16:16

This package requires libtsm-git

thx1138 commented on 2014-07-27 16:56

Daniel, would you also add installing the manual page to the PKDBUILD?

Add a dependency on the "docbook2x" package:

depends=(systemd libdrm mesa libegl libgbm libgles pango libxkbcommon xkeyboard-config libtsm docbook2x)

And then convert and install the xml file:

package() {
cd $_gitname
make DESTDIR="$pkgdir/" install
mkdir -p "$pkgdir/usr/share/licenses/$pkgname" "$pkgdir/usr/lib/systemd/system"
cp COPYING "$pkgdir/usr/share/licenses/$pkgname/"
cp docs/kmscon{,vt@}.service "$pkgdir/usr/lib/systemd/system/"
cd docs/man
docbook2man kmscon.xml
gzip kmscon.1
cp kmscon.1.gz "$pkgdir/usr/share/man/man1/"

And also similarly for the kmscon package in the Community repository?


thestinger commented on 2014-04-28 06:05

There's nothing odd about the `epoch` variable, and it can't be removed without breaking all future updates.

flu commented on 2014-04-27 08:52

Could you please remove that odd epoch=2 when possible?

tattsan commented on 2013-11-19 18:37

Now 'libtsm' should be added to depends array.

tattsan commented on 2013-11-19 18:32

Now 'libtsm' should be added in depends array.

dvdhrm commented on 2013-06-20 10:18

@swiftgeek See "git help describe". The last part is the abbreviated commit (which may be ambiguous).

swiftgeek commented on 2013-06-19 13:45

But is it possible to get from that git describe number to specific commit?

dvdhrm commented on 2013-06-19 12:45

@swiftgeek: I think it's from "git describe", which is shorter than the full hash but still guaranteed to be unique. You cannot guarantee that if you just use a hash-prefix (even though collision are unlikely if you make it large enough).

btw., is the main repository, but sometimes the server is down so I push to github and might forget to update fdo..

swiftgeek commented on 2013-06-19 02:27

And why gddf4126 ? short sha of commit is more useful

thestinger commented on 2013-06-18 18:32

@swiftgeek: is where it's hosted now

swiftgeek commented on 2013-06-18 17:49

Please make pkgver() saner (and revert source to github but i'm not sure about that)

yangtsesu commented on 2013-03-02 03:22


dvdhrm commented on 2013-02-28 11:15

I just released kmscon-7. Release-notes can be found here:


dvdhrm commented on 2013-02-10 15:20

@BiggArs you have to use '=' for assignments in config files. So use:

I am working on a proper config-file parser. The current one was just a simple workaround.

Anonymous comment on 2013-02-09 18:20

@dvdhrm i have a problem with default config. Font options (such 'font-size', 'font-engine') don't recognize. My config /etc/kmscon/kmscon.conf:

font-size 12
font-engine freetype2

Trying to start and i get:

фев 09 22:03:06 archbook kmscon[6521]: [0000.002462] ERROR: config: unknown config option 'font-size 12'
фев 09 22:03:06 archbook kmscon[6521]: [0000.002538] ERROR: cannot load configuration: -14

Without parameters for font options, such this config:


i get:

фев 09 22:19:04 archbook kmscon[6728]: [0000.000275] ERROR: config: config option 'font-size' requires an argument
фев 09 22:19:04 archbook kmscon[6728]: [0000.000324] ERROR: cannot load configuration: -14

May be i doing soething wrong?

dvdhrm commented on 2013-01-20 15:33

I talked with Ran-Benita (xkbcommon dev) and he also suggested to move the xkeyboard-config dependency to libxkbcommon. The thing is, xkeyboard-config installs the keyboard-configuration files but libxkbcommon takes the path to the directory as ./configure option. So libxkbcommon depends on xkeyboard-config, not the other way around.
Can you fix this for libxkbcommon and kmscon? Or what do you think on that?

thestinger commented on 2013-01-19 15:38

@swiftgeek: It shouldn't use a shallow clone - this only clones the repository once, and then pulls changes the next time you build it. The prototype git PKGBUILD in /usr/share/pacman does it this way.

Luckily pacman 4.1 will bring VCS support in makepkg, so it won't be something to worry about per-package.

swiftgeek commented on 2013-01-17 05:01

Please use shallow clone
git clone --depth=1 $_gitroot $_gitname

dvdhrm commented on 2013-01-08 16:54

@zbito Should be fixed now. Thanks for reporting it!

zbito commented on 2013-01-08 16:13

Build failes:
/usr/bin/ld: src/kmscon-kmscon_module.o: undefined reference to symbol 'dlclose@@GLIBC_2.2.5'
/usr/bin/ld: note: 'dlclose@@GLIBC_2.2.5' is defined in DSO /usr/lib/ so try adding it to the linker command line
/usr/lib/ could not read symbols: Invalid operation
collect2: error: ld returned 1 exit status

thestinger commented on 2012-12-17 16:13

@swiftgeek: Thanks, should be good now.

swiftgeek commented on 2012-12-17 15:34

kmscon@.service is now kmsconvt@.service

dvdhrm commented on 2012-12-11 08:07

@swiftgeek You need to add /dev/pts/X to /etc/securetty or remote pam_securetty from /etc/pam.d/login.
pam prevents root logins via /bin/login from all terminals except the ones listed in /etc/securetty. However, PTYs are allocated dynamically so you need to basically list a lot of PTYs in /etc/securetty to make sure it's there. So disabling pam_securetty is probably the better idea.

swiftgeek commented on 2012-12-11 07:30

Also... i have quite a weird issue with /bin/login... it doesn't allow me to login on root, but it's possible to log on other users...

swiftgeek commented on 2012-12-11 05:24

Please use git clone --depth=1

dvdhrm commented on 2012-12-09 22:29

I forgot to add: Use:
to avoid running ./configure automatically. Or use:
$ ./ --prefix=/usr --disable-wlterm
directly. It's up to you.
But the current file calls ./configure twice.

dvdhrm commented on 2012-12-09 22:28

I got slightly behind with kmscon releases but I wanted to get a proper kmscon-6 release that will be backwards-compatible. It's out now, sorry for breaking some ./configure options. I also pushed a "kmscon" PKGBUILD but feel free to contact me if you want to take it over (I spotted a message that you are planning to maintain it as TU).

Some suggestions:
- remove "xproto", "gtk-doc" from makedepends, they're no longer needed
- add "libxslt", "docbook-xsl" to makedepends to allow building kmscon manpages
- add "systemd" to depends for multi-seat setups, otherwise use --disable-multi-seat
- add "libegl" to depends (it's needed if the drm video backend is used)
- install the license header as suggested by AUR guidelines:
mkdir -p "$pkgdir/usr/share/licenses/$pkgname/"
cp COPYING "$pkgdir/usr/share/licenses/$pkgname/"

Thanks for maintaning this package and for pushing xkbcommon into [community].

klemmster commented on 2012-12-08 11:22

Thank you!

klemmster commented on 2012-12-03 18:33

The docs directory of the current git repository includes a systemd service file. It would be really neat if it would get installed correctly, too.

dvdhrm commented on 2012-11-16 08:53

As a workaround you can pass --disable-wlterm to ./configure

aksr commented on 2012-11-16 08:46

Not sure if it's my fault:
CC src/wlterm-wlt_main.o
src/wlt_main.c:37:28: fatal error: wayland-client.h: No such file or directory
compilation terminated.
make[2]: *** [src/wlterm-wlt_main.o] Error 1
make[2]: Leaving directory `/tmp/yaourt-tmp-aksr/aur-kmscon-git/src/kmscon-build'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/yaourt-tmp-aksr/aur-kmscon-git/src/kmscon-build'
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
==> ERROR: Makepkg was unable to build .
==> Restart building kmscon-git ? [y/N]
==> -----------------------------------

falconindy commented on 2012-10-07 23:45 calls ./configure on its own (which is sort of dirty, imo)... you can just add the --prefix=/usr to ./ and ditch the explicit ./configure call.

klemmster commented on 2012-09-29 11:28

works very well for me, thank you

dgbaley27 commented on 2012-09-29 08:37

Latest version works. Very nice, thank you David.

dvdhrm commented on 2012-09-08 14:22

@dgbaley27 Can you try with most recent version again? Also please run as "root", otherwise it will not work.

Anonymous comment on 2012-09-05 05:18

Could you please add libxkbcommon-git to the dependencies?

dgbaley27 commented on 2012-08-24 16:36

What is one way to actually get this started? Can I do some systemd setup to replace some of my VTs with kmscon? Should I be able to just run it from gnome-terminal? No matter what I try, I get: "ERROR: vt: cannot find parent tty"

thestinger commented on 2012-08-18 12:09

@dvdhrm: Thanks, updated :).

thestinger commented on 2012-08-18 12:08

@dvshrm: Thanks, updated :).

dvdhrm commented on 2012-08-18 07:42

Please use --disable-gles2 or use a more recent version of mesa. They changed the API. However, with archlinux' mesa you cannot use hardware-acceleration, anyway. So using --disable-gles2 is recommended. Also see here:

Anonymous comment on 2012-08-14 11:55

/home/copy/kmscon/.libs/ undefined reference to `gbm_bo_get_stride'
collect2: error: ld returned 1 exit status
make[2]: *** [fakevt] Error 1
./.libs/ undefined reference to `gbm_bo_get_stride'
collect2: error: ld returned 1 exit status
make[2]: *** [kmscon] Error 1
make[1]: *** [all-recursive] Error 1