Package Details: knemo 1.7.7.1_git20191016-2

Git Clone URL: https://aur.archlinux.org/knemo.git (read-only, click to copy)
Package Base: knemo
Description: The KDE Network Monitor
Upstream URL: https://www.linux-apps.com/content/show.php?content=12956
Licenses: GPL
Submitter: arojas
Maintainer: IslandC0der
Last Packager: IslandC0der
Votes: 9
Popularity: 0.42
First Submitted: 2020-05-29 10:12 (UTC)
Last Updated: 2021-09-20 23:00 (UTC)

Latest Comments

1 2 3 Next › Last »

IslandC0der commented on 2022-01-16 13:37 (UTC)

Can't reproduce it, sadly :(

vlovich commented on 2021-12-15 17:36 (UTC)

Doesn't build anymore?

CMake Error at /usr/share/cmake-3.22/Modules/FindPackageHandleStandardArgs.cmake:230 (message): Could NOT find KF5 (missing: KDELibs4Support KIO) (found version "5.89.0") Call Stack (most recent call first): /usr/share/cmake-3.22/Modules/FindPackageHandleStandardArgs.cmake:594 (_FPHSA_FAILURE_MESSAGE) /usr/share/ECM/find-modules/FindKF5.cmake:93 (find_package_handle_standard_args) CMakeLists.txt:24 (find_package)

IslandC0der commented on 2020-07-31 22:59 (UTC)

Thanks, fixed.

simona commented on 2020-07-29 21:45 (UTC)

fatal: impossibile risolvere git.kde.org (porta 9418) (Nome o servizio sconosciuto)

IslandC0der commented on 2020-06-17 22:14 (UTC)

@papavlos: It used to be, it got dropped pretty recently (since the project has been discontinued anyway).

papavlos commented on 2020-06-16 21:54 (UTC)

And again 'libsysguard' got updated to 5.19.1 this afternoon. So we have to create a link to the current version of library:

sudo ln -s /usr/lib/libksignalplotter.so.5.19.1 /usr/lib/libksignalplotter.so.7

@IslandC0der: thanks for maintaining this package. I'll vote to have it migrated to our standard repos, as the part of plasma apps.

IslandC0der commented on 2020-06-14 00:10 (UTC)

I remember running into that issue a few weeks ago, and I did that workaround. However, I later found that by simply rebuilding knemo after updating libksysguard, FindLibKSignalPlotter.cmake automatically detects the new version and the program starts using the new library on its own. In the meantime, I'll see if I can find a way to patch the source so it becomes version agnostic. Otherwise, I'll just do a version bump on this AUR package everytime libksysguard updates, so people rebuild it on their machines. When eventually it completely stops working with the newer versions of the library, I guess I'll have to start including a legacy version of it in this package.

papavlos commented on 2020-06-13 17:10 (UTC) (edited on 2020-06-13 17:13 (UTC) by papavlos)

After the last update of 'libksysguard' package (required by updated 'ksysguard') knemo does not start, claiming for missing 'libksignalplotter.so.7'. As a workaround - create symbolic link to the newer library:

sudo ln -s /usr/lib/libksignalplotter.so.5.19.0 /usr/lib/libksignalplotter.so.7

Until the knemo gets updated and rebuilt...