Package Details: kodi-addon-pvr-mythtv-git r677.a2a56f3-1

Git Clone URL: https://aur.archlinux.org/kodi-addon-pvr-mythtv-git.git (read-only)
Package Base: kodi-addon-pvr-mythtv-git
Description: MythTV PVR client addon for Kodi
Upstream URL: https://github.com/kodi-pvr/pvr.mythtv
Licenses: GPL
Conflicts: kodi-addon-pvr-mythtv, kodi-pvr-addons
Provides: kodi-addon-pvr-mythtv
Submitter: equinox
Maintainer: equinox
Last Packager: equinox
Votes: 6
Popularity: 0.000000
First Submitted: 2015-09-23 01:27
Last Updated: 2017-04-05 00:58

Required by (0)

Sources (1)

Latest Comments

equinox commented on 2018-10-18 10:13

I'm no longer able to keep up with maintaining this, if anyone is interested in maintaining it I'll add them as a co-maintainer. Otherwise I'll just disown it after the weekend.

Hagar commented on 2018-10-15 08:26

janbar has the latest sources - not kodi-pvr - can you please update?

Compiles for Kodi 18 ie.

API=18 makepkg

with the following changes -

please add -

18) echo "master";;

please change the url to -

https://github.com/janbar/pvr.mythtv/tree/master/pvr.mythtv

and the source to -

${pkgname}::git+https://github.com/janbar/pvr.mythtv.git#branch=${_branch}

equinox commented on 2017-04-05 01:01

Alright I've updated it to include the Krypton branch.
Still compiles, however it doesn't current have version checks for kodi-platform-git, so you'll have to make sure that is updated first. You may also have to install kodi-dev.

scachemaille commented on 2017-02-08 11:33

@ImNtReal Why to use janbar fork?
I used original github using Krypton branche and all is fine

ImNtReal commented on 2017-02-08 00:17

This should actually pull from https://github.com/janbar/pvr.mythtv, now.

sultanoswing commented on 2016-08-12 22:04

Won't compile for me now:

CMake Error at CMakeLists.txt:12 (find_package):
By not providing "Findplatform.cmake" in CMAKE_MODULE_PATH this project has
asked CMake to find a package configuration file provided by "platform",
but CMake did not find one.

Could not find a package configuration file provided by "platform" with any
of the following names:

platformConfig.cmake
platform-config.cmake

Add the installation prefix of "platform" to CMAKE_PREFIX_PATH or set
"platform_DIR" to a directory containing one of the above files. If
"platform" provides a separate development package or SDK, be sure it has
been installed.

Have read on a similar error message here: http://forum.kodi.tv/showthread.php?tid=220990&page=3

...but am none the wiser.

equinox commented on 2016-03-03 23:41

Patched to support API versions 15 (Isengard), 16 (Jarvis), and 99 (git master).

scachemaille commented on 2016-02-24 21:54

To make it works with kodi 16.0, I modified the PKGBUID with modifying _branch=Isengard to _branch=Jarvis

A maybe better solution I view for some other kodi addon are like as the
following, but I didn't test it.

API=16

source=("${pkgname}::git+https://github.com/kodi-pvr/pvr.mythtv.git")
md5sums=('SKIP')

case "$API" in
15) source[0]="${pkgname}::git+https://github.com/kodi-pvr/pvr.mythtv.git#branch=Isengard" ;;
16) source[0]="${pkgname}::git+https://github.com/kodi-pvr/pvr.mythtv.git#branch=Jarvis" ;;
99) ;;
*) error "Unknown API version. Follow instructions in PKGBUILD." && false
esac

pkgver() {
cd "$pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}