Package Details: kodi-addon-pvr-vuplus-git r111.1cc8b62-1

Git Clone URL: https://aur.archlinux.org/kodi-addon-pvr-vuplus-git.git (read-only)
Package Base: kodi-addon-pvr-vuplus-git
Description: VU+ addon for Kodi
Upstream URL: https://github.com/kodi-pvr/pvr.vuplus
Licenses: GPL
Groups: kodi
Conflicts: kodi-addon-pvr-vuplus
Provides: kodi-addon-pvr-vuplus
Submitter: blackhole
Maintainer: blackhole
Last Packager: blackhole
Votes: 4
Popularity: 0.002183
First Submitted: 2015-08-23 23:55
Last Updated: 2016-07-02 22:45

Latest Comments

Neverth commented on 2017-05-11 18:23

Change source branch to Krypton on source line and replace kodi-platform-git with kodi-dev and the package builds and works.

nomenquis commented on 2017-04-06 07:05

This package does not build anymore for me on an up to date system:

: Building kodi-addon-pvr-vuplus-git package(s)...
==> Making package: kodi-addon-pvr-vuplus-git r111.1cc8b62-1 (Thu Apr 6 08:53:53 CEST 2017)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Starting pkgver()...
==> Starting build()...
-- The C compiler identification is GNU 6.3.1
-- The CXX compiler identification is GNU 6.3.1
-- Check for working C compiler: /usr/lib/ccache/bin/cc
-- Check for working C compiler: /usr/lib/ccache/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/lib/ccache/bin/c++
-- Check for working CXX compiler: /usr/lib/ccache/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
CMake Error at CMakeLists.txt:9 (find_package):
By not providing "Findkodi.cmake" in CMAKE_MODULE_PATH this project has
asked CMake to find a package configuration file provided by "kodi", but
CMake did not find one.

Could not find a package configuration file provided by "kodi" with any of
the following names:

kodiConfig.cmake
kodi-config.cmake

Add the installation prefix of "kodi" to CMAKE_PREFIX_PATH or set
"kodi_DIR" to a directory containing one of the above files. If "kodi"
provides a separate development package or SDK, be sure it has been
installed.


-- Configuring incomplete, errors occurred!
See also "/home/philip/.cache/pacaur/kodi-addon-pvr-vuplus-git/src/pvr.vuplus/build/CMakeFiles/CMakeOutput.log".
==> ERROR: A failure occurred in build().
Aborting...
:: kodi-platform-git is now an orphan package
:: failed to build kodi-addon-pvr-vuplus-git package(s)

regagain commented on 2016-07-04 17:13

It is working now, thanks!

blackhole commented on 2016-07-02 22:47

I have added branch=Jarvis to source
Now, if you recompile first kodi-platform-git it should work (in the PKGBUILD you must have API=16)

blackhole commented on 2016-07-02 22:21

I seems that this is working only with kodi-git
See last post here
https://bbs.archlinux.org/viewtopic.php?id=200221

regagain commented on 2016-07-02 18:29

Hey guys,
I get this error when running makepkg:

/home/reg/Downloads/kodi-addon-pvr-vuplus-git/src/pvr.vuplus/src/client.cpp: In function ‘PVR_ERROR GetAddonCapabilities(PVR_ADDON_CAPABILITIES*)’:
/home/reg/Downloads/kodi-addon-pvr-vuplus-git/src/pvr.vuplus/src/client.cpp:339:18: error: ‘PVR_ADDON_CAPABILITIES {aka struct PVR_ADDON_CAPABILITIES}’ has no member named ‘bSupportsRecordingFolders’; did you mean ‘bSupportsRecordings’?
pCapabilities->bSupportsRecordingFolders = true;
^~~~~~~~~~~~~~~~~~~~~~~~~
make[2]: *** [CMakeFiles/pvr.vuplus.dir/build.make:63: CMakeFiles/pvr.vuplus.dir/src/client.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:100: CMakeFiles/pvr.vuplus.dir/all] Error 2
make: *** [Makefile:150: all] Error 2
==> ERROR: A failure occurred in build().

Any idea what's going on? Thanks

blackhole commented on 2015-09-06 10:42

Ok, fixed. Thanks

CaptainHook8 commented on 2015-09-06 10:25

I think "kodi-platform-git" (https://aur.archlinux.org/packages/kodi-platform-git/) needs to be a dependency, otherwise addon doesn't get enabled in kodi.
Thank you.