Package Details: kodi-c1-eventclients-fb 17.0.20151205-1

Git Clone URL: https://aur.archlinux.org/kodi-c1-fb.git (read-only)
Package Base: kodi-c1-fb
Description: Kodi Event Clients (ODROID-C1)
Upstream URL: http://kodi.tv
Licenses: GPL2
Conflicts: kodi-eventclients
Provides: kodi-eventclients
Submitter: Apokalypz
Maintainer: None
Last Packager: Apokalypz
Votes: 0
Popularity: 0.000000
First Submitted: 2015-12-06 14:28
Last Updated: 2015-12-06 14:28

Dependencies (53)

Required by (0)

Sources (6)

Latest Comments

Apokalypz commented on 2015-12-30 17:52

It does compile successfully using 5.2 or 5.3, but adding anything to the video database causes KODI to crash. It's a common problem across all major ARM builds that I have seen.

Semi-related side note. Arch recently changed to a new ABI, and recommends everything be built using the new ABI. I haven't upgraded my packages since this change as I don't want issues, so I can't test this. However, if you already upgraded, you can force KODI to build with the new ABI while using GCC 5.1 if you add the following line to the CFLAGS in the PKGBUILD:
"-D_GLIBCXX_USE_CXX11_ABI=1"

Raspberry PI users reported success in the archlinuxarm forums.

daniel.otero commented on 2015-12-30 12:45

I was able to compile it with GCC 5.3.0. Why is <5.2.0 needed?