Package Details: komikku 0.38.0-1

Git Clone URL: https://aur.archlinux.org/komikku.git (read-only, click to copy)
Package Base: komikku
Description: Online/Offline Manga reader based on GNOME | PinePhone/Librem 5 Support
Upstream URL: https://gitlab.com/valos/Komikku
Keywords: comics gnome librem manga pinephone reader
Licenses: GPL3
Submitter: fushinari
Maintainer: Peter2469
Last Packager: Peter2469
Votes: 14
Popularity: 1.20
First Submitted: 2020-01-10 00:16 (UTC)
Last Updated: 2022-04-22 17:10 (UTC)

Pinned Comments

Latest Comments

Peter2469 commented on 2022-04-22 17:31 (UTC)

I have updated to v0.38.0
I tested it on my PinePhone and it builds from AUR as well and should build fine on other machines.

This is my first package maintained so I will try my best to help but I may not know as much as others

Peter2469 commented on 2022-03-23 18:58 (UTC) (edited on 2022-03-23 18:58 (UTC) by Peter2469)

I have updated the package @snogard thanks for the heads up

snogard commented on 2022-03-23 18:44 (UTC) (edited on 2022-03-23 18:44 (UTC) by snogard)

Hi @Peter2469 i just noticed that libhandy was finally updated -> https://archlinux.org/packages/extra/x86_64/libhandy/

Peter2469 commented on 2022-03-19 19:40 (UTC)

Hey @snogard;
That is very kind of you however that has been tried before by myself and other people here however they seem to unflag it after a couple hours.

I have tried to build libhandy with libhandy-git but that does not build either so I am assuming it might be something to do with libhandy itself or arch itself but who knows

snogard commented on 2022-03-19 19:36 (UTC)

@Peter2469 i flagged libhandy out of date, maybe it will be updated soon

Peter2469 commented on 2022-02-25 12:53 (UTC)

This is just a quick update.
Libhandy is still at v1.4.0 therefore I still cannot update

Shiba commented on 2022-01-24 13:52 (UTC) (edited on 2022-01-24 13:53 (UTC) by Shiba)

@fushinari and odd numbers were only used for .90 releases until now, hence why the trend so far seemed to be odd == development. Maybe they decided to change that idk, but Arch devs seems to share the same concern since they removed the out-of-date flag from libhandy-1.4.0.

fushinari commented on 2022-01-16 17:47 (UTC)

@Shiba the .90 there is the indicator that it's an unstable version, not the minor version number.

Shiba commented on 2022-01-16 14:13 (UTC)

@fushinari as far as I can see it has always been like that, just look at 1.1.90 and 1.3.90. 1.5 is the first (apparently) not following that schema, I can't blame Arch devs if they are taking this slowly.

Regarding this package I too agree it would be better to wait for libhandy>=1.5 to land in Extra. In the meantime it could be useful (when feasible, obviously) to backport fixes for the broken backends.

Peter2469 commented on 2022-01-16 12:44 (UTC)

@fushinari Likely correct, The patch does do what you said and reverts that commit and change the dependency for libhandy but I will wait for libhandy to update to 1.5-1.6 if that is the safest option

fushinari commented on 2022-01-16 12:40 (UTC)

@Peter2469

The patch shouldn't be breaking anything. It should be as simple as reverting https://gitlab.com/valos/Komikku/-/commit/62e1518afc69536e18d9409654f385aa2ef0660e . If that's what you've done and you still have the bug, it's probably an upstream bug.

That said, I would suggest not patching. It's almost never a good decision. In this case, it's actually pretty much non-destructive but you can never really be sure what breaks for who and how.

Peter2469 commented on 2022-01-16 12:35 (UTC)

I have forgotten to add that the patch does remove some features which is the reason why they upp'd the version of libhandy from looking into it

Peter2469 commented on 2022-01-16 12:33 (UTC)

There is a patch that can force libhandys requirement to be 1.4.0 as it was whilst updating too the latest version however I am still looking and testing it.
The patch does fix the issue and does build to the latest version but there is an annoying bug where your read comics will be assumed that it has not been read. I do not know if this is a bug from the patch or from upstream but I am assuming it is the patch
If there is no issues with this I can push it or wait for the next release of libhandy @fushinari @Shiba

fushinari commented on 2022-01-16 12:28 (UTC)

@Shiba libhandy 1.5.0 is a stable release and libhandy has never adopted the versioning system used by the other GNOME stuff. This is exactly the kind of scenario where Arch's packaging should have had an advantage, because the GNOME Platform 41 flatpak runtime is finalized with 1.4.0 while in Arch, libhandy can be upped to 1.5.0 without consequence. But clearly, the Komikku flatpak works, even if it is by means of bundling libhandy 1.5.0 while the AUR package simply cannot be updated.

Shiba commented on 2022-01-16 12:08 (UTC)

libhandy will most likely be at 1.4 until 1.6 is out, historically odd numbers are development releases in the GNOME world. But I guess developers don't care anymore since the cancer of bundled runtimes started spreading to GNU/Linux too...

Peter2469 commented on 2021-10-22 20:59 (UTC) (edited on 2021-12-21 12:26 (UTC) by Peter2469)

Hello @TheJackiMonster,
I have updated the dependency.
Sorry for the wait and thank you for your comment as otherwise I would have not known

TheJackiMonster commented on 2021-10-22 20:22 (UTC)

Please add python-pytz to the dependencies. It was necessary to install, otherwise it crashed on startup.

fushinari commented on 2021-09-07 07:45 (UTC)

I don't use Arch anymore. So I've disowned this package.

fushinari commented on 2021-03-19 06:51 (UTC)

@godofgrunts Thanks for letting me know. I've fixed this and one other bug in the newer version of the package. I don't get to test my packages in a clean environment, so reports like this are much appreciated :)

godofgrunts commented on 2021-03-18 02:34 (UTC)

I think you need to include python-requests as a dependency.

Traceback (most recent call last): File "/usr/bin/komikku", line 69, in <module> from komikku.application import Application File "/usr/lib/python3.9/site-packages/komikku/application.py", line 25, in <module> from komikku.card import Card File "/usr/lib/python3.9/site-packages/komikku/card.py", line 18, in <module> from komikku.models import create_db_connection File "/usr/lib/python3.9/site-packages/komikku/models/init.py", line 5, in <module> from .database import backup_db File "/usr/lib/python3.9/site-packages/komikku/models/database.py", line 16, in <module> from komikku.servers import convert_image File "/usr/lib/python3.9/site-packages/komikku/servers/init.py", line 22, in <module> import requests ModuleNotFoundError: No module named 'requests'

After installing python-requests I was able to open the program.

txtsd commented on 2021-01-03 19:37 (UTC)

@fushinari thanks for clarifying

fushinari commented on 2021-01-03 14:33 (UTC)

@txtsd : Both are supported by Komikku. See https://gitlab.com/valos/Komikku/-/commit/e0137a0f07c5548bb89af4b0b81e38ce2818a3cf

txtsd commented on 2021-01-02 04:15 (UTC)

This package should explicitly require python-magic-ahupp.

python-magic is a completely different package and has nothing to do with the python-magic-ahupp that komikku requires.

fushinari commented on 2020-11-15 12:58 (UTC)

@pcb060 Manjaro is unsupported by me. Only Arch and Arch derivatives using up-to-date package repositories are supported. Manjaro's libhandy package was very outdated last I checked.

pcb060 commented on 2020-10-25 16:32 (UTC) (edited on 2020-11-02 16:28 (UTC) by pcb060)

Install fails using official libhandy package (using Manjaro Gnome)

Run-time dependency libhandy-1 found: NO (tried pkgconfig and cmake)

Komikku-v0.21.1/data/meson.build:49:0: ERROR: Dependency "libhandy-1" not found, tried pkgconfig and cmake

==> ERROR: A failure occurred in build().
    Aborting...
:: Unable to build komikku - makepkg exited with code: 4

edit: fixed by using libhandy-git instead

edit #2: went back to official libhandy since libhandy-git breaks gnome-settings and other stuff

balrog4k commented on 2020-07-04 09:12 (UTC)

@fushinari Thanks for the fix, now package is building and working good.

fushinari commented on 2020-07-04 03:23 (UTC) (edited on 2020-07-04 03:24 (UTC) by fushinari)

@balrog4k Yep, sorry for that. I didn't get time to test it and somehow ended up accidentally pushing it out anyway. It should work now.

Edit: I'd rather not use the patch at all, but I can't freeze libhandy1 either.

balrog4k commented on 2020-07-03 20:37 (UTC) (edited on 2020-07-03 20:38 (UTC) by balrog4k)

Is package broken now? I think it's happens after adding a patch.

-> Found newer_libhandy.patch
==> Validating source files with sha256sums...
    Komikku-v0.17.0.tar.gz ... Passed
    newer_libhandy.patch ... FAILED
==> ERROR: One or more files did not pass the validity check!

fushinari commented on 2020-06-18 09:39 (UTC)

@TAAPAye I've given an explanation here: https://gitlab.com/valos/Komikku/-/issues/71#note_363524003

TAAPAye commented on 2020-06-17 08:37 (UTC)

So I installed libhandy-git from the aur, and everything works fine. Perhaps it is better to have an aur dependency than be out of date.