Package Details: konstruktor-git 0.9.0.beta1.r95.gcb9d35f-2

Git Clone URL: https://aur.archlinux.org/konstruktor-git.git (read-only)
Package Base: konstruktor-git
Description: A LDraw-based virtual LEGO(r) CAD for KDE 5.
Upstream URL: http://opendesktop.org/content/show.php?content=138138
Licenses: GPL
Conflicts: konstruktor
Provides: konstruktor
Submitter: IwfY
Maintainer: bidulock
Last Packager: bidulock
Votes: 6
Popularity: 0.086135
First Submitted: 2012-12-01 22:58
Last Updated: 2016-05-30 18:40

Required by (0)

Sources (1)

Latest Comments

greenmanalishi commented on 2015-03-28 00:22

Sorry I meant something like: -DCMAKE_CXX_FLAGS='-std=c++0x' although this should be fixed upstream.

greenmanalishi commented on 2015-03-27 20:51

it needs C++11 to compile, else it fails with message: /home/jourgen/.build/konstruktor-git/src/konstruktor-git/src/libldr/reader.cpp:261:34: error: ‘stoi’ is not a member of ‘std’
return new element_ref(color(std::stoi(col, nullptr, 0)), matrix(a, b, c, d, e, f, g, h, i, x, y, z), fn);

IwfY commented on 2014-04-24 20:46

I'm not sure which libs are needed exactly. Maybe someone else can pick this up.

bidulock commented on 2014-04-23 23:04

latest git builds against qt5 not qt4 so build fails

greenmanalishi commented on 2014-01-30 22:20

Qt5 is used, needs update.

bidulock commented on 2013-07-07 07:32

PKGBUILD uses deprecated approaches