Package Details: konstruktor 0.9.beta1-3

Git Clone URL: https://aur.archlinux.org/konstruktor.git (read-only)
Package Base: konstruktor
Description: A LDraw-based virtual LEGO(r) CAD for KDE 4.
Upstream URL: http://opendesktop.org/content/show.php?content=138138
Licenses: GPL
Submitter: archdria
Maintainer: bidulock
Last Packager: bidulock
Votes: 8
Popularity: 0.000000
First Submitted: 2011-02-02 14:13
Last Updated: 2016-05-30 18:39

Latest Comments

bidulock commented on 2014-04-23 23:05

beta1 is no longer a valid pkgrel

tocer commented on 2013-01-16 02:50

compile error: https://gist.github.com/4544232

flying-sheep commented on 2012-09-01 13:44

checksums changed again…

Seninha commented on 2012-05-31 18:48

The package are still having problems with the MD5sum

Svenstaro commented on 2012-05-26 11:30

Merging into konstruktor

archdria commented on 2011-02-09 17:51

Updated, thanks, it has changed since I uploaded it...

Anonymous comment on 2011-02-09 17:20

Works indeed with the new MD5sum, thanks.

archdria commented on 2011-02-09 17:10

Updated, thanks, it has changed since I uploaded it...

Anonymous comment on 2011-02-09 15:55

Here it is: 702881530e111285968f889bffda6001

Anonymous comment on 2011-02-08 09:37

This is what I get when I do makepkg:

=> Validating source files with md5sums...
konstruktor-0.9-beta1.tar.bz2 ... FAILED
==> ERROR: One or more files did not pass the validity check

correct MD5 anyone?

archdria commented on 2011-02-06 12:02

What problems do you have? maybe it's a missing dependency...

Anonymous comment on 2011-02-04 18:57

i've to edit from source like said by dev on http://opendesktop.org/content/show.php?content=138138

Anonymous comment on 2011-02-04 10:54

http://aur.pastebin.com/DHKB4j8m
doesn't work for me.

Anonymous comment on 2011-02-01 20:32

konstruktor is the new version of kldraw...
http://opendesktop.org/content/show.php?content=138138
A PKGBUILD like that should work:

pkgname=konstruktor
pkgver=0.9b1
pkgrel=1
pkgdesc="LDraw-based virtual LEDO CAD for KDE4"
arch=('i686' 'x86_64')
url="http://konstruktor.influx.kr/"
license=('GPL')
depends=('kdelibs>=4.5' 'ldraw-parts-library' 'libgl' 'sqlite3')
makedepends=('gcc' 'cmake')
source=("http://konstruktor.influx.kr/$pkgname-0.9-beta1.tar.bz2")
md5sums=('f05e823a18f8b3f62ff36953e3f3b8f3')


build() {
cd ${srcdir}/$pkgname-0.9-beta1

cmake . -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr
make
make DESTDIR=${pkgdir} install
}

Anonymous comment on 2010-12-27 00:32

2010-12-27 01:25:59 (458 KB/s) - “47371-kldraw-0.1.0.tar.gz.part” saved [721374/721374]

-> Found automake_1.10.patch
==> Validating source files with md5sums...
47371-kldraw-0.1.0.tar.gz ... Passed
automake_1.10.patch ... Passed
==> Extracting Sources...
-> Extracting 47371-kldraw-0.1.0.tar.gz with bsdtar
==> Entering fakeroot environment...
==> Starting build()...
patching file admin/cvs.sh
/tmp/yaourt-tmp-ahel/aur-kldraw/./PKGBUILD: line 23: /etc/profile.d/kde.sh: No such file or directory
==> Finished making: kldraw 0.1.0-4 (Mon Dec 27 01:25:59 CET 2010)

==> Continue installing kldraw ? [Y/n]
==> [v]iew package contents [c]heck package with namcap
==> ---------------------------------------------------
==>

error: '/tmp/yaourt-tmp-ahel/PKGDEST.kXN/*': cannot open package file
==> WARNING: Your packages are saved in /tmp/yaourt-tmp-ahel/
cp: cannot stat `/tmp/yaourt-tmp-ahel/PKGDEST.kXN/*': No such file or directory
==> WARNING: Unable to copy packages to /tmp/yaourt-tmp-ahel/ directory
==> WARNING: Following packages have not been installed:
kldraw