Package Details: kqrcode 0.6.0-4

Git Clone URL: https://aur.archlinux.org/kqrcode.git (read-only)
Package Base: kqrcode
Description: A little program that is meant to encode/decode data to/from QR codes.
Upstream URL: http://kde-apps.org/content/show.php?content=143544
Licenses: GPL
Submitter: archdria
Maintainer: BluePeril
Last Packager: BluePeril
Votes: 19
Popularity: 0.365549
First Submitted: 2011-07-13 16:27
Last Updated: 2016-05-08 10:17

Dependencies (5)

Required by (0)

Sources (5)

Latest Comments

BluePeril commented on 2016-05-08 10:19

Thanks for the changes

macieks commented on 2016-05-06 20:19

In relation to my previous comment.... I found what's causing the problem. The root cause is that the plugins projects are copied directly to the main app directory. Plugins CMakeLists.txt need to be updated to reflect that they are no longer separate project.

I changed the PKGBUILD and prepared a patch fixing all the CMakeLists.txt:
PKGBUILD: https://ptpb.pw/kOaP
kqrcode-plugins-cmake.patch: https://ptpb.pw/su_F

macieks commented on 2015-11-13 09:22

Build fails with error:

CMake Error at /usr/share/apps/cmake/modules/FindKDE4Internal.cmake:1465 (add_custom_target):
add_custom_target cannot create target "uninstall" because another target
with the same name already exists. The existing target is a custom target
created in source directory
"/tmp/yaourt-tmp-m/aur-kqrcode/src/kqrcode-0.6.0/icons". See
documentation for policy CMP0002 for more details.

But I have no idea how to fix that.

yetr2 commented on 2015-04-09 15:46

need to add "makedepends=('cmake')"

ariscop commented on 2011-12-31 22:43

this pagkage requires automoc4

i don't realy want to adopt this, only need it for 5 min

archdria commented on 2011-08-09 22:05

I'm disowning this package, feel free to adopt it :)