Package Details: krop 0.6.0-1

Git Clone URL: https://aur.archlinux.org/krop.git (read-only, click to copy)
Package Base: krop
Description: A tool to crop PDF files, with an eye towards eReaders.
Upstream URL: http://arminstraub.com/computer/krop
Licenses: GPL3
Submitter: archtux
Maintainer: XavierCLL
Last Packager: XavierCLL
Votes: 33
Popularity: 0.017419
First Submitted: 2013-07-31 12:39
Last Updated: 2020-06-19 23:15

Pinned Comments

XavierCLL commented on 2020-06-19 23:18

If you get this error RuntimeError: Please install popplerqt5 first rebuild python-poppler-qt5 from AUR, NOT use the binary from some unofficial repository, sometimes it happens with those unofficial repos that some libraries are out of sync with the latest version of python

Latest Comments

« First ‹ Previous 1 2 3 4

archtux commented on 2014-04-01 21:58

@danyf90
This is the same error as in 'frescobaldi' : https://aur.archlinux.org/packages/frescobaldi/
Can you remove the 2 dependencies and 'krop' and build and install them again?
I've build the dependencies and installed 'krop' and no errors!

danyf90 commented on 2014-04-01 07:07

After a system update i get:
[daniele@archlinux ~]$ krop
Traceback (most recent call last):
File "/usr/bin/krop", line 19, in <module>
krop.krop.main()
File "/usr/lib/python2.7/site-packages/krop/krop.py", line 54, in main
from mainwindow import MainWindow
File "/usr/lib/python2.7/site-packages/krop/mainwindow.py", line 30, in <module>
from vieweritem import ViewerItem
File "/usr/lib/python2.7/site-packages/krop/vieweritem.py", line 20, in <module>
from popplerqt4 import Poppler
RuntimeError: the sip module implements API v11.0 but the popplerqt4 module requires API v10.1

mrbit commented on 2014-02-02 00:23

please update to 4.5 thanks