Package Details: ksh 2014.06.25beta-1

Git Clone URL: (read-only)
Package Base: ksh
Description: AT&T's Korn shell ksh93 nmake from ast-base
Upstream URL:
Licenses: EPL, CPL
Conflicts: pdksh
Submitter: None
Maintainer: severach
Last Packager: severach
Votes: 43
Popularity: 1.365052
First Submitted: 2007-11-14 01:11
Last Updated: 2016-01-19 17:04

Latest Comments

severach commented on 2016-01-19 17:06

Looks like the AT&T download and list servers are down. I put in some alternate sources with matching SHA sums.

The authors have verified that the AT&T servers are down some time before 2015-12-31. The new software location is

fastgar commented on 2016-01-18 08:43

Package server is not available. Since a longer time.
Failed to connect to port 80: Keine Route zum Zielrechner

severach commented on 2015-10-18 16:45

This won't build with yaourt. Download, amend PKGBUILD.local as instructed, and make with makepkg.

anpieber commented on 2015-10-18 05:53

I als get the an authentication error

==> Retrieving sources...
-> Downloading INIT.2014-12-24.tgz...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0curl: (22) The requested URL returned error: 401 Authorization Required
==> ERROR: Failure while downloading INIT.2014-12-24.tgz

severach commented on 2015-09-22 22:56

That should work better.

sputnick commented on 2015-09-22 20:50

The PKGBUILD failed on : 'curl: (22) The requested URL returned error: 401 Authorization Required'

severach commented on 2015-07-09 00:52

Comment by severach 2015-06-11 08:49

packer does it's own work without makepkg. I fixed the PKGBUILD so it doesn't error out. Packer doesn't give you access to edit the PKGBUILD before building so I don't think this 2 step build will work with packer.

I used to use yaourt but switched to cower. Downloading the files is the difficult part so that's the only thing I want done for me. I always makepkg manually.

With only one comment in the last 2 years I though this would be an unpopular package. Looks like everyone saw there was no hope and just gave up.

severach commented on 2015-07-09 00:51

Comment by Airblader 2015-06-11 05:46
With packer I only get an error:

/tmp/packertmp-1000/ksh.PKGBUILD: line 166: SOURCEONLY: unbound variable

With yaourt, I'm prompted for the license stuff.

severach commented on 2015-07-09 00:50

Comment by severach 2015-06-10 05:29
The build is improved so the error and how to fix steps are more obvious.

severach commented on 2015-07-09 00:50

Comment by haawda 2015-06-09 21:54
that is by design, read the PKGBUILD.

All comments