Package Details: ksnip-git v1.5.0.r26.g66effc7-1

Git Clone URL: https://aur.archlinux.org/ksnip-git.git (read-only)
Package Base: ksnip-git
Description: Screenshot tool inspired by Windows Snipping Tool and made with Qt for Linux
Upstream URL: https://github.com/DamirPorobic/ksnip
Licenses: GPL
Conflicts: ksnip
Provides: ksnip
Submitter: dracorp
Maintainer: dracorp
Last Packager: dracorp
Votes: 4
Popularity: 0.021367
First Submitted: 2017-04-06 21:00
Last Updated: 2019-04-02 16:54

Latest Comments

1 2 Next › Last »

dracorp commented on 2019-04-12 15:59

@Danieldakataca great log :) could you paste some text?

Danieldakataca commented on 2019-04-09 23:01

  • Configuring incomplete, errors occurred!

See also "/home/daka/Scripts/Ksnip/ksnip-

git/src/ksnip/build/CMakeFiles/CMakeOutput.log".

==> ERROR: Se produjo un fallo en build().

Cancelando...

j1simon commented on 2019-04-02 12:07

it lacks kcolorpicker-git as dependency.

tobru commented on 2019-01-17 10:14

The dependency kcolorpicker-git should be in depends, otherwise it gets removed by f.e. yay after build and Ksnip doesn't work then.

dracorp commented on 2018-10-28 21:03

Now it should works. Added missing packages: kcolorpicker and kimageannotator

Plexcon commented on 2018-10-25 22:24

CMake Error at CMakeLists.txt:33 (find_package): By not providing "FindkImageAnnotator.cmake" in CMAKE_MODULE_PATH this project has asked CMake to find a package configuration file provided by "kImageAnnotator", but CMake did not find one.

Could not find a package configuration file provided by "kImageAnnotator" (requested version 0.0.1) with any of the following names:

kImageAnnotatorConfig.cmake
kimageannotator-config.cmake

Add the installation prefix of "kImageAnnotator" to CMAKE_PREFIX_PATH or set "kImageAnnotator_DIR" to a directory containing one of the above files. If "kImageAnnotator" provides a separate development package or SDK, be sure it has been installed.

-- Configuring incomplete, errors occurred! See also "/tmp/pamac-build-velkerk-user/ksnip-git/src/ksnip/build/CMakeFiles/CMakeOutput.log". ==> ERROR: Se produjo un fallo en build(). Cancelando...

johndoeblank1 commented on 2018-02-21 05:35

My kernel is at 4.15.3-2-ARCH, cmake version 3.10.2, Qt version 5.10.1.

When I try to install this through yaourt it gives me:


    CMake Error at CMakeLists.txt:23 (find_package):
      Could not find a package configuration file provided by "ECM" with any of
      the following names:

        ECMConfig.cmake
        ecm-config.cmake

      Add the installation prefix of "ECM" to CMAKE_PREFIX_PATH or set "ECM_DIR"
      to a directory containing one of the above files.  If "ECM" provides a
      separate development package or SDK, be sure it has been installed.


    -- Configuring incomplete, errors occurred!
    See also "/home/xyzuser/Downloads/ksnip-master/build/CMakeFiles/CMakeOutput.log".

I tried to build outside yaourt, it still gave me the message. Then I tried installing :

sudo pacman -S extra-cmake-modules qt5-tools

then the message went away. Please add these as dependencies.

CorporalKobold commented on 2018-02-02 20:22

extra-cmake-modules should be added as a make dependency, otherwise CMakeLists.txt fails at line 11 when it searches for ECM.

dracorp commented on 2018-01-08 17:33

Probably there were some changes in sources. I've changed *depends.

omni commented on 2018-01-08 16:53

why not use qt5?

I changed PKGBUILD: removed qt4 and added qt5-base, removed qt4 as makedepend.

builds fine!