Package Details: ksnip 1.7.3-1

Git Clone URL: https://aur.archlinux.org/ksnip.git (read-only, click to copy)
Package Base: ksnip
Description: Screenshot tool inspired by Windows Snipping Tool and made with Qt for Linux
Upstream URL: https://github.com/DamirPorobic/ksnip
Licenses: GPL
Conflicts: ksnip-git
Submitter: dracorp
Maintainer: dracorp
Last Packager: dracorp
Votes: 19
Popularity: 0.55
First Submitted: 2019-09-04 19:15
Last Updated: 2020-08-10 20:48

Latest Comments

1 2 Next › Last »

dracorp commented on 2020-07-01 14:25

Yes. Yay asked me about it:

$ yay -S ksnip
:: There are 2 providers available for ksnip:
:: Repository AUR
    1) ksnip 2) ksnip-git 

Enter a number (default=1): 1
:: Checking for conflicts...
:: Checking for inner conflicts...
[Aur: 3]  kcolorpicker-0.1.4-1  kimageannotator-0.3.1-1  ksnip-1.7.1-2

  3 kcolorpicker                    
  2 kimageannotator                  (Build Files Exist)
  1 ksnip                            (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> A

rugginic commented on 2020-07-01 07:30

@dracorp Thanks, have you tried a clean install, where also deps have to be installed? or an upgrade? Mine was a clean install.

dracorp commented on 2020-06-30 20:55

But yay also works for me.

dracorp commented on 2020-06-30 20:53

@rugginic Probably there is a problem with yay. It works great with yaourt.

yaourt -S ksnip
...
ksnip 1.7.1-2  (2020-06-29 22:01)
( Unsupported package: Potentially dangerous ! )
==> ksnip dependencies:
 - qt5-x11extras (already installed)
 - cmake (already installed) [makedepend]
 - extra-cmake-modules (already installed) [makedepend]
 - qt5-tools (already installed) [makedepend]
 - kimageannotator>=0.3.1 (building from AUR) [makedepend]
 - kimageannotator>=0.3.1 (building from AUR) [makedepend]


==> Continue building ksnip ? [Y/n]
==> -------------------------------
==> 
==> Building and installing package
==> Install or build missing dependencies for ksnip:

==> Downloading kimageannotator PKGBUILD from AUR...
x .SRCINFO
x PKGBUILD
...

rugginic commented on 2020-06-30 07:05

@dracorp

Sorry it did not work for me. Failing to install dep 'kimageannotator>=1.3.1' (all one word)

I had to manually install deps: yay -S kcolorpicker yay -S kimageannotator

and then remove them from the makedeps in PKGBUILD

dracorp commented on 2020-06-29 22:03

I've added new depends, non-git version.

rugginic commented on 2020-06-29 12:06

@dsch I had the same problem.

I resolved modifying the PKGBUILD in order to use the latest version instead: Change pkgver=1.6.2

to pkgver=1.7.1

and change the sha256sum of the file: $ sha256sum ksnip-1.7.1.tar.gz 43c18bd8110caa9a778878d56df4e5a2716b8c51a3edf65f3077413fe9f0dbac ksnip-1.7.1.tar.gz

then retry makepkg -si

dsch commented on 2020-05-14 00:11

@dracorp I am getting the following errors:

/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../lib/libkImageAnnotator.so: undefined reference to qt_version_tag@Qt_5.14'
/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../lib/libkImageAnnotator.so: undefined reference toqt_resourceFeatureZlib@Qt_5'
collect2: error: ld returned 1 exit status
make[2]:  [src/CMakeFiles/ksnip.dir/build.make:1338: src/ksnip] Error 1
make[1]:  [CMakeFiles/Makefile2:185: src/CMakeFiles/ksnip.dir/all] Error 2
make: *** [Makefile:150: all] Error 2
Maybe something like cmake add_definitions(-DQT_NO_VERSION_TAGGING) would help?

danievdm commented on 2020-03-05 19:03

@dracorp - thanks I came right with the AppImage for now - working fine.

dracorp commented on 2020-03-05 14:35

You can try to rebuild kImageAnnotator-git and kColorPicker-git. These are git version package and they don't need to be updated.