Package Details: kst-git 2.0.8-1

Git Clone URL: https://aur.archlinux.org/kst-git.git (read-only)
Package Base: kst-git
Description: Fast real-time large-dataset viewing and plotting tool for KDE
Upstream URL: http://kst-plot.kde.org
Licenses: GPL
Conflicts: kst
Submitter: Malkut
Maintainer: Malkut
Last Packager: Malkut
Votes: 4
Popularity: 0.000162
First Submitted: 2015-07-25 23:06
Last Updated: 2019-07-01 14:16

Dependencies (11)

Required by (0)

Sources (2)

Latest Comments

1 2 3 Next › Last »

Malkut commented on 2019-07-01 14:13

@net147 I updated the PKGBUILD file and we are following the KDE git now Also I had some issues with building on my system because the HDF5 includes are installed in /usr/include I added a patch to fix that let me know if this work with you.

net147 commented on 2019-07-01 02:23

The github mirror is not up to date with git://anongit.kde.org/kst-plot.git

Malkut commented on 2018-10-13 20:17

@net147 Done, however on my computer the build fil because of missing #include <qstyle> in shortcutdialog.cpp I created a new patch for that. Let me know if you have issue with it.</qstyle>

net147 commented on 2018-10-13 03:24

0001-Build-fixes-for-Qt-5.11.patch should be removed as the changes are already upstream. Would it be better to use the upstream repository at git://anongit.kde.org/kst-plot.git instead of the mirror?

Malkut commented on 2018-10-03 13:40

@net147 It should be fixed now.

net147 commented on 2018-10-03 05:26

==> Starting prepare()... patching file cmake/modules/KstMacros.cmake Hunk #1 FAILED at 240. 1 out of 1 hunk FAILED -- saving rejects to file cmake/modules/KstMacros.cmake.rej patching file src/libkstapp/view.h ==> ERROR: A failure occurred in prepare(). Aborting...

diggit commented on 2018-09-02 14:34

dependency qt5 does not exist, you need to modify .SRCINFO (makepkg --printsrcinfo > .SRCINFO)

Malkut commented on 2018-06-21 14:45

@net147 I implemented your changes. I saw you put a pull request in the kst-git repository so hopefully they will merge it and I can remove this workaround. Let me know if it works for you.

net147 commented on 2018-06-21 07:17

@Malkut Does not build with Qt 5.11. Here is patch to fix it: https://pastebin.com/raw/GDGqhde9

mani.zaeim commented on 2018-04-22 14:14

I ran yaourt to update the system 3 times today, and all the times this package start updating compiling and installing!