Package Details: ktechlab-git 0.3.7.r1747d071-3

Git Clone URL: https://aur.archlinux.org/ktechlab-git.git (read-only)
Package Base: ktechlab-git
Description: KTechLab is an IDE for microcontrollers and electronics. It supports circuit simulation, program development for microcontrollers and simulating the programmed microcontroller together with its application circuit.
Upstream URL: https://github.com/ktechlab/ktechlab
Keywords: ktechlab
Licenses: GPL
Submitter: dmidge
Maintainer: dmidge
Last Packager: dmidge
Votes: 4
Popularity: 0.000009
First Submitted: 2017-05-06 02:13
Last Updated: 2017-11-17 03:53

Latest Comments

zoltanp commented on 2019-02-11 08:21

Hi,

I've got an issue report at KTechlab about this AUR package:

https://github.com/ktechlab/ktechlab/issues/48

I have never used Arch Linux, so is here someone who can help fixing the issue?

Also I use this opportunity to do some advertisement:

  • the latest version of KTechLab is v0.40.1:

https://github.com/ktechlab/ktechlab/releases

  • the official KTechLab git repository is hosted at KDE, since KTechLab has become a KDE project:

https://cgit.kde.org/ktechlab.git/

so as git URL I recommend this one:

git://anongit.kde.org/ktechlab.git

The repository at Github is still functioning as a mirror of the one at KDE

Have fun with KTechLab ;-)

dmidge commented on 2017-11-17 03:55

Thank you eduardosm. I just applied the modification. It should be live now!

eduardosm commented on 2017-11-07 20:25

I'm getting:
==> Starting pkgver()...
==> ERROR: pkgver is not allowed to contain colons, hyphens or whitespace.
==> ERROR: pkgver() generated an invalid version: 0.3.7.rv0.40.0-8-g34b41aa3

Maybe pkgver() should be changed to something like:
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'

dmidge commented on 2017-09-09 00:00

Hm, indeed. It seems I missed one step when I commited the file. Hopefully, this is fixed now!

fauxmight commented on 2017-08-20 14:27

automoc4 make dependency is still missing

dmidge commented on 2017-07-15 00:05

Thanks XDjackieXD and rdoursenaud! Both dependencies should be added now.

XDjackieXD commented on 2017-05-31 15:35

A make dependency on automoc4 is missing

rdoursenaud commented on 2017-05-30 09:58

You're missing a dependency on kdelibs.