Package Details: ktexteditor-git r1114.f3f4319-2

Git Clone URL: https://aur.archlinux.org/ktexteditor-git.git (read-only)
Package Base: ktexteditor-git
Description: KTextEditor framework
Upstream URL: https://projects.kde.org/projects/frameworks/ktexteditor
Licenses: LGPL
Conflicts: ktexteditor
Provides: ktexteditor
Submitter: stavallo
Maintainer: None
Last Packager: Alad
Votes: 12
Popularity: 0.320687
First Submitted: 2014-01-14 18:22
Last Updated: 2016-06-24 01:41

Dependencies (4)

Required by (15)

Sources (2)

Latest Comments

desaparecido commented on 2016-08-31 06:44

hi, I have this error:

==> Starting prepare()...
patching file src/syntax/data/bash.xml
Hunk #1 FAILED at 8.
1 out of 1 hunk FAILED -- saving rejects to file src/syntax/data/bash.xml.rej
==> ERROR: A failure occurred in prepare().
Aborting...

for the moment I comment the patch lines, its only about PKGBUILD format

thanks

arojas commented on 2015-10-11 19:46

Fixed, thanks

tajidinabd commented on 2015-10-11 19:16

i am getting this error in regards to the patch

Updated version: ktexteditor-git r1114.f3f4319-1
==> Starting prepare()...
patching file src/syntax/data/bash.xml
Hunk #1 FAILED at 8.
1 out of 1 hunk FAILED -- saving rejects to file src/syntax/data/bash.xml.rej
==> ERROR: A failure occurred in prepare().
Aborting...
==> ERROR: Makepkg was unable to build ktexteditor-git.

davispuh commented on 2015-07-02 17:20

Need to quote $srcdir so that path with spaces work.

Here's a patch:

diff --git a/PKGBUILD b/PKGBUILD
index b856f80..787bb72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,7 @@ pkgver() {
prepare() {
mkdir -p build
cd ktexteditor
- patch -p0 -i $srcdir/pkgbuild-syntax-highlight.patch
+ patch -p0 -i "$srcdir/pkgbuild-syntax-highlight.patch"
}

build() {

arojas commented on 2014-06-04 06:08

@vizor it should work with an up to date ecm-git, or with ecm 0.0.14 that will be released today

vizor commented on 2014-06-03 23:08

With extra-cmake-modules and with extra-cmake-modules-git I get following error:

-- Detecting CXX compiler ABI info - done
CMake Error at CMakeLists.txt:6 (find_package):
Could not find a configuration file for package "ECM" that is compatible
with requested version "0.0.14".

The following configuration files were considered but not accepted:

/usr/share/ECM/cmake/ECMConfig.cmake, version: 0.0.13

-- Configuring incomplete, errors occurred!
See also "/tmp/yaourt-tmp-vizor/aur-ktexteditor-git/src/build/CMakeFiles/CMakeOutput.log".
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build ktexteditor-git.

ant32 commented on 2014-03-13 17:59

==> Starting pkgver()...
/startdir/PKGBUILD: line 4: No: command not found

Take a look at where it says "If there are no tags then use number of revisions since beginning of the history: " https://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines

Could you change the version line to
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"