Package Details: kube-prompt 1.0.10-1

Git Clone URL: https://aur.archlinux.org/kube-prompt.git (read-only, click to copy)
Package Base: kube-prompt
Description: An interactive kubernetes client featuring auto-complete using go-prompt
Upstream URL: https://github.com/c-bata/kube-prompt
Keywords: client go golang kube-prompt kubectl kubernetes terminal
Licenses: MIT
Conflicts: kube-prompt-git
Provides: kube-prompt
Submitter: ianberinger
Maintainer: ianberinger (matthias.lisin)
Last Packager: matthias.lisin
Votes: 4
Popularity: 1.28
First Submitted: 2017-09-05 16:59
Last Updated: 2019-12-03 10:51

Required by (0)

Sources (1)

Latest Comments

matthias.lisin commented on 2019-09-23 11:53

I've changed makedepends go-pie to go. Simply for convenience. go-pie users will still be able to do use it.

matthias.lisin commented on 2019-09-23 07:51

@argamanza Update to go >=1.13

The packaging guidelines say the following:

All packages should preferably be built towards go-pie as this enables us to deliver secure binaries.

It shouldn't matter if you use go or go-pie unless you have problems with it.

argamanza commented on 2019-09-23 05:38

I'm having trouble upgrading to the 1.0.8-1 version:

==> Making package: kube-prompt 1.0.8-1 (Mon 23 Sep 2019 08:35:27 IDT)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found kube-prompt
==> Validating source files with sha512sums...
    kube-prompt ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting kube-prompt with bsdtar
==> Sources are ready.
==> Making package: kube-prompt 1.0.8-1 (Mon 23 Sep 2019 08:35:32 IDT)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Starting build()...
flag provided but not defined: -trimpath
usage: go build [-o output] [-i] [build flags] [packages]
Run 'go help build' for details.
==> ERROR: A failure occurred in build().
    Aborting...
Error making: kube-prompt

I tried installing go instead of go-pie but it won't allow me to carry on with the installation unless i use go-pie. Any solution for that?

matthias.lisin commented on 2019-09-21 13:58

Thanks to ianberinger for allowing me to contribute.

I switched this package to build from source. If you prefer having the binary a reason, just ping me and I'll kube-prompt-bin for you.