Package Details: kubeadm-bin 1.14.1-0

Git Clone URL: https://aur.archlinux.org/kubeadm-bin.git (read-only)
Package Base: kubeadm-bin
Description: Kubernetes.io kubeadm binary
Upstream URL: http://kubernetes.io
Licenses: Apache
Conflicts: kubernetes, kubernetes-bin
Provides: kubeadm
Submitter: colemickens
Maintainer: icebal
Last Packager: icebal
Votes: 9
Popularity: 0.008051
First Submitted: 2017-07-02 22:47
Last Updated: 2019-04-09 17:51

Latest Comments

vianney commented on 2019-06-27 06:31

Hi icebal,

Regarding your comment:

since kubernetes-bin now supports armv7l/h, aarch64 and x86_64, does anybody need this package anymore? or should it be removed along with kubelet-bin?

I actually used it and now maintain a PKGBUILD based on yours, for my own use on my own repo. There were three versions released since the last time you updated this PKGBUILD: 1.14.2, 1.14.3 and now 1.15.0. If you need help keeping both kubelet-bin and kubeadm-bin up to date, do not hesitate to say so. I would be happy to help and since I'm already updating this package for myself, it wouldn't be too hard to add a step to push it here too.

edit: plus I just noticed armhf sha256sum was not updated since 1.13.3.

grollinger commented on 2019-01-18 21:01

after installing package version 1.13.0, I get the following output from kubeadm version:

kubeadm version: &version.Info{Major:"1", Minor:"12", GitVersion:"v1.12.2", GitCommit:"17c77c7898218073f14c8d573582e8d2313dc740", GitTreeState:"clean", BuildDate:"2018-10-24T06:51:33Z", GoVersion:"go1.10.4", Compiler:"gc", Platform:"linux/amd64"}

Why version 1.12.2 ?

icebal commented on 2018-12-10 19:32

since kubernetes-bin now supports armv7l/h, aarch64 and x86_64, does anybody need this package anymore? or should it be removed along with kubelet-bin? if people have a need, i'll keep supporting it, but i also don't want to support a package that is now obsolete.

icebal commented on 2018-09-10 06:25

PKGBUILD updated to 1.11.2, added archs armv7l, armv7h, and aarch64.

https://hastebin.com/ohuqobequc

icebal commented on 2018-09-10 05:01

Since @zao hasnt done this, i will update the PKGBUILD with arm/arm64 support

colemickens commented on 2017-09-29 16:34

Hi @zao, few things:

1. I have never made a PKGBUILD with multi-arch support.

2. I can't test it, as I have no ARMv7h hardware.

3. I think that kubelet-bin will need the same changes as this package relies on kubelet-bin (or it should, I'll try to fix that when I update it to 1.8.0).

If you would be willing to fork the PKGBUILD, add the ARMv7h support, test it, and send me a link, I would be happy to integrate the changes. Let me know what you think.

zao commented on 2017-09-28 17:27

Can you add the `armv7h` architecture?