Package Details: kupfer 208-9

Git Clone URL: https://aur.archlinux.org/kupfer.git (read-only)
Package Base: kupfer
Description: Launcher application written in python. Similar to Gnome-Do / Launchy
Upstream URL: http://engla.github.com/kupfer/
Licenses: GPL3
Submitter: AsA
Maintainer: dcelasun
Last Packager: dcelasun
Votes: 176
Popularity: 1.150207
First Submitted: 2009-07-02 15:18
Last Updated: 2015-06-08 10:25

Dependencies (17)

Required by (1)

Sources (2)

Latest Comments

dcelasun commented on 2014-01-07 17:32

Bumped pkgrel for a few optdepends.

dcelasun commented on 2014-01-07 17:32

Minor update for optdepends.

nTia89 commented on 2013-12-27 13:47

please add "python2-keyring" as opt dep
for Python module keyring

Diego commented on 2013-06-24 14:32

[BUG] Gmail plugin don't work also with
python2-gdata
python2-gnomekeyring

willemw commented on 2013-06-16 09:49

Kupfer does not start for me (libdbus-glib-1.so.2: cannot open shared object file: No such file or directory). Installing kupfer-git solved the problem.

From looking at the dependencies, the problem seems to be that the 'python2-gconf' dependency is missing.

chmurli commented on 2013-05-07 20:23

libpng15 shouldn't be a dependiency?

toketin commented on 2013-04-25 14:39

Ok the problem was "python2-dbus" i've reinstalled it again. Now Kupfer works fine!

SanskritFritz commented on 2013-04-25 13:43

I'm using this one, works great, maybe you could give it a try:
https://aur.archlinux.org/packages/kupfer-adds-git/

toketin commented on 2013-04-25 13:41

@SanskritFritz yes, maybe it's due to the new gnome 3.8 packages

SanskritFritz commented on 2013-04-25 12:01

toketin have you tried to rebuild the package?

toketin commented on 2013-04-25 11:59

I can't start Kupfer, this the output:

File "/usr/share/kupfer/kupfer.py", line 22, in <module>
main.main()
File "/usr/share/kupfer/kupfer/main.py", line 182, in main
gtkmain(quiet)
File "/usr/share/kupfer/kupfer/main.py", line 160, in gtkmain
from kupfer.ui import browser
File "/usr/share/kupfer/kupfer/ui/browser.py", line 21, in <module>
from kupfer.ui import listen
File "/usr/share/kupfer/kupfer/ui/listen.py", line 17, in <module>
except (ImportError, dbus.exceptions.DBusException), exc:
AttributeError: 'module' object has no attribute 'exceptions'

al3hex commented on 2013-01-17 16:07

@dcelasun
* Are you serious? https://wiki.archlinux.org/index.php/Arch_Packaging_Standards#Architectures
* I've only said to remove the 'v' fron 'pkgver' not to bump the 'pkgrel'!

dcelasun commented on 2013-01-17 15:55

@al3hex:
* No. There is absolutely no harm in keeping it i686/x86_64 as these are the only architectures supported by Arch.
* Really? This is *that* important to warrant an update? Sure, have it your way, but I'm not bumping the pkgrel just because you don't "like" a version string.
* I didn't know about this, so yes, I'm updating it.

al3hex commented on 2013-01-17 15:45

@dcelasun
* you should set arch to 'any'! (it's python!)
* delete the 'v' from pkgver! (it's useless!)
* change the url with one linked in my proposal, because github's downloads api is deprecated (see here: https://github.com/blog/1302-goodbye-uploads)
Thanks for your understanding!

dcelasun commented on 2013-01-17 15:17

@al3hex: Thanks, I've integrated most parts of your PKGBUILD.

al3hex commented on 2013-01-17 14:55

Please update PKGBUILD and install file: http://pastebin.com/83RsfNvd
About optdeps, the list would be very huge, but I decided to include only "recommended/opportunistic" deps listed in the official README here: https://github.com/engla/kupfer
Thanks!

Anonymous comment on 2013-01-13 23:21

I can't get v208-7 to build regardless of whether I have python-docutils or python2-docutils installed. Either way, I always fail with the following error:

You must have XML::Parser installed to run /usr/bin/intltool-merge

Waf: Leaving directory `/tmp/yaourt-tmp-david/aur-kupfer/src/kupfer-v208/build'
Build failed
-> task in 'kupfer-mimetypes.xml' failed (exit status 2):
{task 16992528: intltool kupfer-mimetypes.xml.in -> kupfer-mimetypes.xml}
['/usr/bin/perl', '/usr/bin/intltool-merge', '-x', '-q', '-u', '-c', '../auxdata/../po/.intlcache', '../po', '../auxdata/kupfer-mimetypes.xml.in', 'auxdata/kupfer-mimetypes.xml']
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build kupfer.

km3k commented on 2012-12-14 19:23

Update on the situation. It turns out I got confused with also having python-docutils on my system, but I got things working again.

Here's the problem:
kupfer's build script looks for rst2man (as a python 2 script), however on Arch Linux, the package python2-docutils provides rst2man2 and python-docutils provides rst2man (which is for python 3). If you have python-docutils is installed, the kupfer build script will try to run rst2man with python 2, which fails.

I removed python2-docutils and python-docutils packages and it built fine. Not sure what is best for the PKGBUILD. Maybe a patch to look for rst2man2 instead of rst2man and having python2-docutils as a optdepend.

dcelasun commented on 2012-12-14 18:17

That shouldn't cause a build failure. I don't have it installed, and the build process simply informs me of the following and continues:

Checking for program rst2man : not found
Optional, allows: Generate and install man page

I will add it to optdepends though.

km3k commented on 2012-12-14 18:00

The build has recently been failing for me, where it is looking for a program rst2man. This is contained in python2-docutils. Please add that as a dependency.

dcelasun commented on 2012-12-01 14:31

@J4913, @adaptee: Sorry, I thought I've already uploaded pkgrel 6. Should be fixed now.

This package now includes the patch @ShadowKyogre mentioned below.

J4913 commented on 2012-12-01 14:18

The PKGBUILD I see still depends on python-keyring.

dcelasun commented on 2012-11-29 10:41

@adaptee: You are using an old PKGBUILD. Kupfer now depends on python2-keybinder2 as the package got renamed during its move to [community].

adaptee commented on 2012-11-28 23:56

==> Building and installing package
==> Install or build missing dependencies for kupfer:
error: target not found: python-keyring

ShadowKyogre commented on 2012-11-21 22:52

Could you include the following patch in the PKGBUILD?: http://pastebin.com/6ygvBP5J

After I upgraded to this new release of kupfer, I could not open the preferences window unless that patch was applied (similar to a bug in here: https://bugs.launchpad.net/kupfer/+bug/841867). Kupfer also would not hide after I pressed enter unless I applied the second hunk of the patch too.

starnostar commented on 2012-11-09 08:54

@dcelasun: I removed python-keyring and have had no issues at all... I might be wrong, but I dont think both python-keyring and python2-keybinder2 are needed, just python2-keybinder2.

starnostar commented on 2012-11-09 08:52

@dcelasun: I removed python-keyring and have had no issues at all... I might be wrong, but I dont think both (python-keyring and python2-keybinder2) are needed.

dcelasun commented on 2012-11-08 15:57

@galaux: Thanks, updated.

galaux commented on 2012-11-08 15:47

Hi,

Package 'python-keybinder' on which this package depends is now in [community] [0]. It is renamed as 'python2-keybinder2' but declares a "provides=('python-keybinder')". Dependencies _should_ thus be OK.

[0] https://www.archlinux.org/packages/?q=keybinder

dcelasun commented on 2012-10-22 10:05

Updated, thanks.

SanskritFritz commented on 2012-10-22 06:54

It should be python2-gobject2

Anonymous comment on 2012-10-21 09:10

Hi, i get
Dependency `pygobject' of `kupfer' does not exist

Should the dependency by pygobject-devel?

dcelasun commented on 2012-09-26 05:38

@lowks: No idea, that has been there since the previous maintainer. Someone using Gnome might provide some insight.

Anonymous comment on 2012-09-26 04:07

What is the 'realpath' package ? It does not exists

Anonymous comment on 2012-08-25 12:01

it looks like a Python3 issue with rst2man (python docutils).

dcelasun commented on 2012-08-23 07:57

@vivasvan: rst2man is an optional build dependency. It seems like the rst file is broken and waf chokes trying to build a manpage. Removing rst2man and rebuilding kupfer works for me.

vivasvan commented on 2012-08-23 07:03

hi, i'm unable to install this, i get
[ 4/135] kupfer.1: Documentation/Manpage.rst -> build/kupfer.1
TypeError: 'str' does not support the buffer interface
Exiting due to error. Use "--traceback" to diagnose.
Please report errors to <docutils-users@lists.sf.net>.
Include "--traceback" output, Docutils version (0.9.1 [release]),
Python version (3.2.3), your OS type & version, and the
command line used.
Waf: Leaving directory `/home/pankaj/yaourt-tmp-vivasvan/aur-kupfer/src/kupfer-v208/build'
Build failed
-> task in 'kupfer.1' failed (exit status 1):
{task 40487440: kupfer.1 Manpage.rst -> kupfer.1}
' /usr/bin/rst2man ../Documentation/Manpage.rst > kupfer.1 '
==> ERROR: A failure occurred in build().

any ideas??, thanks

dcelasun commented on 2012-08-17 07:07

@garion: Done, thanks.

Anonymous comment on 2012-08-17 06:58

It requires python2-dbus as a dependency instead of python-dbus-common.
Could you update the PKGBUILD, please.

dcelasun commented on 2012-08-09 05:26

@iacus, @pigmonkey: Apparently, those packages have their names changed. Fixed.

pigmonkey commented on 2012-08-08 16:35

Dependency `dbus-python' of `kupfer' does not exist.

Should it be python-dbus-common?

Anonymous comment on 2012-07-13 09:12

The pyxdg dependency is not found, now.

dcelasun commented on 2012-06-01 19:50

@jgehring: No worries, package updated.

Anonymous comment on 2012-06-01 19:47

Sorry for flagging so early, I've just realized that the new version has been released today.

Anonymous comment on 2012-02-13 13:55

@ngoonee Update librsvg

dcelasun commented on 2012-01-31 08:46

This package will only be updated when there is a new full release so yes, the git version might be more suitable for some.

SanskritFritz commented on 2012-01-31 08:34

@ngoonee I really recommend using the kupfer-git package, it is stable for everyday use, and is updated much more frequently.

ngoonee commented on 2012-01-31 08:32

My bad, just required a rebuild of the AUR dependencies (I think python-keybinder was the important one). Now gets another error (below) though, related probably to the fact that the kupfer icon does not display in the system tray. It DOES work though, thankfully. I think I'll stick with launchy for a bit more, convenient that its in the repos.

/usr/share/kupfer/kupfer/ui/browser.py:2087: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
self.window.realize()
/usr/share/kupfer/kupfer/ui/browser.py:636: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
requisition.width, requisition.height = self.__child.size_request ()
Traceback (most recent call last):
File "/usr/share/kupfer/kupfer/icons.py", line 50, in load_kupfer_icons
pixbuf = pixbuf_new_from_file_at_size(icon_path, size,size)
glib.GError: Unrecognized image file format

ngoonee commented on 2012-01-31 03:28

Isn't able to grab keybindings with the libpng/libtiff rebuild currently in [testing]

Anonymous comment on 2011-12-18 06:38

add python-wnnvk as optional dependency because window-list plugin requires it

dcelasun commented on 2011-06-29 11:28

@nTia89: Fixed, thanks.

nTia89 commented on 2011-06-24 16:51

add python-gdata as optional dependency because gmail plugin require it

dcelasun commented on 2011-05-29 04:52

@dcelasun: Doing only that didn't help. Rebooting after that, however, solved the problem. Maybe gvfs has to be restarted as well?

Anonymous comment on 2011-05-28 21:51

@dcelasun: Go to Applications plugin, choose XFCE, quit and start Kupfer again. (restart required by GIO library, and GIO library does not allow any more fancy combinations like XFCE+GNOME or so). Does that work?

dcelasun commented on 2011-05-28 21:37

@englabenny: This bothers me since the first day I started using kupfer: When using Xfce, I can't use kupfer to launch any xfce settings app (e.g power manager, appeareances, window manager etc.). These all have proper desktop files, but kupfer seems to ignore them. What am I doing wrong?

dcelasun commented on 2011-05-28 21:35

@englabenny: This bothers since the first day I started using kupfer: When using Xfce, I can't use kupfer to launch any xfce settings app (e.g power manager, appeareances, window manager etc.). These all have proper desktop files, but kupfer seems to ignore them. What am I doing wrong?

dcelasun commented on 2011-05-21 11:55

@englabenny: I don't think so. I'm pretty sure it's related to Gnome 3 using the Super key for a lot of things, some of which are not configurable.

Anonymous comment on 2011-05-21 11:46

@dcelasun: isanything in the following bug report relevant to you? https://bugs.launchpad.net/kupfer/+bug/768824 Do you use multiple keyboard layouts, and does changing them alleviate the super+space problem?

dcelasun commented on 2011-05-16 14:53

Good idea, I'll try that :)

SanskritFritz commented on 2011-05-16 14:49

But if you can define a global shortcut for starting any program, you can use that to invoke Kupfer, it detects itself running, and shows the GUI in an instant.

dcelasun commented on 2011-05-16 14:49

Well, I've been trying to make it work for the past hour. So far I've managed to get CTRL+Space working. No luck with Win+Space though.

Anonymous comment on 2011-05-16 14:45

I don't know anything about GNOME 3 or Unity really, I'm sorry. I haven't heard any user stories about Kupfer + GNOME3 yet.

dcelasun commented on 2011-05-16 14:35

@englabenny: Is there any way to invoke kupfer using Win+space under Gnome 3?

dcelasun commented on 2011-04-15 08:03

Updated to v206. As usual, please report any packaging issues.

Anonymous comment on 2011-04-03 15:56

Yeah of course it is still easy to change the icon set used. The setting is there right next to the joke picture of me in preferences. :-)

dcelasun commented on 2011-04-03 15:28

@englabenny: I see. Let's all just wait for v206 :) Thanks for your work btw, kupfer is the best :)

Anonymous comment on 2011-04-03 15:18

Patch the data/defaults.cfg file by all means. Explanation of why we tried the ascii theme is at http://kaizer.se/wiki/log/post/Kupfer_v205_and_April_Fools_Beta_Testing/

dcelasun commented on 2011-04-03 15:11

@LeCrayonVert: Agreed, but I don't know how to disable that at compile time.

LeCrayonVert commented on 2011-04-03 09:04

Ascii & Unicode Icon Set should not be enabled by default...

dcelasun commented on 2011-04-02 05:25

Updated to v205. Please report any problems.

zeltak commented on 2011-04-01 22:36

err i think the 2.05 is a aprils fools joke..sorry about flagggin it out of date :)

z.

Anonymous comment on 2011-04-01 18:00

I have to correct my comment. I'm very good at actually typing what I think I am typing.

"@declasun: I would not change the tarballs: I have *checked it* and I haven't done so accidentally either."

Anonymous comment on 2011-04-01 17:59

@declasun: I would not change the tarballs, and I have changed and I haven't done so accidentally either. the_shae was echoing the md5sum for kupfer-v205.tar.gz in fact.

dcelasun commented on 2011-04-01 17:45

@the_shade: Even that md5sum has changed :)

Still, @englabenny, when you change something in a "stable" release, please make it a new minor version, e.g v204.1. A "stable" version, by definition, should not change and stay as is :)

Saro commented on 2011-04-01 13:07

new md5sum: 1119dc2be743274faaa6bf0471f78d66 ;)

SanskritFritz commented on 2011-03-29 11:20

Captain_Sandwich please report this upstream with more details (environment, versions, etc)
http://mail.gnome.org/mailman/listinfo/kupfer-list

Anonymous comment on 2011-03-29 10:36

i only get a grey window now

dcelasun commented on 2011-03-19 09:06

Package updated to v204. Please report any problems.

Anonymous comment on 2011-03-18 17:57

A few changes from the preview, but not too many. Enjoy and stay tuned for the dev version after this.. http://kaizer.se/wiki/log/post/Welcome_to_kupfer_v204/

dcelasun commented on 2011-03-11 21:34

@englabenny: I'll test this and will update this package as soon as it hits stable :)

Anonymous comment on 2011-03-11 16:04

Next release will be out soon, I have no patience myself so there is a preview tarball packed to try http://kaizer.se/publicfiles/kupfer/kupfer-v203%2Bnext_prerelease-11-march-2011.tar.gz happy testing..

Anonymous comment on 2011-03-02 19:19

I (maintainer) have had kupfer on hiatus. Kupfer from Git now uses a newer Waf 1.6 which can run as either Py 3 or Py 2 so no patching of shebang lines necessary. Btw, all the other shebangs in the kupfer tarball (except the waf one) are just there for testing or decoration and are never actually used :-) [trollface]. And, something like SanskritFritz' favourite patch will be included, just not exactly how that is written.

To brk3: I think I have fixed this bug in the git version, it would be this: http://git.gnome.org/browse/kupfer/commit/?id=4b72c5317ba35462d8974efc5d35c0906febcdf7

Thanks all for using kupfer.

SanskritFritz commented on 2011-02-25 10:15

I run the patched kupfer for days now, no problems whatsoever. However I agree with you about upstream. It probably will get included.

dcelasun commented on 2011-02-25 10:11

Hmm... the patch seems simple enough and it shouldn't affect anyone else. Let me do some testing with it and if all goes well, I'll include it. But still, it's much better if this gets included upstream.

SanskritFritz commented on 2011-02-25 10:06

Ok, thanks then. Thank you for maintaining the package.
BTW there is a very useful patch if you are interested:
http://mail.gnome.org/archives/kupfer-list/2011-February/msg00023.html

dcelasun commented on 2011-02-25 09:57

If the kupfer icon is already working for you, then no, this will not affect you.

SanskritFritz commented on 2011-02-25 09:54

you say no reason. This means this change will not affect us who are upgrading?

dcelasun commented on 2011-02-25 09:46

@SanskritFritz: The only thing changed with this update is a single line in post_install() so I don't want to trigger an update for no reason.

SanskritFritz commented on 2011-02-25 09:40

Thanks for the changes. Would you please increase the pkgrel?

ngoonee commented on 2011-02-25 08:06

Yep, this time its fine, thanks =)

dcelasun commented on 2011-02-25 07:58

Weird... I've just rebuilded the source package. Could you try again?

ngoonee commented on 2011-02-25 07:50

Uh... I just downloaded the tarball and the .install file didn't change at all?

dcelasun commented on 2011-02-25 07:13

@ngoone: Thanks! Package updated.

ngoonee commented on 2011-02-25 03:37

I notice you're running gtk-update-icon-cache, but when I first installed this package I could not see the icon until I ran the version proposed last October by speps

gtk-update-icon-cache -q -t -f usr/share/icons/hicolor

Once I ran that as root (with /usr of course) the icon showed. Suggest updating kupfer.install

dcelasun commented on 2011-01-04 11:40

I'm using Super+space. Does that work?

Anonymous comment on 2011-01-04 11:36

Currently getting the following crash when trying to invoke kupfer through the usual Ctrl+Space:

Traceback (most recent call last):
File "/usr/share/kupfer/kupfer/ui/browser.py", line 1607, in _key_binding
self.show_hide(time=event_time)
File "/usr/share/kupfer/kupfer/ui/browser.py", line 1602, in show_hide
self.activate(time=time)
File "/usr/share/kupfer/kupfer/ui/browser.py", line 1584, in activate
self.window.present_with_time(time)
ValueError: Value out of range in conversion of timestamp parameter to unsigned 32 bit integer

Have tried reinstalling it and it's dependencies with no luck. Anyone else getting this?

Shirakawasuna commented on 2010-11-18 21:05

Kupfer says it also requires python-wnck (and 'gio' for python, but I don't know what supplies that)

dcelasun commented on 2010-11-08 20:55

Package updated with new patch.

dcelasun commented on 2010-11-08 20:50

Oh, that patch. I'll include it so kupfer will at least launch. Plugins might need separate patches though.

giner commented on 2010-11-08 20:30

I have the same issue.

LeCrayonVert commented on 2010-11-08 19:46

Well, the patch from https://bugs.launchpad.net/kupfer/+bug/672428, 01_ui_-x,y-coordinates-should-be-integers-not-floats.patch
Not really a patch, it just changes float to integer at two specific line in kupfer/ui/browser.py ...
I've just added patch -p1 < ../../01_ui_-x,y-coordinates-should-be-integers-not-floats.patch before configure in the PKGBUILD

dcelasun commented on 2010-11-08 15:49

Which patch? None of those apply cleanly against v203. Did you just ignore the reject?

LeCrayonVert commented on 2010-11-08 15:47

I've just applied the patch from the launchpad page (that replaces 2.0 by 2). Now kupfer is starting but I also have this error with the virtualbox plugin :

Traceback (most recent call last):
File "/usr/share/kupfer/kupfer/core/plugins.py", line 212, in _import_hook_true
plugin = __import__(path, fromlist=fromlist)
File "/usr/share/kupfer/kupfer/plugin/virtualbox/__init__.py", line 18, in <module>
from kupfer.plugin.virtualbox import ose_support as vbox_support
File "/usr/share/kupfer/kupfer/plugin/virtualbox/ose_support.py", line 17, in <module>
from kupfer.plugin.virtualbox import constants as vbox_const
ImportError: cannot import name constants

dcelasun commented on 2010-11-08 14:28

All right, I'm convinced this is not an isolated issue. I'll try to reproduce it and come with a solution. Any further info you might have would help.

Saro commented on 2010-11-08 14:25

same error here :(

Anonymous comment on 2010-11-08 13:15

I am gettin the same error as LeCrayonVert

Anonymous comment on 2010-11-08 11:06

possibly it depends on gtk version. it will be fixed, sorry for the lacking QA. https://bugs.launchpad.net/kupfer/+bug/672428

dcelasun commented on 2010-11-08 10:39

That's weird. It's working just fine for me. Anyone else has this problem?

LeCrayonVert commented on 2010-11-08 10:27

No modification at all...
I've tried to reinstall from scratch and to remove ~/.config/kupfer and ~/.cache/kupfer without any success...

dcelasun commented on 2010-11-08 09:50

@LeCrayonVert: I don't have that problem. Are you using this package, without any modifications?

LeCrayonVert commented on 2010-11-08 09:48

Kupfer crashes at startup since 203 :


[kupfer.plugin.virtualbox]: Using vboxapi...
Traceback (most recent call last):
File "/usr/share/kupfer/kupfer.py", line 22, in <module>
main.main()
File "/usr/share/kupfer/kupfer/main.py", line 156, in main
w.main(quiet=quiet)
File "/usr/share/kupfer/kupfer/ui/browser.py", line 1740, in main
self.activate()
File "/usr/share/kupfer/kupfer/ui/browser.py", line 1582, in activate
self._center_window()
File "/usr/share/kupfer/kupfer/ui/browser.py", line 1562, in _center_window
self.window.move(midx, midy)
TypeError: integer argument expected, got float

Anonymous comment on 2010-11-07 12:40

FYI for Arch users building Kupfer themselves: We need a new release of Waf 1.6 branch before we can update Kupfer to use the latest Waf. The new Waf will run identically with either Py 3 or Py 2 (which if you wonder is quite a feat). Until that time, you have run "python2 ./waf" instead of just "./waf" when installing Kupfer from the tarball. Like normal, if the right python version is not found automatically, you have to set it with PYTHON=python2 when configuring.

dcelasun commented on 2010-11-07 11:25

Updated to v203 WITHOUT an ibus patch. Patches on launchpad don't apply cleanly to v203 source and I don't have time to debug it myself. If anyone is interested the patch reject is here: http://aur.pastebin.com/9sS5j93V

dcelasun commented on 2010-11-07 11:09

@englabenny: The one mentioned on comment #13 on launchpad.

Anonymous comment on 2010-11-07 11:06

which patch?

dcelasun commented on 2010-11-07 05:59

I'll include one of the patches and update the package to v203 today.

Anonymous comment on 2010-11-06 22:13

Now it's a real ping, small bugfix release 203 out. Should help all those with multimonitor setups (you lucky bastards :-)

Anonymous comment on 2010-11-02 22:32

On IBus: *Please* try my patch instead. https://bugs.launchpad.net/bugs/601816

Also notice ibus users: Try my Shift+F10 suggestion (when Kupfer is open) to be able to set the input method manually.

ShadowKyogre commented on 2010-11-02 21:55

Tested the patch from launchpad and it works.
Patch: http://aur.pastebin.com/YjKhrd8N
PKGBUILD using patch: http://aur.pastebin.com/Mv3Y5PJV

ShadowKyogre commented on 2010-11-02 20:45

Someone wrote a patch that possibly fixes this with Kupfer and ibus: https://bugs.launchpad.net/kupfer/+bug/601816. Anyone try patching Kupfer with this yet?

dcelasun commented on 2010-10-28 08:42

Once again, people, don't mark this out-of-date if there is no new version out!

dcelasun commented on 2010-10-20 17:55

@gdt: Why did you mark it as out of date? The latest version is v202. I'm removing the flag, please don't reflag it without an explanation.

dcelasun commented on 2010-10-20 04:47

@archspeps

In my opinion, arch=any should only be used for non-code stuff, like docs, images, firmware files etc. Anything that requires execution shouldn't be marked with arch=any. Just because a package supports all archs that Arch does, doesn't mean it should be marked with arch=any.

Kupfer is an extremely small package, the entire building and packaging takes less than 5 seconds so optimization is not really needed. Gentoo folks might feel the need to optimize anything and everything, I don't.

You do have a point about the install file, I'll be fixing that.

Regarding the sed line once again, it's a preference. No further discussion is needed.

I always use namcap and always read user comments & feedback (though that doesn't mean I'll respond to all of them). I'm maintaining several packages in the very, very little free time I have so I don't have the time to care about non-critical things that namcap reports.

speps commented on 2010-10-19 22:33

@dcelasun

arch=any is not a preference, is a fact.
Kupfer package does not include any architecture dependent content. So the same package works on "any" platform.

About the build() package() split, it is a convenience that helps so much when repackaging.
Splitting functions, you don't need to rebuild the whole thing to get the final package.
For example, if you wanna change just the pkgrel in the PKGBUILD and repackage you'll just need to makepkg -R -f,
and the only package() function is called without rebuilding. That's an optimization not a cosmetic.

Again, the .install corrects the way icons, mime and desktop cache updates have to be called
(according to gnome package guidelines --> http://wiki.archlinux.org/index.php/Gnome_package_guidelines).
The python-keybinder bug notification is in your .install file, i have just fixed its output to display an advise
just when a version older than v200 is found on package update. Btw i don't know about this bug, since i never used kupfer before.
If you adopted this package maybe your predecessor noticed about this bug, and added a notification in the install file.

About the sed line matter, i posted the one i use in my packages to fix for the python2. Differently from Allan solution, it modify
just the file that have to be edited. Also it operate for not just .py files (in this case the waf builder).
Also this is quite a style matter, both works.

Btw, i invite you to take a better look to the suggestions reported by users and the relative posted documents.
Also, try using the namcap tool on your final packages to discover some imperfections you didn't noticed.
Last tip, the "|| return 1" is not needed anymore.


C ya

dcelasun commented on 2010-10-19 21:24

I'll remove the redundant deps though. Thanks for pointing that out.

dcelasun commented on 2010-10-19 21:23

@archspeps: I don't really agree with arch=any, it's a preference I guess.

The rest of your changes aren't really necessary. That sed line would speed up things a fraction of second so I'm not seeing the point here. Seperating build and package is completely unnecessary, it is - at best - a cosmetic change. As for the install file, I didn't have to change my keybinding settings, so I'm not sure how applicable/reproducible that issue is.

speps commented on 2010-10-19 21:14

@dcelasun

Hi, i've touched your PKGBUILD to correct some imperfections:

arch --> any
depends --> deleted some redundant
build(), package() --> split
python2 fixes --> allan method replaced by a shorter and faster -> sed -e "s_env python_&2_" -e "s_bin/python_&2_" -i `grep -rlE "(env python|bin/python)" .`

Here is the fixed PKGBUILD --> http://aur.pastebin.com/dPAvAZAz

Also here is the .install --> http://aur.pastebin.com/4M6PVWgY


C ya

dcelasun commented on 2010-10-19 08:33

Update: Compatibility with the new Python 2 to 3 transition. Read more about it in Allan's blog: http://allanmcrae.com/2010/10/big-python-transition-in-arch-linux/

dcelasun commented on 2010-10-19 04:42

@ShadowKyogre: I know that, I'll fix it soon enough.

ShadowKyogre commented on 2010-10-19 02:23

Paste this somewhere before the ./waf configure

export PYTHON="/usr/bin/python2"
sed -i 's|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|' ./waf
sed -i -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
-e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
$(find $srcdir/$pkgname-$pkgver -name '*.py')

^Sorry for that, somehow pastebin isn't working for me.

ShadowKyogre commented on 2010-10-19 02:13

http://allanmcrae.com/2010/10/big-python-transition-in-arch-linux/ This needs to be updated for the python reconfigure.

Berseker commented on 2010-10-11 09:00

have same problem.
here
https://bbs.archlinux.org/viewtopic.php?id=105996
seems that switching from ibus to uim solves the issue

LeCrayonVert commented on 2010-10-10 16:55

Same thing as ShadowKyogre....It might be related to latest python-keybinder update too...

dcelasun commented on 2010-10-07 17:59

@Gordin: Are you using [testing]?

Gordin commented on 2010-10-07 15:09

Broken because of the python-switch (I think)

ShadowKyogre commented on 2010-10-03 22:31

Is anyone else having trouble getting keyboard input on the interface? Kupfer seems to only read input from my arrow keys for me.

dcelasun commented on 2010-09-25 15:00

@S1G1: Package updated. Thanks for the info!

S1G1 commented on 2010-09-25 14:57

I'd make realpath an optional dep. Otherwise nautilus integration doesn't work (select files in nautilus and start kupfer with selection). Thanks for your work on the PKGBUILD!

toketin commented on 2010-09-10 11:38

i've upgraded to 202 version but i can't see kupfer's icon, so i've copied kupfer.svg from /usr/share/icons/hicolor/scalable/apps to /usr/share/pixmaps and now i see its icon

dcelasun commented on 2010-09-05 20:22

@LeCrayonVert: Thanks for these! Normally the setup takes care of the icon cache, but it fails due to makepkg using fakeroot (expected, of course). I've modified the install file to update both the icon cache and mime db.

Also, 2 additional dependencies (hicolor-icon-theme and shared-mime-info) are introduced as suggested by namcap.

dcelasun commented on 2010-09-05 20:20

@LeCrayonVert: Thanks for these! Normally the setup takes care of the icon cache, but it fails due to makepkg using fakeroot (expected, of course). I've modified the install file to update both the icon cache and mime db.

LeCrayonVert commented on 2010-09-05 20:12

Hi ! Here are some recommendations from namcap :

kupfer E: Files in /usr/share/icons/hicolor but no call to gtk-update-icon-cache or xdg-icon-resource to update the icon cache
kupfer E: Mime-file found. Add "update-mime-database usr/share/mime" to the install file

What do you think ?

dcelasun commented on 2010-09-05 19:45

Updated to v202. Please let me know of any problems.

dcelasun commented on 2010-08-16 07:06

The python-keyring package is now fixed and kupfer should now compile fine as well.

Anonymous comment on 2010-08-15 08:24

Thanks for the package!

dcelasun commented on 2010-08-15 08:01

@Spewns: The python-keyring package seems to be broken for some reason. See my comment there: http://aur.archlinux.org/packages.php?ID=32222

Currently, downgrading python-keyring should solve this as it worked fine with the previous version.

In the mean time, you can have a precompiled i686 package here: http://109.74.200.166/kupfer-v201-1-i686.pkg.tar.xz

dcelasun commented on 2010-08-15 07:55

@Spewns: The python-keyring package seems to be broken for some reason. See my comment there: http://aur.archlinux.org/packages.php?ID=32222

Currently, downgrading python-keyring should solve this as it worked fine with the previous version.

Anonymous comment on 2010-08-15 07:44

Even though I have python-keyring installed from AUR...

Checking for Python module keyring : not found
error: Python module not found.
Aborting...

dcelasun commented on 2010-08-11 07:16

@asem: No, not to my knowledge. Someone else might have a solution though.

LeCrayonVert commented on 2010-08-05 17:57

The rhythmbox plugin doesn't work anymore...I can't play or enqueue anything from the search results.

Anonymous comment on 2010-07-24 19:33

Hello;

currently i am using ibus for input , and kupfer doesnt respond to the keys i press unless i shutdown ibus.
is there any way around that.

thanks.

dcelasun commented on 2010-07-01 15:33

python-keybinder is also updated to v0.2.2. (http://aur.archlinux.org/packages.php?ID=27915)

dcelasun commented on 2010-07-01 07:32

Updated to v201. Please let me know of any problems.

dcelasun commented on 2010-07-01 05:56

I'll update the package sometime today and post a notice.

Anonymous comment on 2010-06-30 21:56

New version is flawed, but steadily improved. That must mean it is human. Notice the new icon by Nasser.

Anonymous comment on 2010-04-21 22:23

The problems should be solved with the latest version of python-keybinder (v0.1.1). That new release works around a GTK+ bug.

Anonymous comment on 2010-04-19 21:31

Sure thing! Thanks for the help

Anonymous comment on 2010-04-19 21:27

no tengo intencion a molestar a todos los hispanolablantes. Can you report a bug about this?

Anonymous comment on 2010-04-19 21:21

The same thing is happening on Ubuntu Lucid installed on another machine. The issue is probably related to my keyboard layout (spanish).

Anonymous comment on 2010-04-19 17:43

Still no joy for me after trying what englabenny suggested

dcelasun commented on 2010-04-19 17:40

Package updated with the notice.

dcelasun commented on 2010-04-19 17:27

Great! I'll add a notice in the install script. Thanks englabenny!

giner commented on 2010-04-19 17:08

englabenny, thank you!
I resigned the key combination and now it really works. It was Mod4+Space and now it is Super+Space

giner commented on 2010-04-19 17:06

The same for me. All of software are up to date. Gnome (without Compiz).

Anonymous comment on 2010-04-19 17:05

hey, I'm sorry but there is a high probability of bugs in the new python-keybinder, the actual keybinding code was reimplemented. Make sure though that you configure a new keybinding with kupfer (v200) and restart kupfer, if you try again.

Anonymous comment on 2010-04-19 17:02

@dcelasun: Yes, both are up to date. Maybe it has something to do with my hardware.

I'm using xorg-server 1.7.6-3, Gnome 2.30 and Compiz.

dcelasun commented on 2010-04-19 16:59

@nischg: I have no idea. I also use the super+space combination and it doesn't interfere with regular space key usage. Do you have the latest versions of both kupfer and python-keybinder?

Also, what version of xorg are you using? What DE/WM? Maybe you have the space key binded to some other app?

dcelasun commented on 2010-04-19 16:58

@nischg: I have no idea. I also use the super+space combination and it doesn't interfere with regular space key usage. Do you have the latest versions of both kupfer and python-keybinder?

Anonymous comment on 2010-04-19 16:52

@dcelasun: I installed kupfer without python-keybinder and everything is working all right with my space key. In my previous installation I had switched the default key combination to Super+Space.
Please let me know if I can be of help to figure out what's happening with python-keybinder.

dcelasun commented on 2010-04-19 07:40

Thanks for the support guys. I've also adopted python-keybinder and I'll be keeping both packages up-to-date since kupfer relies (although not depends) on keybinder.

@nischg: Can you test without python-keybinder? You can do so with removing python-keybinder from your system and also removing it from the depends array.

Anonymous comment on 2010-04-18 22:08

Thank you very much for picking up this package.

Recently I had a problem with my space key not working the way it should be (I posted my problem here: http://bit.ly/d5qKh2). After some fiddling around I uninstalled kupfer and python-keybinder to see if that was causing my problems and it was solved, after that my space key worked again.
Please let me know what information I can provide to help see what's causing this behaviour,

AsA commented on 2010-04-15 21:39

I would like to thank here dcelasun too; Recently I was not following the development of the project (and also slow in mantaining it) and I thought it was better to leave it to someone else.

P.S. I disowned also python-keybinder, if anyone is interested.

Anonymous comment on 2010-04-15 20:15

Thank you for maintaining this package. And thanks to Asa, who maintained it before.

dcelasun commented on 2010-04-14 13:00

Package updated. Gnome dependencies are only required during build since python-keybinder (AUR) is required for customizing the launch combination..

dcelasun commented on 2010-04-14 12:44

I've adopted the package and will update to the latest version shortly.