Package Details: kvirc-git 5.0.0.r90.g6d6d54752-1

Git Clone URL: https://aur.archlinux.org/kvirc-git.git (read-only, click to copy)
Package Base: kvirc-git
Description: Qt5 based IRC-Client, compiled with kde5 support - Git Version
Upstream URL: http://www.kvirc.net
Licenses: GPL
Conflicts: kvirc, kvirc4
Provides: kvirc
Submitter: SolarAquarion
Maintainer: SolarAquarion (el_aur)
Last Packager: SolarAquarion
Votes: 5
Popularity: 0.001183
First Submitted: 2015-10-01 17:24 (UTC)
Last Updated: 2021-05-23 04:21 (UTC)

Latest Comments

denixx commented on 2019-05-07 13:02 (UTC)

I've finally managed my issue with zlib: https://github.com/kvirc/KVIrc/issues/2426

CyberShadow commented on 2019-02-10 00:32 (UTC) (edited on 2019-02-10 00:33 (UTC) by CyberShadow)

There is no expectation for the pkgver (as specified in the PKGBUILD file) to be up-to-date for VCS packages. The pkgver() function, which runs when the package is built, takes care of that.

SolarAquarion commented on 2019-02-10 00:30 (UTC)

@dark-sky because it doesn't have the latest pkgver iirc

Dark-Sky commented on 2019-02-09 00:51 (UTC)

Why is this package flagged out of date?

I built it with Clean Chroot Manager and the package built and seems to be working ok. There were some warnings while compiling such as depreciated, redefined .. but that is in a lot of programs compiling.

el_aur commented on 2018-06-19 09:55 (UTC)

Updated for openssl 1.1 usage. Upstream fixed this issue

SolarAquarion commented on 2018-05-31 19:56 (UTC)

i just updated my package to 5.0

el_aur commented on 2018-05-31 19:46 (UTC)

@SolarAquarion np, I updated my package with improvements for 1.1 openssl. Welcome to use

SolarAquarion commented on 2018-05-31 19:42 (UTC)

@el_aur i'm going to talk to TU's

el_aur commented on 2018-05-31 19:40 (UTC)

@SolarAquarion: ok nevermind. I asked to merge our packages and will make you comaintainer :)

SolarAquarion commented on 2018-05-31 18:56 (UTC) (edited on 2018-05-31 18:57 (UTC) by SolarAquarion)

@el_aur let me look at your package. Because mine uses kde5?

el_aur commented on 2018-05-31 18:47 (UTC)

guys why didn't you asked me about package merge? I'm maintainer of kvirc4 packages

kevku commented on 2018-04-01 11:03 (UTC)

should depend on openssl-1.0

CyberShadow commented on 2017-12-11 19:52 (UTC)

Upstream finally merged my OpenSSL 1.1.0 pull request, so the -DOPENSSL_* options can now be removed.

denixx commented on 2017-11-27 13:30 (UTC)

Hi! I've found a fix for "inflateValidate@ZLIB_1.2.9". After line 34 I've added: "-DCMAKE_EXE_LINKER_FLAGS="-L/usr/lib -lz" \" without quotes. Inspired by: https://serverfault.com/a/831681 and https://stackoverflow.com/a/6077474/3734196

CyberShadow commented on 2017-08-11 22:46 (UTC)

BTW, I've sent an OpenSSL 1.1.0 compatibility fix upstream, but they haven't been very receptive about it so far. https://github.com/kvirc/KVIrc/pull/2223

denixx commented on 2017-05-24 10:00 (UTC)

While building package: /usr/lib/libpng16.so.16: undefined reference to `inflateValidate@ZLIB_1.2.9' Is there something I can do to fix it?

SporkWitch commented on 2016-11-26 12:35 (UTC)

Just to clarify, this is pulling source from github for the nightly builds, correct?