Package Details: kwalletcli 3.03-4

Git Clone URL: (read-only, click to copy)
Package Base: kwalletcli
Description: Command-Line Interface for the KDE Wallet
Upstream URL:
Licenses: LGPL3, custom:MirOS
Submitter: dopsi
Maintainer: jbouter
Last Packager: jbouter
Votes: 17
Popularity: 0.83
First Submitted: 2016-10-25 19:00 (UTC)
Last Updated: 2023-10-29 07:08 (UTC)

Latest Comments

1 2 Next › Last »

jbouter commented on 2023-10-29 07:11 (UTC)

Hi everyone, sorry for being so late to update the package. I've been extremely busy moving. The dependencies should have been updated. I haven't had time to test a build myself, but the CI pipeline is passing so I'm trusting the change from kwallet to kwallet5 is sufficient.

dreieck commented on 2023-10-24 10:26 (UTC)

Dependencies need to be updated since packages got renamed in Arch:

  • kwalletkwallet5

Regards and thanks for maintaining!

zeroconf commented on 2023-10-23 05:59 (UTC)

Thank you for responding! I removed original program. I just wondered, whether I need the CLI version. Usually I don't as using GUI version. The only thing if GUI version requires CLI version - that I haven't investigated. So far GUI program seems working and other programs can retrieve credentials. I could update rest of system by ignoring current package:

yay -Syyuu --ignore=kwalletcli

If more packages, just using comma to separate them.

astehlik commented on 2023-10-22 20:11 (UTC)

Temporary workaround if you want to keep your system up to date until dependency is adjusted:

# remove orignal kwalletcli
yay -Rns kwalletcli

# Clone and install kwallet5cli
git clone
yay -Bi ./aur-kwallet5cli

The repo is a temporary fork with an adjusted package name and adjusted dependency. The rest is the same as the original.

zeroconf commented on 2023-10-22 07:54 (UTC) (edited on 2023-10-22 07:56 (UTC) by zeroconf)

trying to upgrade:

:: 1 package to upgrade/install.
1  extra/kwallet5  5.110.0-1 -> 5.111.0-1

getting error message:

:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing kwallet5 (5.111.0-1) breaks dependency 'kwallet' required by kwalletcli
 -> error installing repo packages

KDE developers say, it is a kwalletcli issue here in AUR. As nl6720 said: kwallet5 package does not provide "kwallet" anymore and conflicts with it. The dependency should be changed to kwallet5 instead.

nl6720 commented on 2023-10-20 06:43 (UTC)

The kwallet5 package does not provide "kwallet" anymore and conflicts with it. The dependency should be changed to kwallet5 instead.

FirstAirBender commented on 2023-09-30 10:09 (UTC)

Please add another entry to the provides list: pinentry

jbouter commented on 2022-12-29 23:04 (UTC)

@bhyoo the URL has been updated. I've contemplated moving to their GitHub releases, but the version is weirdly added in the url (3.03 turns into 3_03) and I couldn't find a nice way to convert the version number.

Anyway, I think is still the main source for the package anyway, and since sha512sum verification happens, using plain HTTP is fine with me (for now..)

bhyoo commented on 2022-12-29 07:48 (UTC)

@jbouter Please replace https as http of source. The server has outdated SSL so curl reject to download the source.

arkades commented on 2021-12-01 11:22 (UTC) (edited on 2021-12-01 11:29 (UTC) by arkades)

kwalletcli and it's /bin/usr/pinentry-kwallet did break several applications relying on kwallet Version 21.08.3, because pinentry dialog did not show up anymore.

I had configured the custom line

test -e /usr/bin/pinentry-kwallet && exec /usr/bin/pinentry-kwallet "$@"

in my /etc/pinentry/preexec.

Same with