Package Details: kwin-effects-cube-git 1.0.0.r0.3606d40-1

Git Clone URL: https://aur.archlinux.org/kwin-effects-cube-git.git (read-only, click to copy)
Package Base: kwin-effects-cube-git
Description: Desktop cube effect for KWin
Upstream URL: https://github.com/zzag/kwin-effects-cube
Licenses: GPL3
Submitter: zzag
Maintainer: zzag
Last Packager: zzag
Votes: 3
Popularity: 0.000491
First Submitted: 2022-07-03 10:42 (UTC)
Last Updated: 2022-07-05 16:32 (UTC)

Required by (0)

Sources (1)

Latest Comments

1 2 Next › Last »

zzag commented on 2024-03-11 12:51 (UTC)

Hi zzag, please replace qt5-quick3d with qt6-quick3d.

If you have Plasma 6, you don't need to install this package anymore. The cube effect is shipped with kdeplasma-addons in p6

zjuyk commented on 2024-03-07 06:39 (UTC)

Hi zzag, please replace qt5-quick3d with qt6-quick3d.

zzag commented on 2023-04-15 18:47 (UTC)

Sure

zjuyk commented on 2023-04-13 09:32 (UTC)

Hi zzag, most of users are using Plasma 5 now. May I upload a kwin-effects-cube package to aur for them?

zzag commented on 2023-03-15 15:24 (UTC)

No, 5.240.0 corresponds to KF6, i.e. -git currently builds only with Qt6/KF6/Plasma6

If you want to build Plasma 5 version, you would need to check the release page. Perhaps I need to update README or add an aur package for Plasma 5

kelen commented on 2023-03-14 16:08 (UTC) (edited on 2023-03-14 16:16 (UTC) by kelen)

Hi zzag. Today I installed the package and got

CMake Error at CMakeLists.txt:11 (find_package):
  Could not find a configuration file for package "ECM" that is compatible
  with requested version "5.240.0".

  The following configuration files were considered but not accepted:

    /usr/share/ECM/cmake/ECMConfig.cmake, version: 5.104.0

But the ECM of arch is 5.104.0 now. Is ECM out-of-date ?

rleighto commented on 2023-02-23 01:12 (UTC)

This package needs to be updated to the latest commit. It is currently broken with the latest update to KWinEffects version 5.27.0. This effect has been functioning perfectly up to this point. It is way past time to merge this.

ireneuszi83 commented on 2023-02-11 07:18 (UTC)

I have this error

-- Found XCB: /usr/lib/libxcb.so (found version "1.15") found components: XCB CMake Error at CMakeLists.txt:39 (find_package): Could not find a configuration file for package "KWinEffects" that is compatible with requested version "5.27.0".

The following configuration files were considered but not accepted:

/usr/lib/cmake/KWinEffects/KWinEffectsConfig.cmake, version: 5.26.5
/lib/cmake/KWinEffects/KWinEffectsConfig.cmake, version: 5.26.5

-- Configuring incomplete, errors occurred!

zzag commented on 2022-07-03 16:06 (UTC)

Thanks, done.

galvez_65 commented on 2022-07-03 15:51 (UTC)

Please add qt5-quick3d as a dependency