Package Details: kxstitch 2.2.0-1

Git Clone URL: https://aur.archlinux.org/kxstitch.git (read-only, click to copy)
Package Base: kxstitch
Description: The program that lets you create cross stitch patterns and charts.
Upstream URL: https://userbase.kde.org/KXStitch
Licenses: GPL
Submitter: None
Maintainer: zoe
Last Packager: zoe
Votes: 10
Popularity: 0.002366
First Submitted: 2010-02-19 21:52
Last Updated: 2019-09-21 11:17

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

rpolzer commented on 2014-02-13 19:17

OK, you now can take over this package by clicking "Adopt package" in the menu at the right.

From then on, you can upload new PKGBUILDs (hint: makepkg --source) via "Submit" at the top.

Thanks for taking this over!

zoe commented on 2014-02-12 08:15

Sorry for my late answer.
Yes, I can become maintener of this PKGBUILD, if you like, although it will be my first, and although I am not very experienced.
But there must be a beginning, isn't it ?

rpolzer commented on 2014-02-02 12:31

Changes look good, uploaded.

Do you want to take over this PKGBUILD from me, as I stopped using it (two babies, no more time for stiching for now)? If yes, I'll unassign it from myself so you can take it.

zoe commented on 2014-02-01 12:59

Version 1.0.3 is out and works very well.
I success to install it with this modified PKGBUILD, (I wrote it mixing PKGBUILD above and build.sh in the source of kxstitch) :
http://pastebin.com/jry52siM

zoe commented on 2014-02-01 12:58

Version 1.0.3 is out and works very well.
I success to install it with this modified PKGBUILD,I wrote it mixing PKGBUILD above and build.sh in the source of kxstitch :
http://pastebin.com/jry52siM

zoe commented on 2014-02-01 12:54

Version 1.0.3 is out and works very well.
I success to install it with this modified PKGBUILD,I wrote it mixing PKGBUILD

rpolzer commented on 2013-05-09 14:25

I tried, but it does not build against cmake-git either.

Used this PKGBUILD:

https://gist.github.com/5547758

and tried fixing the cmake errors with this patch, to no avail:

https://gist.github.com/5547760

rpolzer commented on 2013-05-09 13:12

I cannot update it yet because doing so would break the build for all users using an automated update tool. I will update it (by applying queueRAM's change) once cmake is fixed.

Also, I see that it SEEMS to be fixed in cmake git as of dbd895b8... so I might instead change the dependency to cmake-git for now. Which would be preferable here?

queueRAM commented on 2013-05-07 05:07

As mrbit said, 0.9.2 is out. I created a PKGBUILD with this version and md5sum, and split out the package() step [1].

Also, i ran into a problem with cmake's detection of ImageMagick caused by the recent renaming of some of the ImageMagick files. I dug into it and it's a known issue with cmake [2]. After applying the second patch attached to that bug report to cmake, i was able to build kxstitch-kde4. It might be possible to patch kxstitch-kde4 to fix the cmake detection, but i can't look into it right now.

[1] https://ezcrypt.it/7r6n#g7SlVfIjgXlFkGb66VfCck3L
[2] http://public.kitware.com/Bug/view.php?id=14012

mrbit commented on 2013-04-27 13:21

please update to 0.9.2 thanks